Solved

VideoCD not playing properly (hard!)

Posted on 1998-10-31
15
226 Views
Last Modified: 2010-04-27
I am trying to play a videoCD with my AOpen-mtrp-924E CDROM drive and my computer can't seem to read the stream properly (very slow read, jerky image & sound, mpeg software hangs after a while).

My computer is P2-233 (Vision motherboard - intel chipset), the CDROM (IDE) is connected as secondary master (alone), and I am using win95. (standard atapi compatible driver as recomended by the manufacturer)

I already tried the CDROM as primary slave, and even tried a different CDROM drive (Toshiba XM-6102B) with the same results! which leads me to think that it's not the CD itself but rather something to do with the board/IDE.

Both CD's are supposed to support CD-I format.
I used several MPEG reading softwares to try to read the VCD with the same results.

On a friend's computer, the same CD plays fine (it's not a "badly burnt CD" ;-)

I even tried reading it with Linux special drivers with the same results :-(

Any suggestions?
0
Comment
Question by:ofer052997
  • 5
  • 5
  • 3
  • +2
15 Comments
 
LVL 6

Expert Comment

by:joopv
ID: 1128104
What kind of video card are you using ?  And what operating system ?

The performance of movie playback is very dependent of the video hardware and drivers.  Try going back to 256 colors (8 bits/pixel).  Does this improve things ?

What is the data transfer rate you get when coping a file from the cdrom drive ?  Measure it with a watch while copying a large file to hard disk or better, to the null device.
In a dos box :
copy /b blabla.dat nul:
Time this operation (use a large file, the .dat file of you video cd for example) and calculate the dataxfer rate.

Another hint : stop all programs not absolutely nessecary.

0
 

Expert Comment

by:radulucian
ID: 1128105
I had the same problem when using smartdrv.exe
see if you have it in your autoexec or config.
if you have it try removing it, but also if you don;t have it try adding that.

another related solution:
check your friend config.sys and autoexec.bat. try disabling any drivers or programs you have and he does not, even if you think you need them.
if problem is solved this way, you can then start to add them back one by one to see which one is causing the problem.

you should also compare and see if you have any useless items in your device listing in your system control panel menu.

another solution would be a second installation of win95 in a different directory (let's say "win4cd" with only the drivers and software you need for the dvd. Still you will have to clean the autoexec and config.sys files.

hope that any of these can be of help.
good luck
0
 
LVL 9

Expert Comment

by:larbel
ID: 1128106
Under Control Panel>System>Device Manager>CDRom click on Properties>Settings and make sure the DMA check box is checked and reboot.  And it would really help if you tell us what software are you using to decode.  Currently the best decoder is the MS Windows Media Player 5.2 which you can download from MS' site.

http://www.microsoft.com/windows/mediaplayer/

The CDRom should be left at secondary master.

Also, update your IOSUPD for your CDRom:

ftp://ftp.microsoft.com/Softlib/MSLFILES/iosupd.exe
0
 

Author Comment

by:ofer052997
ID: 1128107
Sorry,
I do not use smart drive (and never did..), and I already removed all drivers from my startup files (they only have the MODE lines added by windows setup, no devices etc...)
0
 

Author Comment

by:ofer052997
ID: 1128108
for some reason I don't have a "grade answer" form, but I will add a few comments to larbel & joopv:

joopv:
my video card is ATI Expert@Play AGP 4M 3DRagePro
my OS: windoze 95 4.00.950r-7
Switching to 256 colors didn't help
(!! forgot to mention this in my initial question...)
 when measuring transfer rate COPYING one of the avseq##.dat files to the HD, it takes a very long time! I measured it some time ago already. when I used a busMaster IDE driver, the copy took ~2 minutes (and still the file could not be read in the player), now that I uninstalled the BusMaster driver, it starts copying and estimates the time at ~22 minutes (!) so I gave up waiting...
Does that mean anything to you?

larbel:
I was using ATI video player, and Xing.
I am now d/l-ing MS mediaPlayer and iosupd.exe , I'll get back to you about that!
you said:
"Under Control Panel>System>Device Manager>CDRom click on Properties>Settings and make sure the DMA check box is checked"
well... the only checkboxes I have there are: disconnect(checked), Sync data transfer (tried both - currently unchecked), & Auto insert notification (checked)
Our drivers are probably different (I am using the "Standard CD-ROM device" driver which comes with win95)

Hope This clears things up and it'll help us find a solution...
0
 
LVL 6

Expert Comment

by:joopv
ID: 1128109
If you copy the AVSEQ file to harddisk you measure the common xfer speed from cdrom to hd.  Use the copy /b filename nul: command to just read from cdrom.

Do the same with reading from hd.  What xfer speed do you get there ?  A modern system should do at least 2-3 Mbyte/sec, probably more like 4-6 Mbyte/sec.  So a copy of 400 Mbyte to the nul: device should never take more than 3 minutes from hd.

22 minutes is very bad - like 2 speed (300 kb/sec) or something.  This means your system is completely tied up with reading from cdrom and has only little time to decompress the video stream information.

Personally i have an big aversion against IDE stuff.  I use only SCSI in my system (3 hd's, cdrom, scanner, tapestreamer).  Costs are higher but stress is MUCH lower :-).

I have smooth fullscreen video (1024*768*24) playing cd-video on a pentium 233. (s3 virge, ncr scsi, plextor 12sp cdrom) using standard W95b media player.

ps what is 950r-7 ??  I only know 950, 950a and 950b.

0
 

Author Comment

by:ofer052997
ID: 1128110
This is interresting, I copied one of the avseq##.dat files using "copy /b avseq02.dat nul:"
the file size is ~50M and it took it 1:10 minutes only.

the 950r-7 is a hebrew enabled version of win95 (what can I do... that's my language ;-)

I also installed the iosupd.exe update as suggested by 'larbel' and M$ MediaPlayer with no significant results (actually, I didn't figure out yet why MediaPlayer doesn't have .dat extention configured as an acceptable mpeg data, but anyway it doesn't read it at all) My ATI player still responds the same to the videocd.

0
How to improve team productivity

Quip adds documents, spreadsheets, and tasklists to your Slack experience
- Elevate ideas to Quip docs
- Share Quip docs in Slack
- Get notified of changes to your docs
- Available on iOS/Android/Desktop/Web
- Online/Offline

 
LVL 6

Expert Comment

by:joopv
ID: 1128111
So just reading the file gives 50M/70sec=750k/sec.  That is about 5 speed.  Not very good for such a system.  On my 12 speed i get more than 1M/sec.

If copying the file to hd goes even slower then there sure is a problem with your IDE driver or hardware (cabling, power supply, ide interface, etc).

You are running win95 original.  I would install win95b.  All drivers and the kernel are significantly improved.  And the standard media player can cope with video-cd.  The media player from the older versions of w95 can not, as you have just found out.

0
 
LVL 9

Expert Comment

by:larbel
ID: 1128112
Ofer,

Sounds like you have an IDE driver problem.  Please state exactly what chipset motherboard you're using and what's being list under System>Device Manager>Hard disk controller.  If you're using Standard IDE controller, that might then be your problem.  The DMA checkbox is available when using the Win95 driver for CDRom, you DO sound like you have an IDE problem...
0
 
LVL 9

Expert Comment

by:larbel
ID: 1128113
Ofer,

I'll post the solution as an answer if this is indeed the case...
0
 
LVL 2

Expert Comment

by:selim007
ID: 1128114
hello buddy
please check your directx setup and especially direct3d and direct play if you got not certified reinstall directx (directx5 prefered).....
hope that i can solve ur problem
best regards:
selim007

0
 

Author Comment

by:ofer052997
ID: 1128115
Sorry selim007 - directx really isn't the issue... (checked it and it's OK, I have dx5 installed.)

I think that 'larbel' and 'joopv' are more onto the case because my feeling is that it's IDE/BOARD related too (as I mentioned before, i also got the same results under linux - even if the cdv drivers there are pretty new and buggy, this should indicate something about the fact that it's not exactly dependant on the OS config.)

To address some of the facts  'larbel' and 'joopv'  asked about:
1. my system->devices->hard drive controllers says:
-   intel 82371AB PCI BusMaster IDE Controller (even though it is uninstalled - when trying to re-uninstall it detects that the busmaster drivers are NOT installed),
-   Primary IDE Controller (dual fifo)
-   Secondary IDE Controller (dual fifo)
(all are "working properly' ... yeah right...)

2. my board chipset is intel 440LX AGPset. it is manufactured by "Vision" model "P2-LX ver 6.35"
3. my cpu is Pentium II MMX (Intel..)
4. IDE specifications (in board's manual) says: dual channel PIO & PCI Bus Master IDE ports ..blah... 4 EIDE devices for HDD or CDROM, suppots PIO Mode 4 w. data transfer rate up to 22 MB/Sec, supports Ultra DMA 33 (UDMA) ... transfer rate up to 33 MB/Sec
5. Bios is Award BIOS ver 4.51

I hope this covers it... If you can make any sense out of this and give me some suggestions, I'll be real greatful - this problem is busting me for about 2 months now! I am pretty resourceful usually with my computer... but this time I'm at a loss.

I hope you won't get discouraged...
10x a lot for your help
0
 
LVL 9

Accepted Solution

by:
larbel earned 500 total points
ID: 1128116
The release version should be 950, 950A, 950B or 950C.  I really don't know if the hebrew 950r-7 is the original version or not.  If it's the same as version 950 and 950A, then BusMaster or UDMA is NOT supported.  And that's the reason you don't have the 'DMA' checkbox under CDRom.  I understand you've already installed the 440LX patch, but that only let Win95 to identify your chipset and IDE channel correctly, doesn't add BusMaster support at all.

Here's a link where you can download the latest Intel BM driver, try it and see if it make any differences:
ftp://download.intel.com/design/pcisets/busmastr/bmide_95.exe

Another thing, if your version is indeed the same as 950 or 950A then you're *not* using AGP capable features, in order to use AGP features, you've got to have 950B (OSR2.1 up)

The MS MediaPlayer 5.2 will play *.dat file (*.dat = data file), you've got to select 'all files' from the pull down menu and highlight the file then click open to play.  if you're copying the *.dat file to your HDD, you can then rename it to *.mpg to play.

Your config suggest that you should have very smooth mpeg playback, a 24X CDRom is more than enough, display card and CPU is not an issue here too.  You *should* try copying a movie to your HDD then play from HDD to see what happens, it would help us pin point the problem.  But I think you should go for Win98, it has all the latest driver and support for your hardwares.  The version that you're using is not up to your config.
0
 

Author Comment

by:ofer052997
ID: 1128117
'larbel' - I see what you mean.
I will try to install win98 on a different HD / Partition and see what happens then.

Meanwhile, I am nor "rejecting" the answer nor am I "accepting" it since it will probably take me a few days to make this test (it's not a simple matter of "click here / put a jumper there"...).

Of course, If this will solve my problem I will accept the answer - however, I would really be happy to hear more comments from you (or other experts!).

The version of win95 I am using is (as you figured out) "Pre-OSR2", but it's the best version available in hebrew (the way I understand it, win98 can support hebrew anyway , and even if it does, I can leave a small partition with win95 installed with my hebrew software).
0
 
LVL 9

Expert Comment

by:larbel
ID: 1128118
Like I said, your config is too new for your OS to handle.  Bus Mastering, FAT32, and AGP support alone is a good reason to go for Win98.  It actually contains lots of other fixes too.  Please let me know how it goes.
0

Featured Post

How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

Join & Write a Comment

I recently purchased an HP EliteBook 2540p notebook/laptop. It has two video ports on it – VGA and DisplayPort. HP offers an optional docking station for the 2540p that also has both a VGA port and a DisplayPort. There are numerous online reports do…
This paper addresses the security of Sennheiser DECT Contact Center and Office (CC&O) headsets. It describes the DECT security chain comprised of “Pairing”, “Per Call Authentication” and “Encryption”, which are all part of the standard DECT protocol.
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.
Polish reports in Access so they look terrific. Take yourself to another level. Equations, Back Color, Alternate Back Color. Write easy VBA Code. Tighten space to use less pages. Launch report from a menu, considering criteria only when it is filled…

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

22 Experts available now in Live!

Get 1:1 Help Now