Solved

C000021a (Fatal System Error)

Posted on 1998-10-31
11
1,855 Views
Last Modified: 2013-12-28
I keep on getting this error message "C000021a (Fatal System Error). Windows logon process system process terminared unexpectedly"

And I cannot logon to NT at all. Please help...
email answers to richard.adeolu@jci.com will be greatly appriciated
0
Comment
Question by:adeolu
  • 3
  • 2
  • 2
  • +3
11 Comments
 

Expert Comment

by:adnanza
ID: 1794226
 
PSS ID Number: Q156669
Article last modified on 03-03-1998
 
WinNT:3.5,3.51,4.0
 
winnt
 

======================================================================
--------------------------------------------------------------------------
The information in this article applies to:
 
 - Microsoft Windows NT Workstation versions 3.5, 3.51, and 4.0
 - Microsoft Windows NT Server versions 3.5, 3.51, and 4.0
--------------------------------------------------------------------------
 
SYMPTOMS
========
 
A Windows NT Server or a Windows NT Workstation may stop with the
following message:
 
   STOP: c000021a {Fatal System Error}
   The Windows Logon Process system process terminated unexpectedly
   with a status of 0xc0000034 (0x00000000 0x0000000)
   The system has been shutdown.
 
NOTE: The parameters in parenthesis are specific to your system
configuration and may differ each time.
 
CAUSE
=====
 
The stop 0xC000021A is caused by a user-mode process that causes the
Windows NT operating system operations to come to a halt. Windows NT
interprets this STOP as a fatal error and the operating system will not
continue. A memory dump from this type of STOP does not contain much
useful information without the proper preparation.
 
RESOLUTION
==========
 
The solution to the STOP 0xC000021A lies in troubleshooting this STOP from
an application stand point. Basic troubleshooting procedures apply. "Was
new hardware installed?" "Was new software installed?" And so forth.
 
Any applications loaded in user-mode memory space can cause this STOP.
This includes the native user-mode processes of Windows NT. Carefully
review the loaded software on this system and try to determine if any one
of them may be causing a problem. Follow these steps to help in isolating
the cause of these types of errors.
 
First, set up Dr. Watson to trap any user-mode application that may be
causing this problem. Dr. Watson for Windows NT is an application error
debugger, which is a program that detects application errors, diagnoses
the error, and logs the diagnostic information.
 
To properly set up Dr. Watson to trap user-mode problems, perform the
following steps:
 
1. Run <SystemRoot>\System32\Drwtsn32.exe-I. This will initialize the Dr.
   Watson program.
 
2. Run <SystemRoot>\System32\Drwtsn32.exe and select dump symbol table
   and create crash dump.
 
3. Copy the <CD-ROM>\Support\Debug\Symbols from the Windows NT Server
   CD onto the <SystemRoot> of the failing system.
 
4. When a Dr. Watson log is generated, use the log to determine what user
   mode process may be causing a problem. The Dr. Watson help file can be
   used in assisting in decoding the log file.
 
NOTE: If the Windows NT system fails running a third-party application,
this problem should be directed to the third-party software vendor.
 
If a third-party software package was recently installed, and now the
system fails on booting with a 0xC000021A, try using the Last Known Good
option at start up. After Windows NT has started, remove the faulting
application and contact the third-party software vendor.
 
Set the GlobalFlag to 60000 in the registry. To do this, please see the
following Microsoft Knowledge Base article:
 
   ARTICLE-ID: Q147314
   TITLE     : GlobalFlags for Windows NT 3.51
 
After setting this global flag, the systems memory dump will contain more
information on the faulting user-mode application. Making any kernel mode
memory dump more useful.
 
MORE INFORMATION
================
 
This information for the global flags can be found in the NTEXAPI.H FLG_
definitions in the Windows NT Software Development Kit (SDK).
 
Additional query words: debugref 21A 21a 0x21a
======================================================================
Keywords          : NTSrvWkst kbnetwork
Version           : WinNT:3.5,3.51,4.0
Platform          : winnt
Issue type        : kbprb
Solution Type     : kbworkaround
=============================================================================
Copyright Microsoft Corporation 1998.


 

0
 
LVL 95

Expert Comment

by:Lee W, MVP
ID: 1794227
0
 

Author Comment

by:adeolu
ID: 1794228
Thanks for the time taken.
However, I have seen this knowledge base, and the problem is I cannot even log into Nt lest do any copy to the any file to the system directory. And worst still, I am using NTFS. So I cannot get into any directory.

I have also used the last known good menu, to no avail.
I cannot reinstall, because I do not have enough FAT space.
Thanks for your reply.
0
 
LVL 95

Expert Comment

by:Lee W, MVP
ID: 1794229
You can reinstall NT to the NTFS partition directly, provided you have the boot disks (which which you can make by running the winnt setup with the appropriate switch (which I don't remember off hand - do "setup /?" for the list))
0
 
LVL 1

Expert Comment

by:jb123
ID: 1794230
To install NT without the floppies, the command is winnt.exe /B
You may try doing a repair installation and have it leave your security settings alone, just fix the other areas. Ensure that you re-install any service packs after this.
You can choose the Repair installation at the screen where you are given several options to continue: Enter to Install, R to do a repair, etc.. This should give you back the basic operating system and allow you to get back inside.
0
Do email signature updates give you a headache?

Are you constantly making changes to email signatures? Are the images not formatting how you want them to? Want high-quality HTML signatures on all devices, including on mobiles and Macs? Then, let Exclaimer solve all your email signature problems today.

 

Expert Comment

by:adnanza
ID: 1794231
If the repair option doesn't work, what you could in that case is install NT on the same drive different folder or a different drive. then you would be able to copy files to the folder or from it to a different folder to recover your data.
0
 
LVL 5

Expert Comment

by:j_powers
ID: 1794232
The best thing to do at this point is to make your system as basic as possible. The error says that there is a device or software program that NT does not like the way it is. If you did a repair on the software, users and registry, then the next thing to do is look at the hardware. Go into your BIOS, and disable all PNP. You may want to even think about removing some cards to get to this Base area.

What happened before the error? Did you install any software?

Let me know.
0
 

Author Comment

by:adeolu
ID: 1794233
Thanks for your replies.
I have tried to reinstall NT on the NTFS partition, except that I keep oin getting the error that Setup cannot copy a file, Cannot find the files copied to my hard Disk, which of course did not happen. I am installing from CDROM.

I remember I installed some shareware program. Something very simple. Just to Extract file_id.diz from CDROMs. I do not believe this should be the cause.

I am going to try reinstalling NT again, and will let you know. I have also try using  repair option, but no show.

I will be giving it another shot tonight.

Thanks in advance
0
 

Expert Comment

by:trd
ID: 1794234
:(
0
 

Author Comment

by:adeolu
ID: 1794235
Thanks people,
I finally did the last thing everyone does.. I formated, created fat and reinstalled. NT refuse to install on my NTFS. It demanded for FAT partition. I used the original setup disks, did not help. Created mine, still same problem, so I formated....

Now, I intend to leave my 2gig partion as FAT. I hate that though, but am not sure if my STOP error will happen again.

Thanks to everybody for thier inputs.. Well appriciated..
Richard
0
 
LVL 5

Accepted Solution

by:
j_powers earned 200 total points
ID: 1794236
For the sake of arguments, just grade this at 0 points to remove the question.
0

Featured Post

Make managing Office 365 email signatures a breeze

Are you using Office 365? Having trouble trying to set up email signatures for your users? Getting stressed out managing multiple signatures? Need an easier way to manage? We have a solution for you, try the most-user friendly and powerful signature management tool on the market.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Our Group Policy work started with Small Business Server in 2000. Microsoft gave us an excellent OU and GPO model in subsequent SBS editions that utilized WMI filters, OU linking, and VBS scripts. These are some of experiences plus our spending a lo…
Sometimes drives fill up and we don't know why.  If you don't understand the best way to use the tools available, you may end up being stumped as to why your drive says it's not full when you have no space left!  Here's how you can find out...
This is used to tweak the memory usage for your computer, it is used for servers more so than workstations but just be careful editing registry settings as it may cause irreversible results. I hold no responsibility for anything you do to the regist…
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.

911 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

27 Experts available now in Live!

Get 1:1 Help Now