Solved

No FTP or Telnet unless client in host file

Posted on 1998-11-04
5
263 Views
Last Modified: 2010-03-18
Grab a cup of coffee, this is long winded...

I have a Gateway Solo2300 which has a Gateway Telepath Como Card (33.6 + 10base-T).  I have installed RH5.1 3 times and have had the same problem each time.

During install I do not configure the Network beacuse my card is not avialable in the list to choose from.

After I re-boot I run netconf to configure the LAN, Under Client tasks-adapter setup I add the TCP/IP info; however, for the adapter I simply enter eth0 (I do not specify a driver, IRQ or memory location).

I reboot the computer and Whola, PCMCIA service finds my Gateway combo card and assigns the 10base-T port the name eth0.  I can connect to the network no problem, I can FTP and Telnet out, I can use Netscape etc.  I can also connect to the Apache web server running on the laptop from other clients on the network; however, HERE IS THE PROBLEM.

When I try to FTP or Telnet to the laptop my client PC (WinNT) just hangs; however, if I enter the client PC in the laptop's hosts file WHOLA, I'm in.  That's nice but that's not how it is supposed to work.  Why can I not FTP or Telnet from clients that are not in the hosts file ?  I have installed RH on serveral PC's and I have never seen this happen.

0
Comment
Question by:hbrady
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
5 Comments
 
LVL 1

Author Comment

by:hbrady
ID: 1587621
Edited text of question
0
 
LVL 19

Expert Comment

by:xterm
ID: 1587622
Because the IP addresses of the hosts you are coming from
do not have IN PTR records in the DNS server you are using.
When you specify them in the hosts file, it doesn't have
to look them up since the default resolution order is
hosts,bind.  

If the addresses are routable internet IPs, then have your
service provider add reverse mappings for them.  If they
are private IPs, then you'll have to enter them in the hosts
file, or run DNS locally.

Incidentally, if you wait long enough on one of those hung
telnet/ftp sessions, it will time out and let you in
eventually.
0
 
LVL 1

Author Comment

by:hbrady
ID: 1587623
Sorry Chief, this is a LAN and we do not use DNS let me elaborate some....

I have a laptop with RH5.1 (192.168.2.62)
I have an NT WS (192.168.2.199)
I sit at my NT Workstaion and type Ping 192.168.2.62 and I get a speedy reply...
I go to Netscape and type 192.168.2.62 and I get the old Apache "IT WORKED"
I type at a DOS prompt ftp 192.168.2.62 and Its nap time (no go).
Telnet-Same Deal

I swing around to the laptop and enter:
192.168.2.199     bonesii.the_zone.com    bonesii

in the /etc/hosts file and FTP and Telnet work great from the NT Box.

Somewhere, buried in my Laptops network configuration is a setting that will not allow you to open a terminal session unless you exist in the host file....  ??

Keep diggin', I need an answer and it's good points :-)
0
 
LVL 19

Accepted Solution

by:
xterm earned 300 total points
ID: 1587624
You may not use DNS, but your in.ftpd & in.telnetd sure do
(like it or not).  In your /etc/host.conf, you'll find the
line "order hosts,bind".  This means it consults your hosts
file for lookup first & then DNS (whether you use it or not).

Yes, httpd works, but go into httpd.conf & turn "HostLookups"
to "on", sig HUP your web server & watch the slowdown begin
(it won't hang it to the extent of ftp/telnet since the timeout
is set shorter,  but it should be noticeable)

I understood your original question, and my answer is correct.
When you added that line to your /etc/hosts, you supplied your
server daemons with a name lookup on the originating IP of the
connection, whether you meant to or not.

I've run into the identical problem many a time over the
past 5 years - its way more common than you think.
0
 
LVL 1

Author Comment

by:hbrady
ID: 1587625
Thanks Xterm.  I feel like a guy caring his sunglasses around on my head and asking people "Have you seen my sunglasses?"  Sometimes the obvious isn't so obvious
0

Featured Post

Secure Your Active Directory - April 20, 2017

Active Directory plays a critical role in your company’s IT infrastructure and keeping it secure in today’s hacker-infested world is a must.
Microsoft published 300+ pages of guidance, but who has the time, money, and resources to implement? Register now to find an easier way.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Multicast - Linux 4 38
Ubuntu VNC server rejects access by client 7 214
Running Guacamole on port 80 5 295
BIND DNS - Single Zone 2 views 5 84
I have seen several blogs and forum entries elsewhere state that because NTFS volumes do not support linux ownership or permissions, they cannot be used for anonymous ftp upload through the vsftpd program.   IT can be done and here's how to get i…
Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…
A short tutorial showing how to set up an email signature in Outlook on the Web (previously known as OWA). For free email signatures designs, visit https://www.mail-signatures.com/articles/signature-templates/?sts=6651 If you want to manage em…
In an interesting question (https://www.experts-exchange.com/questions/29008360/) here at Experts Exchange, a member asked how to split a single image into multiple images. The primary usage for this is to place many photographs on a flatbed scanner…

749 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question