• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 357
  • Last Modified:

modem is not working, why ?

The modem in my window 95 is used to be working.
But one day, it is not working. I went to control panel, and click modem icon, then diagnostic. It said "the port is already opened". My modem use com port 4, IRQ 3 and they are factory setting. I used Modem doctor to check, my modem functioned properly but it come up that com port 2 is also using IRQ 3. I delete com port 2. But the same message "the port is already opened".
I delete all the com ports and modem driver. Reboot and Use Add hardware  function in control panel. When all is done, all the four com port appeared when I click system.  I went to modem icon and click diagnostic, the same message came up again. How comes the message and how to make my modem works again? Help !

How comes
0
man_15
Asked:
man_15
1 Solution
 
fredfanCommented:
-Delete all the com ports and modem driver, shutdown the computer.
-unplug the modem card (if it's internal modem) and plug it back OR
-off and unplug the cable from the com port if it's an external modem.
-on your computer and do the add hardware function in control panel again or let the Win95
 auto detect.
-let me know the result
0
 
man_15Author Commented:
I did what you suggest. It don't work.
After I deleted  com ports 2, 3, 4 and modem driver and unplug modem ;then reboot the system. Windows 95 always said "Found new device and install communcation port"
Com port 2 always appears and an unsupported device also appears.
May be  this unsupported device (a ghost ?) occupy the comport 2 which cause the problem.
0
 
man_15Author Commented:
My computer is a pentium. There is no controller card. I don't find a way to disable the com port 2 in the system setup.
Is there a way to disable com port 2 in the registry?
0
VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

 
chesbroCommented:
Does the device manager show any conflicts? You might try booting in safe mode and check to see if any other devices show up. Then when in safe mode remove the unsupported device, remove all com ports and the modem. Reboot and have Windows reinstall the com port and modem.
0
 
uilleannCommented:
you MUST have an option in the cmos to disable com2.
Go to "integrated peripherals" in the cmos
there you must be able to disable :)

Good luck
0
 
OttaCommented:
> I used Modem doctor to check,
> my modem functioned properly but it come up
> that com port 2 is also using IRQ 3.

Correct. By default, COM1 and COM3 use IRQ4,
and COM2 and COM4 use IRQ3.

My US Robotics modem is jumpered to COM4/IRQ3,
and my digital-camera uploads images
via the internal COM2/IRQ3 port.

As long as I don't try to use both devices *simultaneously*,
each device works correctly.

> I delete com port 2.

You can do this, but it doesn't matter,
since your modem uses COM4/IRQ3.

> But the same message "the port is already opened".

You must be loading some other software,
before trying to use the modem.
What's in your "Startup" folder?
Do you use any e-FAX software?
Do you use any modem-monitoring software?

0
 
man_15Author Commented:
I disabled com port 2 and reinstall modem. It works thanks
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now