We help IT Professionals succeed at work.

Incorrect MS_DOS version

jjfarm
jjfarm asked
on
1,916 Views
Last Modified: 2013-12-29
I just upgraded to Win98. When I boot up, either to WIN98 or by holding down the ctrl key to get to the DOS prompt I get a line that says:
Incorrect MS-DOS version
When I type ver at C:\ I get:
Windows 98 [version 4.10.1998]
I'm not knowledgable enough to tell if it is effecting anything but it doesn't appear to be.
How do I get the right version??
Comment
Watch Question

Author

Commented:
Edited text of question

Commented:
Error Message: Incorrect MS-DOS version
After you install Windows 95 and restart the system, it returns to an MS-DOS prompt with the following error message:

Incorrect MS-DOS version
Enter the name of Command Interpreter (e.g., C:\WINDOWS\COMMAND.COM)
This problem can occur if SETVER.EXE is being loaded in the CONFIG.SYS file and has a setting indicating that
COMMAND.COM should look for a version of MS-DOS earlier than 7.0.

Boot the system with the Windows 95 Startup disk and do the following:

1. Change to the WINDOWS directory by typing the following:

cd\<Windows 95 directory name>

2. Rename the SETVER.EXE file by typing the following:

ren setver.exe setver.old

3. Remove the Windows 95 Startup disk from drive A, then shut down and restart the system. (Windows 95 loads at this point.)

4. Click the Start button, point to Programs, and then click MS-DOS Prompt.

5. Change to the Windows directory by typing the following:

cd\<Windows 95 directory name>

6. Rename the SETVER.EXE file again by typing the following:

ren setver.old setver.exe

7. Remove the COMMAND.COM entry by typing the following:

setver command.com /d

8. Restart the computer to make the SETVER changes take effect.

The above procedure allows SETVER to maintain compatibility with existing MS-DOS-based applications.

When Windows 95 is installed, the new SETVER.EXE assumes the settings of the currently loaded SETVER.EXE in an effort to
maintain compatibility with existing MS-DOS-based applications.

Regards
http://www.geocities.com/~budallen/

Author

Commented:
I upgraded to win98 and I don't believe it is wise to put back my win95 cd back in and use it as a tool to troubleshoot the win98 problem. Smeebud did not mention win98 in the text of his reply. Perhaps the correction to the problem is the same for win98 but I would need to know that, i.e. "Boot the system with your win98 startup disk-- etc.etc.". Also I do not get any request to enter the command.com interpreter after the line Incorrect MS-DOS version.
vr
Jim

Commented:
Sorry JJ,
I thought I was in the 95 section.
glad you caught my mistake.

Regards
http://www.geocities.com/~budallen/

Commented:
It's also possible you're executing some old DOS command (i.e.: DOS 6.x) from your AUTOEXEC.BAT

As it normally starts saying "@ECHO OFF", you're unable to see the command responsible of that message...

Author

Commented:
Viking's answer is a suggestion that there COULD be something (hidden autoexec.bat command causing problem). I'm sorry it does not help. He does not tell me what to do: i.e. turn Echo on and look for something???. I am not quite sure about his lead in sentence, "It's also possible your---. Also possible to what, Smeebud's answer?? But thanks Viking. Smeebud, I've got a coupon for Sear's Optical :)grin
CERTIFIED EXPERT

Commented:
JJ,
  Start > Run > type 'NOTEPAD C:\AUTOEXEC.BAT', Enter...
  Post the contents of the file up....
  From a command prompt, can you run DIR, COPY and commands like that ?
  It could be loading up the wrong COMMAND.COM.
  If you run.. 'NOTEPAD C:\CONFIG.SYS' - check for a line COMSPEC and that the path indicated goes into C:\WINDOWS\COMMAND.COM...
  Alternatively, you can try renaming these two files (CONFIG.SYS and AUTOEXEC.BAT), keeping them somewhere safe, and then restarting Windows to see if the problem recurs..
  You may have some drivers you need in these files...
  Best to post them both up so we can all take a peek !

Tim

Commented:
Check the command.com you have more then one version of the command.com files in your system, checked the data of these files, they should two different dates and sizes.   Because you have two different command.com files in you OS, that was the reason cause Incorrect MS-DOS version massage.  Copy the command.com from C:\ into the path of c:\windows\command  That will take care your problem.

Author

Commented:
Can't accept or reject yet. theh95 answer said to put the command.com into c:\windows\command\. Ok, first I have four files command.com; in c:\, c:\windows, c:\windows\ebd\ and c:\windows\options\cabs\. The first three are all same size and dates(5/11/98) the fourth is slightly smaller(91k vs 92k) and dated 12/31//95. There is no command.com directly under c:\windows\command, should I put one there even though there is one in that ebd folder? I will rename the one in cabs and reboot just for kicks.
Tim here is my two files. I have no problems-yet-except for the error message
rem @C:\PROGRA~1\NORTON~2\NAVBOOT.EXE /STARTUP
@echo off
LH c:cdd\MSCDEX.EXE /D:WP_CDROM /M:20
SET PATH=C:\PROGRA~1\COMMON~1\BORLAND\BDE;C:\WINDOWS;C:\WINDOWS\COMMAND;C:\;C:\DOS;C:\WINDOWS\TWAIN\SCANWIZ;%PATH%
SHARE
rem SET BLASTER=A220 I5 D1 H5 P330 T6
rem SET SOUND=C\:VIBRA16
rem SET MIDI=SYNTH:1 MAP:E
rem C:\VIBRA16\DIAGNOSE  /S  /W=C:\WINDOWS
rem c:\VIBRA16\MIXERSET  /P  /Q
rem c:\msinput\mouse.exe
rem
rem
rem
rem PATH=C:\WINDOWS\TWAIN\SCANWIZ;%PATH%
rem SET PATH=%PATH%;C:\WINDOWS\Twain_32\ScanwizDOS=HIGH,UMB
device=c:\windows\himem.sys  /testmem:off
device=c:\windows\emm386.exe  ram
devicehigh=c:\cdd\wcd.sys  /d:wp_cdrom
devicehigh=c:\plugplay\drivers\dos\dwcfgmg.sys
devicehigh=C:\SCSI\ASPI2DOS.SYS /D /Z /P140 /Q10
devicehigh=c:\scsi\aspidisk.sys /e
DEVICE=C:\VIBRA16\DRV\VIBRA16.SYS /UNIT=0 /BLASTER=A:220 I:5 D:1 H:5
DEVICE=C:\VIBRA16\DRV\CTMMSYS.SYS
buffers=70
FILES=100
CERTIFIED EXPERT

Commented:
JJ,
  Thanks for your posting !
  From a C prompt, try running these commands :

1.  echo
2.  share
3.  cdd\mscdex
4.  lh

   One of these is probably going to say 'Incorrect DOS version'.
   If it does, look for all instances of that file on your HDD and try running each, by going into the directory where the file is (ie: cd windows) and running it from there to narrow this down ...

Tim

Author

Commented:
theh95 did not propose a solution which ended in an answer to the question.

However Tim Holman's suggesttion has identified the SHARE commmand in my autoexec.bat as the cause of the line "incorrect MS-DOS version" For when I rem'd it out the error msg went away. I will have to investigate the share problem, I do see it is a 1995 file.
After rebooting to DOS at start up the version I get is Windows 98 version 4.10 1998. Tim, shouldn't I get something like 7.0? Or has windows totally taken over the DOS?
vr
Jim
ps I guess Tim gets the points

Commented:
Put the 98 version of the command.com into the 95 version.  you can just rename the 95 version.  that could take care your problem.

Author

Commented:
Hmmm. thought I did this. My reject answer is above.Tim Holman comes close.
This appears to be getting a bit long and I should bow out gracefully.
Thanks everyone
Jim

CERTIFIED EXPERT
Commented:
Unlock this solution and get a sample of our free trial.
(No credit card required)
UNLOCK SOLUTION

Author

Commented:
Tim found the cause of the problem. Now I need to find the cure and what am I supposed to get when I type ver at the c prompt.
Unlock the solution to this question.
Thanks for using Experts Exchange.

Please provide your email to receive a sample view!

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.