Mounting MSDOS HardDrives: NLS Charset Error

When I go to mount my msdos hard drives from within Linux I get the following error message:
Unable to load NLS charset cp437 (nls_cp437)

I mount like this: mount /dev/hda1 /c:

The mounting, though, was successful as I am able to access my msdos hard drives.  I just don;t like that error message.  When I do the mounting from with in X windows, thru the X term, I don't get this error message what so ever as if X windows handled the problem.

Oh and one more thing.  I notice my msdos mounted hard drives have all their filenames in the 8-char.3-char format of old msdos and not the long filenames of win95.  How do I get linux to recognize the long filenames of my msdos mounted HDs?

Thanks!
ratboy2Asked:
Who is Participating?
 
sortofConnect With a Mentor Commented:
in the system root make a folder called /c
the colon : mighr be interpreted as a command.. im not sure.. but just to make sure it works leave it out..
then type:

mount -t vfat /dev/hda1 /c

that should mount the drive and you should be able to view it.  if not then the drive is not vfat and youll need to try the correct type.

i hope this works for ya
0
 
ratboy2Author Commented:
Nope, the error message:
Unable to load NLS charset cp437 (nls_cp437)

still exists.  Mounting the drive is ok (I can access the msdos HD ok), just I hate that error message.  Maybe is there a way to hide output messages?

Thanks.
0
 
somberlainCommented:
try recompiling your kernel and setting up that charset again.  also, if you want vfat support be sure to add support for vfat along with msdos and fat filesystems.  I use modules for M$ filesystems and just modprobe them if I need to access a msdos disk.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.