Solved

NNTP: "You have no permission to talk"

Posted on 1998-11-10
13
930 Views
Last Modified: 2013-12-29
Recently I starting to receive this message, while tried to
use news. Mail (SMTP), WWW, FTP works OK. I thought that it's
Netscape 4.5, but same message goes from IE and even from
WinVN. Reinstalled MSDUN - no luck. Service guys said, that
their news work OK (sure thing :), so I think that fault is
on my side. Auto-run tasks all the same: Cpuidle, RVS Port
Server (maps ISDN on COM port), Moony Caller ID detector,
CleanSweep detector modules.
PS: DeviceManager has some "DialUp with VPN" as well as normal
DialUp adapter listed, but it sits there long time.
0
Comment
Question by:busuka
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 4
  • 3
  • +1
13 Comments
 
LVL 6

Expert Comment

by:sgenther
ID: 1727345
PSS ID Number: Q186741
Article last modified on 08-26-1998
 
Winnt:5.5
 
winnt
 

======================================================================
---------------------------------------------------------------------------
The information in this article applies to:
 
 - Microsoft Exchange Server version 5.5
---------------------------------------------------------------------------
 
SYMPTOMS
========
 
When you set up the Internet News Service for Microsoft Exchange Server
5.5, and you attempt to connect to another host Network News Transfer
Protocol (NNTP) server, the following error message may appear:
 
   502 You Have No Permission to Talk
 
CAUSE
=====
 
This error can occur if you try to connect to a host server that does not
allow access from your IP address.
 
This is a security measure that allows Internet Service Providers (ISPs) to
restrict access to their NNTP server.
 
RESOLUTION
==========
 
If you are setting up a new connection with an NNTP server, your ISP needs
to include the IP address (or range of addresses) of your Exchange Server
computer, explicitly in order to allow you to connect.
 
If you do not have a static IP address (or a range of addresses) that can
be included on your newsfeed server's authorized pool for incoming
connections, then you may need to set up a secure connection using a logon
name and password.
 
To select a secure outbound connection, click the Security tab IN the
newsfeed object in the Microsoft Exchange Administrator program.
 
MORE INFORMATION
================
 
To prevent unauthorized access to their NNTP servers, Internet Service
Providers often restrict logon attempts to their own network or to a group
of IP addresses.
 
You may not see this error message unless you manually telnet to port 119
of an NNTP server for troubleshooting reasons. The telnet dialog box looks
something similar to the following:
 
   502 You have no permission to talk, Goodbye
   Connection closed by foreign host.
 
Additional query words: news, usenet
======================================================================
Keywords          : XFOR
Version           : Winnt:5.5
Platform          : winnt
Issue type        : kbprb
=============================================================================
Copyright Microsoft Corporation 1998.


 

0
 
LVL 6

Expert Comment

by:sgenther
ID: 1727346
This info should help,it still sounds like its on the ISP side though.
0
 
LVL 7

Author Comment

by:busuka
ID: 1727347
Sgenthet, sorry for rejecting, but I'm not setting Microsoft Exchange Server, I'm just
humble dial-up'er with dynamic IP address that worked 1/2 years, till past week. :)
And my account not expired: I'm just confused, because my logic tells me that
my record on NNTP server of my ISP damaged/erased. I'll try to convince them, that
it's their problem, but in the same time I'd like to hear hints if it can be my fault (and
where).
0
Secure Your WordPress Site: 5 Essential Approaches

WordPress is the web's most popular CMS, but its dominance also makes it a target for attackers. Our eBook will show you how to:

Prevent costly exploits of core and plugin vulnerabilities
Repel automated attacks
Lock down your dashboard, secure your code, and protect your users

 
LVL 6

Expert Comment

by:sgenther
ID: 1727348
No problem...I know you didn't have exchange server ,but in the article it explains the causes of getting this error msg as being
the ISP lack of having your ip in their security.I really don't believe this is something you can do anything about.
0
 
LVL 6

Expert Comment

by:joopv
ID: 1727349
You can test if you are authenticated to access the news server of your isp.

Just telnet to port 119 of the newsserver.  Type help (set your telnet program to echo locally first)

The issue some nntp commands and see if they work.  If the nntp server needs authentication it will complain about it.  You can log in manually by using the authinfo command

0
 
LVL 7

Author Comment

by:busuka
ID: 1727350
joopv, good hint. From home: "you have no permission to talk" and
"cannot connect". From work: "conection refused".
0
 
LVL 6

Expert Comment

by:joopv
ID: 1727351
Probably at work you have to work via a proxy/firewall ?  I'm not sure if this will block your tcp port 119 traffic.  Where i work it will.

Experiment with a public (no authentication needed) news server like cs.intel.com ans see how it reacts to your manually given nntp commands.

0
 
LVL 6

Expert Comment

by:joopv
ID: 1727352
oops, i meant this to be a comment, not an answer.

another thing to check is your local config : see if it has something like 'this news server needs you to log in using this username and this password' and check the values.

0
 
LVL 7

Author Comment

by:busuka
ID: 1727353
He-he. You right, at work I have proxy/firewall, but I telnet'ed
to site which doesn't have it and from it telnet'ed to news.
. OK, I got it by telnet. Now syntax of authinfo is
authinfo user Name|pass Password|generic <prog> <args>
I tried to put:
authinfo user _my_username_ pass _my_password (answer is PASS required)
authinfo user _my_username (answer is PASS required)
authinfo pass _my_password (answer is telnet jumped out and auth  error:)

Do I miss something ?
0
 

Expert Comment

by:mcaddan
ID: 1727354
I had this problem with Netscape V 4.03 but when I checked at the time my clock had been reset - now isn't that something wild, anyhow when I reset the clock the error did not reappear. Also after I upgraded to V 4.06 the problem dissapeared, BTW frustrated with h.disk problems with Netscape I now use MS Explorer. Also if on the net a lot, you may have a virus - do get an antivirus package.
RE
Netscape cache and malicious java code - the easy way to get rid of this sort of silliness is to delete the cache folder from the Nestscape directory. It does not affect the performance of netscape and it does deal quickly with these type of problems - I do recall one occasion where I got the error 'No permission to talk' and I did close down NS dissconnect, delete the cache folder, log on again reload NS then post my comments.
These viruses are becomming tooo much really !
0
 
LVL 7

Author Comment

by:busuka
ID: 1727355
Hi all. Now it's clear to me that it's ISP problem. I have several news.* server names. Old one
suddenly asked my login/password and failed, second, suddenly as well, started to receive news
WITHOUT any authentication.
0
 
LVL 7

Author Comment

by:busuka
ID: 1727356
OK. Now it's 100% crystal clear that it's ISP problem. joopv, you
got the cigar for effort (I mean answer :)
0
 
LVL 6

Accepted Solution

by:
joopv earned 100 total points
ID: 1727357
Ok so i understand your problem is solved or at least you are looking with your ISP to find it out.  It is strange since most isp's use special protocols to authenticate (RADIUS/TACACS) and it usually means that once you are in, you don't have to authenticate every service, just once at login.

Good luck

0

Featured Post

Why Off-Site Backups Are The Only Way To Go

You are probably backing up your data—but how and where? Ransomware is on the rise and there are variants that specifically target backups. Read on to discover why off-site is the way to go.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

No single Antivirus application (despite claims by manufacturers) will catch or protect you from all Virus / Malware or Spyware threats. That doesn't stop you from further protecting yourself however - and this article is to show you how.
Compliance and data security require steps be taken to prevent unauthorized users from copying data.  Here's one method to prevent data theft via USB drives (and writable optical media).
Windows 10 is mostly good. However the one thing that annoys me is how many clicks you have to do to dial a VPN connection. You have to go to settings from the start menu, (2 clicks), Network and Internet (1 click), Click VPN (another click) then fi…
This is used to tweak the memory usage for your computer, it is used for servers more so than workstations but just be careful editing registry settings as it may cause irreversible results. I hold no responsibility for anything you do to the regist…

628 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question