Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 279
  • Last Modified:

Forcing 10BaseT for eepro100

I've just installed Red Hat 5.1 on a Pentium Pro and can't get eth0 to intialize.  I am using an Intel EtherExpress Pro 100B network card. I think, from reading lots of docs, that my problem may to two-pronged:
1. eepro100 driver uses the same IRQ as the Adaptec 2940.
2. I am using 10BaseT and I may need to load the driver as a module and force use of 10 MB ethernet because the NWay autonegotiation is not working.

I have read up on the documentation(Ethernet HOWTO) and there appears to be a solution, but I am too much of a newbie to figure it out.  

Can anyone give me some advice to get the eth0 up and running?

Thanks much!
0
bgodden
Asked:
bgodden
  • 3
  • 2
1 Solution
 
vxCommented:
I read the following (http://cesdis.gsfc.nasa.gov/linux/drivers/eepro100.html):

In most cases no transceiver override option need be set. A notable exception is when connecting to a older ethernet switch that operates in full-duplex mode but does not do NWay autonegotation. The driver options flags are recognized:

 Hex   Decimal  Meaning
 0x10  16       Force Full-Duplex operation (must be used with 0x20 or 0x40)
 0x20  32       Force 100mbps-only operation
 0x40  64       Force 10mbps-only

i.e.:
The option flags are passed as follows when loading the driver as a module

        insmod eepro100.o debug=1 options=0x20,0,0x50

The option flags are passed as follows when using the driver as a built-in

          ether=0,0,0x20,eth0 ether=0,0,0,eth1 ether=0,0,0x50,eth2


About the IRQ's: I don't think it really matters, I believe a have some double IRQ's in my system (with Intel EtherExpress100B!) as well.
0
 
bgoddenAuthor Commented:
Well, I got impatient and bought RH 5.2 and it appears auto-sensing for this has been fixed so it worked after install.  This, however, is a excellent answer and I think would be helpful if anyone else digs it up.  

One thing I would like you to add to it though is the answer to: "Are the options for the built-in driver used at the boot: prompt during boot-up or hard-coded somewhere else?"

Request acceptance for you answer and I will.
Cheers!
0
 
bgoddenAuthor Commented:
Well, I got impatient and bought RH 5.2 and it appears auto-sensing for this has been fixed so it worked after install.  This, however, is a excellent answer and I think would be helpful if anyone else digs it up.  

One thing I would like you to add to it though is the answer to: "Are the options for the built-in driver used at the boot: prompt during boot-up or hard-coded somewhere else?"

Request acceptance for you answer and I will.
Cheers!
0
 
vxCommented:
The built-in driver should be configured at boot-time, that means at LILO's bootprompt (or in the LILO configuration file) or it should be appended to your LOADLIN boot-parameters (if you don't know what LOADLIN does, you probably won't need it; but it's a program to boot Linux from DOS).
0
 
bgoddenAuthor Commented:
Thanks vx
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Build your data science skills into a career

Are you ready to take your data science career to the next step, or break into data science? With Springboard’s Data Science Career Track, you’ll master data science topics, have personalized career guidance, weekly calls with a data science expert, and a job guarantee.

  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now