• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 306
  • Last Modified:

Record Lock Threshold exceeded total violation 656

Hi, I'm currently running an foxpro application in novell 3.12 version.  While run a particular option in the application I would get an error message from the application. "Record in used by another".  I then checked the console of the novell server and got the above "error message"  Pls help ...
0
salconen
Asked:
salconen
  • 3
  • 2
  • 2
  • +1
1 Solution
 
mark2150Commented:
Your foxpro app is in runaway mode. It's recursively locking records in database until the lock manager gets wound around the peg. Check your code and make sure that you're releasing the locks prior to asserting a new one.

M

0
 
salconenAuthor Commented:
Yes I did release it before getting new ones.  Would it be the network sides ??
0
 
michelandreCommented:
At what time???
Is there backups being done?
Is there a  batch file waiting to be process then executed at night???
I think the max for locked is 10,000 locks.
0
Prep for the ITIL® Foundation Certification Exam

December’s Course of the Month is now available! Enroll to learn ITIL® Foundation best practices for delivering IT services effectively and efficiently.

 
mark2150Commented:
You've got to have a logical error somewhere. If you monitor the task from RCONSOLE/MONITOR I think you'll see it locking and locking and locking...

Sometimes you need to wait a bit tween lock release and new requests. Give the server time to digest. Try setting TRUE COMMIT ON in the NET.CFG file. This will prevent the server from pre-acknowledging writes until the disk has really written them.

M

0
 
jsyringCommented:
Here are the SET-parameters you need to modify:

     (the default values are for NW4.11)
     Maximum Record Locks Per Connection (default: 500, range 10 - 100000)
     Maximum File Locks Per Connection (default :250, range 10 - 1000)
     Maximum Record Locks (default :20000, range 100 - 400000)
     Maximum File Locks (default: 10000, range 100-100000)

     A rule of thumb is to double the parameters and monitor if the problem persists.

0
 
salconenAuthor Commented:
Hi jsyring got your setting, where do I have to set it and what is the syntax to set them...  Pls reply as soon as possible

Thanks
0
 
jsyringCommented:
Salconen

All of the settings can be set in the startup.ncf file and the syntax to set them is as follows

Set Maximum Record Locks Per Connection 1000
Set Maximum File Locks Per Connection 500

I have doubled the default in each setting and would then monitor the problem. You can then set the paramaters higher if you need to. Each of these setting may effect performance so I would not go any higher thean you need to.
0
 
salconenAuthor Commented:
yeah... you're right.   but the lines need to entered in the autoexec.ncf
0

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 3
  • 2
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now