Winsock error 10038

I have an NT 4.0 server that is serving as my email server.  I upgraded the memory and installed internet 4.0 on this system on Tuesday.  System has sp3 on it.  Everything was okay.  Now users can receive mail but cannot send mail.  I am using NTMail product ver 3.2.  In my mail logs I have an error regarding winsock 10038 - socket operation on a non-socket.  When I attempt to send mail it comes back immediately saying no transport provider is available.  I am at my witts end.  I have done everything I know to do.  Stopped and started services.  Uninstalled i.e 4.0, reinstalled the sp3, rebooted.  Still nothing.  Any suggestions on what to try next.  Deparately need to get people the ability to send mail.  Thanks
swebbAsked:
Who is Participating?
 
mbreukerConnect With a Mentor Commented:
You say you uninstalled IE 4 and re-installed SP 3, but did you re-install NTMail?

Microsoft claims the winsock 10038 error is a "bug" in SP 3. They claim the fix is to install SP 4.

It is possible that the creators of NTMail knew of this bug and the program therefore installed an older DLL from say, SP 2, in order to work around this. It is possible that IE 4 re-installed the later DLL, and thus re-introduced the bug. If this is the case, re-installing NTMail may fix the problem.

Your other option is to install SP 4. I would only recommend this as a last resort since SP 4 may have other bugs of its own.

Good Luck.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.