Solved

Error: No domain server was available to validate your password

Posted on 1998-11-12
11
218 Views
Last Modified: 2013-12-28
I'm troubleshooting a problem on a single PC running Win95/OSR2 attempting to logon to an NT 4.0 domain server. The network settings consist of: Client for MS Networks, Novell IntraNetware client 2.2, protocols IPX/SPX, NetBEUI, and TCP/IP. The MS Client accesses NT via Logon validation to the Domain. I've thoroughly checked the networking settings...even compared to all 16 other PCs accessing the NT server the same way. It logs in to the Netware box fine, but pauses and displays the error message:
"No domain server was available to validate your password. You may not be able to access some network resources."

The user and passwd is set up correctly in NT, also. In fact, I've deleted and readded the user just to be safe. I can access shared resources, etc. on NT, but the login script won't run. I've noticed that the error doesn't appear when NetBEUI is not installed on the Win95 PC.

Thru my trials I've been unable to determine whether it's a Win95 or NT issue. I've scoured Microsoft's KB and searchd the net, but all references to this message do not provide an answer. Obi-wan, you're my only hope...
0
Comment
Question by:mwyatt
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
11 Comments
 
LVL 95

Expert Comment

by:Lee W, MVP
ID: 1794619
You're problem may be with both.  Do you use WINS or LMHOSTS?  We had a similar problem and the NT server's WINS database was corrupt.   A work around (and as I view it, safety feature) is to use an LMHOSTS file along with the WINS service.  If you add your domain controller and domain to an LMHOSTS file with the following entries (adjust the domain names, "internet" in my example, to match yours and change the computer name to your server's name.

123.45.6.37      computername      #PRE #DOM:internet
123.45.6.37      "internet       \0x1b"      #PRE
123.45.6.37      "internet       \0x1c"      #PRE

Incidentally, in the example above, the "" area must be 20 characters long.  the \0x1b, c must be at the end of the quotes like in the example.

This LMHOSTS file should be placed on the client.

Then, when you have an opportunity, rebuild the WINS database (and it's best if you can do this with all the clients off.  And the WINS server should also point to itself as both the primary and secondard server.  And there should be no static mappings (unless you need to connect to macs or unix boxes).

See http://support.microsoft.com/support/kb/articles/q168/7/12.asp?FR=0 for information on rebuilding the WINS database.

Let me know if this solves you're problem and I'll post it as an answer.
0
 

Author Comment

by:mwyatt
ID: 1794620
I don't use WINS resolution, nor is a LMHOSTS file present. This is strictly NetBEUI in use as a transport for simple peer file sharing. I will add that the problem presented itself on one other machine some months ago, but even after reinstalling Win95 on it the problem persisted. Finally, we replaced it with a new PC which, of course, resolved the problem. Unfortunately that isn't an effective solution in the long run...

I'm open for more suggestions.
0
 
LVL 8

Expert Comment

by:wayneb
ID: 1794621
Try removing all network cards and protocol stacks and re adding them and the network card.  Be careful if you do this as the novell client may have to be uninstalled first and then reinstalled.  There are 2 possibilitys here, the network stack is corrupted or the registry is damaged, the later is a major problem.
0
Portable, direct connect server access

The ATEN CV211 connects a laptop directly to any server allowing you instant access to perform data maintenance and local operations, for quick troubleshooting, updating, service and repair.

 

Author Comment

by:mwyatt
ID: 1794622
Removing network cards and protocol stacks was one of my first approaches, however that didn't work. Some of the other things I've tried include (all with no successful effect):
-Changing the computer name
-Change to quick login
-Deleted password files (*.pwl)
-Remove clients and stacks, restart and re-add clients/stacks

I've spent a great deal of time observing it by doing the above incrementally rather than in one fell swoop so as to hopefully spot the trouble area. In the adding of clients/protocol stacks the following version conflicts appeared (where an attempted file to copy from Win95 OSR2 was older than the existing file):
secur32.dll (4.10.1057)
rpcltc1.dll (4.71.112590848)
rpcltc5.dll (4.71.112590848)
rpclts5.dll (4.71.112590848)
vredir.vxd  (4.0.1116)
0
 
LVL 1

Expert Comment

by:jminck
ID: 1794623
you might try a network sniffer & see what is going on during the login process.....
0
 

Expert Comment

by:trd
ID: 1794624
Have u tried another NIC? Or updated the existing NIC driver?
What about NetBios for IPX/SPX? If it is installed, try removing it.

0
 
LVL 1

Expert Comment

by:ahood
ID: 1794625
At your configuration the Computer log's to Novell and pass the parameters to the NT logon.

Are both Novell and NT using same USER NAME ?

I suggest rename / delete  the "*.pwl" at the windows directory , i guess somthing is wrong with the paswword list.
0
 

Author Comment

by:mwyatt
ID: 1794626
I haven't tried a network sniffer yet, but that's a possible idea. This shows no indications of a hardware issue, so replacing the NIC is probably not a worthy choice. Also, Netbios is not enabled over IPX, and Netware and NT use identical names. I'm still testing other areas...
0
 
LVL 23

Expert Comment

by:Tim Holman
ID: 1794627
MWyatt,
  For a long term solution, why not disable NetBEUI ?
  I've come across this problem before and have fixed it by either shifting the PC to another network port or by logging on locally, changing the domain, then changing it back again...
  I put it down to a network problem.
  Sometimes turning it off for five minutes, then powering on again sorts it out..
  You may have a duplicate NetBIOS name on ANOTHER segment ??
  Try changing the NetBIOS name....
  Oh dear... broadcasts broadcasts broadcasts....

Tim
 
0
 

Accepted Solution

by:
ChrisRobin earned 50 total points
ID: 1794628
This sounds as it  is a silly microsoft IPX implementation problem.
On both the NT and 95 box you have to set the frame type to be 802.3 ((automatic will not work!!!)Control panel..Network...IPX protocol...advanced)
If it is not this you may have screwed the trust relationship between the NT4 box and the 95 box
0
 
LVL 23

Expert Comment

by:Tim Holman
ID: 1794629
This isn't really a solution...
Windows, when configured to 'automatic' will pick up and use as default the first IPX/SPX frame type it sees.
So - if manually selecting a frame type cures the problem, then this means there are definitely other frame types reaching your PC that you need to either filter out or eliminate from source in order to reduce network congestion.
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Today, still in the boom of Apple, PC's and products, nearly 50% of the computer users use Windows as graphical operating systems. If you are among those users who love windows, but are grappling to keep the system's hard drive optimized, then you s…
When you try to extract and to view the contents of a Microsoft Update Standalone Package (MSU) for Windows Vista, you cannot extract the files from the MSU. Here we are going to explain how to extract those hotfix details without using any third pa…
With the advent of Windows 10, Microsoft is pushing a Get Windows 10 icon into the notification area (system tray) of qualifying computers. There are many reasons for wanting to remove this icon. This two-part Experts Exchange video Micro Tutorial s…
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.

730 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question