Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 232
  • Last Modified:

Hard drive installation

I just installed a new 6.4 Gig HDD into my system.  I partitioned it into the following drive letters: c: d: e:.  Now my cd-rom is not showing up.  How do I assign the letter f: to my cd-rom and get my computer to recognize it?
0
jkemper
Asked:
jkemper
  • 10
  • 4
  • 3
  • +2
1 Solution
 
Lee W, MVPTechnology and Business Process AdvisorCommented:
add LASTDRIVE=F to you're config.sys file.  (or to prevent this problem from happening again to any new device, make it LASTDRIVE=Z.

If that doesn't work, double check the autoexec.bat line with MSCDEX in it.  I believe the /L: switch specifies the drive letter to assign the drive.  Normally MSCDEX will give it the next available drive letter, but sometimes if that switch is set, it won't.
0
 
jkemperAuthor Commented:
This sounded like a good answer.  But it didn't work.  I put the LASTDRIVE=Z in the last line of the config.sys file, would that make a difference.
0
 
Lee W, MVPTechnology and Business Process AdvisorCommented:
No, the placement in CONFIG.SYS is not important.

How about this:  What operating system are you using?  95?  NT?  3.11?  If 3.11 (and DOS 6.2) press F8 as soon as you see "starting MS-DOS" and "step through" the boot.  Note any error messages that may appear.

You know, I completely missed this, too.  Look in config.sys - do you see any line beginning with DEVICE= and somewhere on that line having "/D:" in it.  for example:

DEVICE=c:\cdrom\mtmcdai.sys /D:mscd001

If not (and you're running 3.11), then you aren't loading the driver.  

Please post what operating system you use and we'll try to work with it some more.
0
Who's Defending Your Organization from Threats?

Protecting against advanced threats requires an IT dream team – a well-oiled machine of people and solutions working together to defend your organization. Download our resource kit today to learn more about the tools you need to build you IT Dream Team!

 
jkemperAuthor Commented:
I'm using Win 95 without OS2.  There are no error messages when I bootup and check the Bios setup.  It shows that the Cd-rom is installed and the appropriate driver is installed.
YES, Idid notice the lines in autoexec.bat and config.sys with d:/mscd0001.  Ichanged the letter to f in both files and that did nothing.  When I installed the new drive, I used the data cable from the CD-ROM to hookup the old drive so that I could copy it to the new drive.  Everything is fine except that the CD-ROM is not showing up in Windows.
0
 
jkemperAuthor Commented:
This is an ULTRA DMA EIDE HDD.
0
 
Lee W, MVPTechnology and Business Process AdvisorCommented:
Ah, there's a mistake.  the /d:mscd0001 is the name of the driver.  /D: needs to be present in both. Change the /F: back to /D: in config.sys and make the line in autoexec.bat read exactly as follows:

mscdex /d:mscd0001

mscd0001 is the name.  if config.sys said /d:cd then autoexec.bat must have mscdex /d:cd

then press F8 when you see "Starting Windows 95" and note any error message from either of the two lines.  Then post them.  Actually, if you could post the lines from config.sys and autoexec.bat I can make sure everything set properly.
0
 
jkemperAuthor Commented:
I will do that and get back soon.
0
 
dacopelCommented:
I've had problems related generally to win 95 not seeing CD ROM.  Problem has been related to win 95 starting up before cd rom has initiallised. One answer is to put "pause" in autoexec.bat before win95 starts, you then have to press a key to continue and CD rom has time to initiallise.  Delay can also be made by inserting Choice "wait for cd rom".  Check also how you have cabled up. Are you running hard drive and cd rom from same cable and IDE socket, if so use separate cables for hard drive and cd rom, this worked for me.
0
 
jkemperAuthor Commented:
I never had this problem until I installed the new hard drive today.  I've had this computer for almost three years.  YES, I do have them running off of separate cables.
0
 
dacopelCommented:
if you use the "choice" route check your dos documentation how to do this as I can't rememebr the line in detail and am presently away from home on business
0
 
jkemperAuthor Commented:
to leew:

I did as you said, there were no error messages at all.  Here are my files

autoexec.bat
@ECHO OFF
C:\SOUND144\UTILITY\AZCAL.EXE
PROMPT $P$G
SET PATH=C:\WINDOWS;C:\WINDOWS\COMMAND;C:\;C:\XWORLD
rem - By Windows Setup - LH C:\WINDOWS\COMMAND\MSCDEX.EXE /D:MSCD0001 /M:20 /S /L:D
SET DIRCMD=/O
SET TEMP=C:\PBTOOLS\WINTEMP
SET WINPMT=[WINDOWS] $P$G
SET BLASTER=A220 I5 D1 T4
SET GALAXY=A220 I5 D1 K10 P530 T6
SET SOUND=C:\SOUND144
IF EXIST C:\VGA\CLMODE.EXE C:\VGA\CLMODE T640=60 T800=60 T1024=87 T1280=0
REM                          
REM              
REM  

config.sys
DEVICE=C:\WINDOWS\HIMEM.SYS
DOS=HIGH,UMB
DEVICE=C:\WINDOWS\EMM386.EXE NOEMS I=B000-B7FF
FILESHIGH=50
BUFFERSHIGH=20
STACKSHIGH=0,0
FCBSHIGH=1
DEVICEHIGH=C:\WINDOWS\MOUSE.SYS
DEVICEHIGH=C:\PBTOOLS\CR_ATAPI.SYS /D:MSCD0001
LASTDRIVE=Z
0
 
ryanicCommented:
I think you should just simply go to device Manager of your Windows and go to the properties of your CDROM drive. Go to the settings TAB and then reserve the drive letter F: (or whatever you wish) for the start and end drive letter.

Restart your system and pray hard.

:-)


0
 
jkemperAuthor Commented:
There is no settings tab or anywhere in the device manager to reserve drive letters.
0
 
dacopelCommented:
Still think your probem is related to late initiallisation of CD rom. Try uninstalling cd rom driver and removing lines in autoexec.bat and config.sys which refer to cd rom.  Reboot, if win95 sees cd rom as new hardware then install driver. if win95 does not see cd rom as new hardware then check in device manager if cd rom is present. rebbot a few times and each time check device manager to see if cd rom is present. If present sometimes and not others then for sure initialiation id the problem. If this is the case then on on of the occasions cd rom can be seen in device manager then use change driver option to install driver.  
Your line autoexec,bat which is  *rem by windows set up" indicates that win95 does sometimed see the cd rom.  You may find that cd rom works ok without installing the driver at all.
0
 
jkemperAuthor Commented:
I gave it a shot, but it didn't do the trick.  When my computer is booting, it says that cd-rom found and it then shows the driver info for the cd-rom.  It does all this before windows starts booting.
What I need are the system files from a Windows 95 OSR1 system.  (4.00.950.a)  (drvspace.bin, command.com, io.sys, and msdos.sys)
0
 
OttaCommented:
> rem - By Windows Setup - LH C:\WINDOWS\COMMAND\MSCDEX.EXE
    /D:MSCD0001 /M:20 /S /L:D

Remove all the text before the 'LH'.

Use 'F8' during boot-up, and check the message(s)
written by the execution of the above (corrected) command.
0
 
jkemperAuthor Commented:
Where was Otta about 6 hours ago when I was pulling my hair out.  You nailed it.  That little bit of text is the cause of my last six hours of stress.  Great job!!  Your response was greatly appreciated.
0
 
Lee W, MVPTechnology and Business Process AdvisorCommented:
I'm 99% certain one or both of the following actions will work:

The first thing that should work regardless:
====================================
do not change anything in config.sys for this part.
The current line in autoexec.bat that reads:  
rem - By Windows Setup - LH C:\WINDOWS\COMMAND\MSCDEX.EXE /D:MSCD0001 /M:20 /S /L:D

Otto is somewhat correct.  The "rem - By Windows Setup -" is a remark ("rem" = remark and windows/dos won't process that line) However the end of it can be removed as well.  Change it to read:
LH C:\WINDOWS\COMMAND\MSCDEX.EXE /D:MSCD0001

I don't recall the /M switch - I know it's valid, but it's not necessary.  the /S switch, as I recall, was related to sharing under Windows 3.1x/DOS 6.2x and is, again, unnecessary.  The /L:D is saying to assign the CD-ROM drive letter D, which won't work now because of the hard disk partition.  When /L:x is not specified, MSCDEX assigns the next available drive letter, so unless you want the CD to be a particular drive letter, this switch is also unnecessary.



The second thing:
================
Edit both config.sys and autoexec.bat.  Place an "REM " in front of both the line with "LH C:\WINDOWS\COMMAND\MSCDEX.EXE /D:MSCD0001" in autoexec.bat and an "REM " in front of "DEVICEHIGH=C:\PBTOOLS\CR_ATAPI.SYS /D:MSCD0001"

Now provided you don't shut down to DOS for anything, this should provide a little better performance for the CD-ROM drive.  95 SHOULD be able to find the CD-ROM on it's own, but I've seen strange problems with Packard Bell machines, especially related to CD-ROMs, Modems, & Sound Cards.  So if the CD-ROM isn't found like this, just undo the "REM "'s above.
0
 
jkemperAuthor Commented:
Thanks for your help leew.  What Otta said done the trick.
0

Featured Post

Evaluating UTMs? Here's what you need to know!

Evaluating a UTM appliance and vendor can prove to be an overwhelming exercise.  How can you make sure that you're getting the security that your organization needs without breaking the bank? Check out our UTM Buyer's Guide for more information on what you should be looking for!

  • 10
  • 4
  • 3
  • +2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now