• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 230
  • Last Modified:

Apache problem

How can I allow any user to have cgi-scripts in their public_html dir?

0
wqclatre
Asked:
wqclatre
  • 3
1 Solution
 
wqclatreAuthor Commented:
Edited text of question
0
 
harrysCommented:
0
 
wqclatreAuthor Commented:
But I have AddHandler cgi-script .cgi in my /etc/httpd/conf/srm.conf

I have done chmod 755 ~/public_html/test.cgi

And I still get:
 Forbidden

You don't have permission to access /~user/finger.cgi on this server

0
 
alfarrisCommented:
In addition to setting the AddHandler in srm.conf, you've also got to set up permissions
to execute CGI scripts for the directory hierarchy that contains your user account directories in access.conf. If all of your user directories are in /home try:

<Directory /home>
Options ExecCGI
</Directory>

Chances are if you have a recent version of apache there is a <Directory /home> directive
already in access.conf.

Another thing you can do is use the location directive try:

<Location /~*>
Options ExecCGI
</Location>

This will apply to any location accessed with a url that begins with '~' such as
http://www.mysite.com/~user

I haven't actually tried either of these, but they should work in combination with the modification to srm.conf mentioned above.

don't forget to restart your webserver after you make the changes.
0
 
wqclatreAuthor Commented:
Thanks!!!!!!!!!!!!!!!!!!
0

Featured Post

 [eBook] Windows Nano Server

Download this FREE eBook and learn all you need to get started with Windows Nano Server, including deployment options, remote management
and troubleshooting tips and tricks

  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now