Solved

Timeout Error!

Posted on 1998-11-14
8
1,479 Views
Last Modified: 2008-02-26
Im am accessing a Sybase system 10 database using Visual Basic and ODBC. There are a number of clients in operation.
When performing an Update to the database, the client occasionally times-out and the following message is returned from ODBC.

S1T00:[INTERSOLV][ODBC SQL SERVER DRIVER][SQL SERVER]ct_results():user api layer: internal Client Library error:Read  from the server has timed out."

This only happens when there are a lot of people using the system. When a single person is accesing the database, it all works fine.
Could the server be causing this problem?
0
Comment
Question by:Coates
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
  • 2
  • +1
8 Comments
 

Author Comment

by:Coates
ID: 1098428
Sorry, thats a sybase sql server version 11
0
 
LVL 5

Expert Comment

by:n0thing
ID: 1098429
On which OS your Sybase is running ?? Solaris ? SunOS ?? HP/UX ?? NT ??
0
 

Author Comment

by:Coates
ID: 1098430
It is running on a Solaris Server.
I am writing a lot of Long data (TEXT etc).
Could this cause the problem?
0
Moving data to the cloud? Find out if you’re ready

Before moving to the cloud, it is important to carefully define your db needs, plan for the migration & understand prod. environment. This wp explains how to define what you need from a cloud provider, plan for the migration & what putting a cloud solution into practice entails.

 
LVL 5

Expert Comment

by:n0thing
ID: 1098431
I would suggest you to run the 2 following commands as root:
ndd -set /dev/tcp tcp_old_urp_interpretation 1
ndd -set /dev/tcp tcp_keepalive_interval 10000

and add it to your /etc/inetinit so if you reboot your system
it will remain set. This will set your keep alive timer long enough at the network level so your packets doesn't get discarded by the system.
0
 

Expert Comment

by:bmoore111898
ID: 1098432
Have you checked the max number of user connections allowed?  Maybe that or # of open databases.  You could be hitting up against one of these.  Check em with sp_configure

just a guess
0
 
LVL 2

Accepted Solution

by:
ajith_29 earned 100 total points
ID: 1098433
Check with sp_configure with time out option.The reason is there are many process running and the multi-threaded application has to run on your server.So the treads to get the work done as to wait a much longer, so give the time out opption it little bit larger than the previously set value.If this also does not work edit your interface file in which you give the delay time for the server.
0
 
LVL 2

Expert Comment

by:ajith_29
ID: 1098434
inform me what all options are sent with just sp_configure command.
0
 

Author Comment

by:Coates
ID: 1098435
Ive already sorted this out...I was opening far too many connections and recordsets without closing them on my client, coupled with sending large amounts of text data. This made the affair very slow, but ive fixed it now, thanks.
0

Featured Post

Announcing the Most Valuable Experts of 2016

MVEs are more concerned with the satisfaction of those they help than with the considerable points they can earn. They are the types of people you feel privileged to call colleagues. Join us in honoring this amazing group of Experts.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

With the rising number of cyber attacks in recent years, keeping your personal data safe has become more important than ever. The tips outlined in this article will help you keep your identitfy safe.
Originally, this post was published on Monitis Blog, you can check it here . In business circles, we sometimes hear that today is the “age of the customer.” And so it is. Thanks to the enormous advances over the past few years in consumer techno…
In this video, viewers are given an introduction to using the Windows 10 Snipping Tool, how to quickly locate it when it's needed and also how make it always available with a single click of a mouse button, by pinning it to the Desktop Task Bar. Int…
Monitoring a network: why having a policy is the best policy? Michael Kulchisky, MCSE, MCSA, MCP, VTSP, VSP, CCSP outlines the enormous benefits of having a policy-based approach when monitoring medium and large networks. Software utilized in this v…

617 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question