Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 241
  • Last Modified:

Modem dosen't work under win98

I have installed a new win98 installation on my hard disk and everything seem's to work except for the dial-up part.
If I try to dial up I get always the same fault = 560 (I think it was) anyway it says that there is no modem answer and I should try to put the power on and off).
But I have a internal US robotics modem and as far as I have test it I have No collisions in the system and I can use the hyperterminal to send a AT kommand to the modem.
If I try under control panel -> modem and choose 'more info' Then you get alot of data from the modem, the configuration and some more stuff.
As far as I understand The modem is working and allsow the TAPI because I get the answer from the modem when I choose more info. By the way I have tryed to install it several times both the modem (with PnP and the hard way, choosing av port)and the hole win98 but it is allways the same result, any suggestions ?
0
Snowman
Asked:
Snowman
  • 5
  • 3
  • 2
  • +6
1 Solution
 
netmageCommented:
It seems that win 98 knows there is a modem so it might actually be a fault or error in the hardware.

I would assume that you have the latest drivers for your modem.

Since you know how to get to a terminal prompt.

Try these commands.

ATD 123      to test for a line dial tone ( i hope you have speaker enabled)

ATA          To test and check for negotiation.

If this fails.

Try
AT@F     To reset to factory defaults and try again

Try this and we'll work back from there.


0
 
rmarottaCommented:
Will the modem dial using Hyperterm? (ATDT followed by phone number)
If so, I would try to re-install DUN.
If not, verify phone line connection.
Regards,
Ralph
0
 
Tim HolmanCommented:
Snowman,
  Under Control Panel > Modem > Properties > Connection > Advanced, does View Log show anything interesting ?
 
Tim

0
The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

 
Asta CuCommented:
Have you tried using the troubleshooter for your modem problem?  Have you confirmed your dial-up settings (ie. TCP/IP or whatever your protocol is).  When you ran the modem diagnostics, they should have provided the maximum baud rate on that screen, make sure your COM port speed, modem speed, port setting, etc. are synchronized to the same speed.  Your ISP (whoever your internet service provider is), may also have connection settings you must check.  Lastly, of course, is to ensure that you have no IRQ conflicts.  Hope this helps.
0
 
joshbopCommented:
You may simply have the wrong modem selected in your Dial Up Networking Configuration for the ISP you wish to connect to.

Try Double Clicking "My Computer" then "Dial-Up Networking" and locate the icon for your connection.  Right Click over this icon and then choose "properties" from the menu that appears.  A dialogue box should appear and show the modem it is trying to use to connect with.  Next to the modem name, there is a small arrow (pulldown) that will allow you to select the correct modem that is installed.

I dont propose this is the answer, but definately a check worth doing.  As an ISP Administrator, I have seen this fault a few times.

0
 
mwakefieldCommented:
This isn't neccessarily an answer but a way of determining whether the modem driver (.inf) file is the culprit...

Try changing the modem driver to a Standard 28800/33600/57600 Modem driver...(depending on the speed of your modem)...and see if that works...

The only difference between these drivers and the drivers supplied by modem manufactures (except Winmodems) is that compression and error correction is enabled in the manufacturer supplied drivers (.inf)...
0
 
SnowmanAuthor Commented:
First I want to say thank's for the suggestions everyone ( I have been out traveling and was really suppriced about the response her), To answer/check your suggestions before I tell you what the solution was !,
mwakefield:
It hasen't been any difference I have tryed with several different "modems". Yes If I use hyperterminal I can phone with ATDTxx and allsow answer with ATA.

rmarotta:
se above, But what is a DUN ? and how to re-install the DUN I dont know ?

tim_holman:
Nothing in the logfile discovers whats the problem

astaec:
Yes, But nothing helps in the troubleshooter, No IRQ conflicts could be detected.

joshbop:
This one as you say is a good one but everything was as it should bee.

THE SOLUTION ( I think )
Tonight I'm going to end this (installation) I think, When I installen windows98 I did almost everything except running the Internet guide and the other stuff in the dialog who shows up by itself, because in windows95 you could just setup by yourself a dialup connection BUT now you MUST run the guide first, after that you can do as before in the dial-up setup. I really dont know or understand why I must run the guide but it started to work a little better, The modem could phone but after a few seconds the windows reported "no modem", I disabled the option "wait for a sound before dialing" then everything start to work as it should do. ( I hope ), I'm coming back with the information from the final test later.

/Snowman
0
 
Asta CuCommented:
Great, sounds hopeful.  I hasten to add that although Windows 98 has improved diagnostic tools, it couldn't detect IRQ conflicts relative to I2 and I9 (cascaded IRQs), when for a DOS game, some craziness flared up fiddling with Dosstart settings and within the game setup.  Sound IRQs modified to I2,I9 in various iterations and obvious lock/up, lock outs.  Device Manager detected no conflicts -- think these are the exceptions.
0
 
rmarottaCommented:
Snowman,
Since the modem diagnostics work in Control Panel, and it dials okay in Hyperterm, I think there is no problem with your modem at all.
Windows just needs DUN (Dial-Up Networking) installed & configured correctly in order for it to dial out automatically.
The internet wizard should prompt you for what's needed, but let me know if you need more help to set it up.
Regards,
Ralph
0
 
linschotenCommented:
Under Control Panel > Modem > Properties > Connection > Advanced
Put an ATZ command in there . I have setup a number of machines with the USR modems and that always seems to be needed. Almost as if the setup string is incorrect.
Internal modems work best on Comm 3 or 4. If you have a serial mouse on Comm1 Irq 4 then I would suggest using Comm4 Irq3. Most Usr's these days are PnP and Comm3 is usually the next available setting as most machines use the bus mouse connection.
0
 
SeanHaffeyCommented:
IF - and only if - you have the modem driver diskettes then try uninstalling the modem driver.  Go to Control Panel ->  System -> Devices and then select the modem and uninstall it.  Then re-boot.  W98 will recognise "new" hardware and go through an auto-install, at which stage you can click on the "Have disk" button and point W98 at your modem driver.

*** But make sure that you have the driver first ***
0
 
rmarottaCommented:
There is no need to install another modem driver.
Read the thread........
The modem works.
Snowman, I suggest you reject that "answer".
Ralph
0
 
SnowmanAuthor Commented:
Yes you are right "rmarotta", Please Read the thread SeanHaffey I find the fault (atlast). But thanks anyway.
The final solution was as I said before ( Se above ). now it work's as it should have done in the first place.
I'm little confused know, I wonder If I should delete this question or ??, The question should be closed I think. Anyone know what todo now ??

Thanks everyone for your suggestions

/Snowman
0
 
rmarottaCommented:
Invite the person who helped you solve the problem to post an answer for you to grade.
The question will then be saved in the PAQ.
Regards,
Ralph
0
 
SnowmanAuthor Commented:
rmarotta:
Yes, but there was a lot of suggestions her none solve the problem for me, ( I discovered bye myself ).
maybee you ( = RMAROTTA ) can help me, please post a answer on monday so I can close this thread.
Note!. If anyone claims for the point he or she should do it before monday.
0
 
rmarottaCommented:
Snowman,
Here is an "answer" for you.
Regards,
Ralph
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

  • 5
  • 3
  • 2
  • +6
Tackle projects and never again get stuck behind a technical roadblock.
Join Now