Solved

CD ROM INSTALL PROBLEMS

Posted on 1998-11-16
28
218 Views
Last Modified: 2010-04-27
After installing an IDE cd rom drive the machine found it o.k. and everything was fine, after rebooting it told me that there were hardware conflicts with my "standard floppy drive" and my Intel IDE Controller. Win 95 would not let me change the settings for either device and if I removed the "standard floppy drive" windows just reloaded it after booting up. Besides I need that device as much as the other. I do have a secondary port on my mother board but if I plug into this windows never sees the cd rom drive. I used auto detect in the bios and it did not find it. how do I turn on this secondary. The bios is AWARD. circa 1995.
0
Comment
Question by:kasdas
  • 12
  • 4
  • 4
  • +4
28 Comments
 

Author Comment

by:kasdas
ID: 1129152
Edited text of question
0
 

Expert Comment

by:Libidinous
ID: 1129153
I believe that reinstalling Windows 95 will fix the problem. You could also try removing the Intel IDE driver and the floppy driver and rebooting. When Windows restarts it should find both devices and assign the appropriate settings. Hope this helps
0
 

Author Comment

by:kasdas
ID: 1129154
The first part of your answer may or may not be correct. I cannot reinstall win 95 with out a cd rom drive. I tried the second suggestion and it did not work. windows found the floppy upon booting up but I had run "find hardware" to find the IDE controller. I ended up with the same problem
0
 

Expert Comment

by:Libidinous
ID: 1129155
So you can't access the CD-ROM from DOS either? You may want to check the BIOS settings to make sure it's not assigning IRQ's.
0
 

Author Comment

by:kasdas
ID: 1129156
Could you please elaborate? And if it is what do I do to keep it from assigning the IRQ?
0
 

Expert Comment

by:Libidinous
ID: 1129157
So you can't access the CD-ROM from DOS either? You may want to check the BIOS settings to make sure it's not assigning IRQ's.
0
 

Expert Comment

by:Libidinous
ID: 1129158
sorry about that repeated comment. I'm not sure. I don't know what motherboard you have. If you have a manual for the board, it should have a section for BIOS settings.
0
 
LVL 3

Expert Comment

by:gward28
ID: 1129159
is plug and play enabled in your bios?
have you tried using another driver to install the cd-rom?
what is the cd-rom? (you said ide but no bran name)
and are the jumpers on the cd-rom right (slave for primary ide)
(master for secondary Ide)
make sure that the bios(cmos setup)does not have drives on these
ports.
<example>
pri.master  your hard drive
pri.slave   none  cd-rom as slave
sec.master  none  cd-rom as secondary master
sec.slave   none

(if you have more then one hard drive this may very)
make sure none appiers where a cd-rom is placed
if your looking for different cd-rom driver try mitsumi's
disk inspector install it while your in dos.e-mail me at gward28@hotmail.com and I can send it to you.
hope this helps :~)
0
 
LVL 3

Expert Comment

by:cumbo
ID: 1129160
kasdas,

Check under the "Performance" tab under the "System" icon in control panel. See if any drive running in DOS Compatability mode. If it is do the following:

1. Click Start, Run and type regedit

2. When the registry editor opens click edit, find.

3. Type noide in the find box.

4. If an entry is found right click on it and click delete.

5. Close the editor box.

6. Goto Device Manager and expand your Disk Controller entry.

7. If there are three listings:
       a. Primary FIFO controller
       b. Secondary FIFO controller
       c. Master IDE Controller
(Your entries may vary in wording)
Click on the Master and click remove. Note: Your computer may or may not lock up after removing the driver. If it locks up push the reset button.

If it tries to stsrt in Safe mode, arrow up to Normal mode.

0
 

Author Comment

by:kasdas
ID: 1129161
regedit found no "noide". Here is something that may help, If I remove the conflicting hardware then have windows find new hardware it installs everything just fine with no conflicts. After I reboot the cd rom is gone and I have the conflicts.
0
 
LVL 17

Expert Comment

by:xema
ID: 1129162
Plug the CD on the secondary IDE, during startup go to BIOS setup, go to peripherials and scroll down. You should find something like "Secondary IDE contoller" set to enable.   Save your new BIOS settings and let the startup process continue.

DON'T forget to set your CD to master, this is acomplished by the jumper in the back located above the cable connector. Also don't use IDE autodetect because it won't detect the CD.

If your problem continues please post the version of your BIOS, CPU & chipset or the long string at the bottom left of your monitor during bootup
0
 

Author Comment

by:kasdas
ID: 1129163
xema,Your suggestion did not work. The computer failed to find the cd rom and I again encountered conflicts. The bios is Award Modular Bios Ver. 4.50pg. there are the following letters and numbers under this heading. These are MB-8500 Tel 06/07/95. In the lower left corner on boot it reads, 06/07/95-Triton 2A59CB0900. Also, in my bios I did not find anything saying peripherials. In "Standard Cmos Set Up under hard disks I did not have the "enable" option on the Secondary Master I had the options of auto, user and none and numbers 1 thru 45. In the Bios Features Set Up there was nothing about drives. In the Chipset Features Set Up under Secondary Master PIO I had options of auto master and Modes 1 thru 4. I don't Know what my chipset is but the CPU is a Pentium 90 Intel. Boy I hope this info helps!
0
 
LVL 3

Expert Comment

by:gward28
ID: 1129164
kadas is it possible that you have the wrong driver for your cd-rom?
is PNP enabled in your bios?
also some hard drives have jumper settings of master,or master with slave.if your Hard drive jumpers are set wrong it can cuase
conflicts such as this one .
also as i stated above I can send you a different driver to see if that might be the problem.:~)
0
 
LVL 17

Expert Comment

by:xema
ID: 1129165
OK
Under Chipset
you got the following
>On chip secondary 2nd chanel PCI IDE
>PCI slot IDE 2nd chanel

Enable both

In your Config.sys and Autoexec.bat rem the lines reagarding the CD and MSCDEX.
Check that your CD is set to master

0
Free Trending Threat Insights Every Day

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

 
LVL 17

Expert Comment

by:xema
ID: 1129166
Sorry I've forgot something you may need to add an Intel Patch for Bus mastering, wich version of WIN 95 do you have.
OK
    Under Chipset
    you got the following
    >On chip secondary 2nd chanel PCI IDE
    >PCI slot IDE 2nd chanel

    Enable both

In your Config.sys and Autoexec.bat rem the lines reagarding the CD and MSCDEX.

Check that your CD is set to master
0
 
LVL 3

Expert Comment

by:cumbo
ID: 1129167
kasdas,

You have never said what the CD is conflicting with..By default the
Primary IDE is set for IRQ 14 and the Secondary for IRQ 15. Is ther
something conflicting with one of these IRQ's? If so, you must
change the IRQ of the conflicting device. You cannot change either
of the above settings.

How does the conflict show up? Is it via a Windows message?

Cumbo
0
 
LVL 3

Expert Comment

by:cumbo
ID: 1129168
kasdas,

Scratch the last message, I just went back and read the question
again. I am acting like a newby expert; sorry. The IRQ's for
both devices (floppy controller and IDE) are set by the BIOS.
They are not set by Win 95.

Is the hard drive conflicting as well?? If not and, the CD is set
as a slave on the primary, it is possible you have a bad CD drive.

Cumbo
0
 

Author Comment

by:kasdas
ID: 1129169
xema, Both bios setting you listed were already enabled. I played some more and now the Intel 82371fb pci bus master ide controller that was conflicting is still conflicting with the standard floppy controller but the properties for the standard floppy shows no conflicts. The computer still cannot find the cd rom drive. I am very tired, confused and ready to say to heck with this but it's my son's machine so I'll raise the points by 50 and continue on.
Of note, I found some information on "ms-dos compatibility mode problems with PCI-IDE controllers and it sounded like my problem except there is no "noide" in my registry. The article I read said that there would be. One more thing, I am running an older version of windows, I am not sure which version.
0
 

Author Comment

by:kasdas
ID: 1129170
Adjusted points to 150
0
 

Author Comment

by:kasdas
ID: 1129171
cumbo, the hard drive is just fine and working well. the cd drive runs just fine in my machine and i have the manufactures installation disk with the right drivers
0
 
LVL 17

Expert Comment

by:xema
ID: 1129172
Three basic questions:
1. Are you shure that you are conecting the red marked side of the flat cable to both Pin one in the MoBo connector and the CD connector
2. Have you got the patch for the Intel IDE Controller?
3. Click the Start button & run  type regedit.exe, use the find function under edit and search for noide, if you find it, write in a pice of paper where it is and then delete it.
0
 

Author Comment

by:kasdas
ID: 1129173
Connections are correct. search did not find a noide. Where do I find this patch for the controller?
0
 
LVL 23

Expert Comment

by:Tim Holman
ID: 1129174
Kasdas,
  It appears the thread has been lost somewhat...
 
  Is your hard disk the first on the IDE cable coming out of your primary IDE controller and set to MASTER ?
  Subsequently, is the CD ROM attached 2nd in line on the IDE cable set to SLAVE ?

Tim
0
 

Author Comment

by:kasdas
ID: 1129175
Tim, Yes the hard disk is the first on the cable coming out of the primary ide. The cd drive is now  connected to the secondary ide port. At first it was as you asked, the second in line after the hard disk and the cd rom was set to slave. That is when the conflicts started.
0
 

Author Comment

by:kasdas
ID: 1129176
My problem has been fixed but I am not sure who gets the points. It was actually a number of things that were done to make my drive work but the most important thing I think was that I ended up running FDISK, deleting and re-partitioning, formatting and doing a clean win98 install. Thanks for all your help and I will be sure to tell everyone I know with computer related problems to try the experts exchange. Thanks again!
0
 
LVL 3

Expert Comment

by:cumbo
ID: 1129177
kasdas,

Since you fixed the problem yourself there's no need to award
points unless you wish to. If you wish to award points ask the
expert you wish to award to to post an answer.

If not, post a question to Linda in the lounge to remove the
question.

Glad you resolved the problem.

Cumbo
0
 

Author Comment

by:kasdas
ID: 1129178
Thank You!
0
 

Accepted Solution

by:
cyrix_100 earned 150 total points
ID: 1129179
ok
set your cd rom jumper for master.(must set your Hard disk to master to)
connect your hard disk to IDE 1
connect your cd-rom to IDE 2
restart your computer.

after that check your cmos setup, get to auto to primary and secondry master.
try to install your cd-rom..


if not working try..

reinstall your windows again..

or if not working again

format your computer and install back your windows

or use win98 startup disk...
 
0

Featured Post

Backup Your Microsoft Windows Server®

Backup all your Microsoft Windows Server – on-premises, in remote locations, in private and hybrid clouds. Your entire Windows Server will be backed up in one easy step with patented, block-level disk imaging. We achieve RTOs (recovery time objectives) as low as 15 seconds.

Join & Write a Comment

Every server (virtual or physical) needs a console: and the console can be provided through hardware directly connected, software for remote connections, local connections, through a KVM, etc. This document explains the different types of consol…
Internet Business Fax to Email Made Easy - With eFax Corporate (http://www.enterprise.efax.com), you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, fr…
Here's a very brief overview of the methods PRTG Network Monitor (https://www.paessler.com/prtg) offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…

746 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

15 Experts available now in Live!

Get 1:1 Help Now