Error spawning cl.exe - MS VC++ 6.0

I'm getting the following error message when trying to compile a project I'm working on using Microsoft's Visual C++ 6 -> "Error spawning cl.exe". Anyone know what this is about and/or how to resolve the issue?
KriegerAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
cssathyaConnect With a Mentor Commented:
Spawning Error occurs when VC cannot find its files in the desired path. The best and sure fire method is to uninstall VC and re-install it once again. Though this may take some time, this will surely solve the problem.
If u feel queasy about re-installing, you have to check and ensure that the source files are all in their respectiive places. For that u have to go to Options menu and verify that the directories in the options menu match the actual paths.

Personally I would prefer you to re-install the software as this will eliminate the possibility of generating more errors in the future. I did that once and it worked fine.

All the best.
0
 
KriegerAuthor Commented:
Edited text of question
0
 
KriegerAuthor Commented:
Edited text of question
0
Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

 
nietodCommented:
It sounds like VC cann't find its CL compiler or is finding the wrong one.

Look for other cl.exe's that might be in your path.  
Aref you are running from the command line?  If so, make sure your path includes the path set by the VCVARS.BAT batch file.
0
 
perrizoCommented:
It's possible to create a share problem if cl.exe is locked by another process.  This can happen if VC locks during linking and you have to end VC abnormally.  Just a thought?
0
 
Tommy HuiEngineerCommented:
Check Options | Tools | Directories. In the dialog, make sure the Executables directory includes the VC/Bin directory. If there are more than one paths, move it to the top of search order.
0
 
KriegerAuthor Commented:
Thui,
The VC/bin directory containing cl.exe is at the top of the search order. (c:\Program Files\Microsoft Visual Studio\VC98\bin)

Perrizo,
I've rebooted recently and VC hasn't locked since.

Nietod,
I'm not on the command line, and there is only one cl.exe on my machine.

Thank's for the help. I'll keep investigating and if I figure it out on my own I'll put a comment up.
0
 
KriegerAuthor Commented:
This is ridiculous. I just uninstalled and reinstalled VC 6 and I still get the same error trying to compile anything, not even a simple hello world program. I don't get it. I'm going to have to call in the big guys on this one because I'm obviously not dealing with a programming error here. Thanks to all who responded.
0
 
nietodCommented:
cssathya, please read the question history.  In the comment right above your answer he says that he reinstalled and that didn't help.
0
 
KriegerAuthor Commented:
O.K., I uninstalled and reinstalled _again_, this time deleting all the garbage folders & files that were left behind by the uninstaller before I reinstalled. Things seem to be working again, but I still don't know why it got hosed in the first place. cl.exe was in the right path and thigs seemed to be set up correctly. Oh well, thanks to all who responded.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.