Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

IIS on NT trying to get to Netware server.

Posted on 1998-11-17
12
Medium Priority
?
185 Views
Last Modified: 2013-12-25
I'm not sure if this is the correct area for this question, but is seems like the most appropriate so I will post it here. If someone thinks it belongs in the Networking area then I'll put it there.

Anyway, here's my question...

I am using IIS3.0 on NT4.0. Everything that I have done so far has worked just fine. I now want a link on my web page to reference something on a Netware server. This doesn't work so well.

Let me give you an example...

If I have

<a href="docs/page1.html">

this works fine because my browser knows that my home directory is wwwroot and therefore will point to

"http://wwwroot/docs/page1.html

But if I want to get to my Netware server, I can't just say

<a href="h://lab/page2.html">  
[where H: is mapped to my netware server]

because drive letters are meaningless to IIS.

So, since I can't use drive letters to specify where my links will go, I believe the only way to get there is by setting up a virtual directory in the Internet Service Manager.

So I go to the directories tab and click "Add" and specify which drive and folder I want to point to and I give the virtual directory a name and click "Apply".

When I refresh my list of directories I see my new entry, but it has a red stop sign by it saying that "The specified network password is not correct." Which password is it talking about?  

I am already logged into the Netware server with the same ID and password that I use on the NT web server. It seems like the IIS service itself is trying to somehow authenticate itself on the Netware Server. Is my assumtion correct? Does anybody else do this? and How do I get Netware to let my IIs server in?

If anyone has any info on this I would really appreciate it. If there is another way around this, I am open to that as well.

Thanks.
0
Comment
Question by:johnsm
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 3
  • 3
  • +2
12 Comments
 
LVL 7

Expert Comment

by:BlackMan
ID: 1856420
By default, IIS runs under the context of the user named INET_USER (or something like that, check in the User Manager). This user does not have access to the network! This is made as a security precaution. What you have to is to give the user rights to access the network, you can f.ex. add it to the Administrators group, if security is not a big issue for you..
You can also change the user that the webserver runs under. I can't remember exately where it is in IIS3, I think it is the same place (under webserver properties) where you choose what authorization you are using. It is named something like "Anonymous user context".
0
 
LVL 1

Author Comment

by:johnsm
ID: 1856421
The user id is IUSR_WEB_SERVER and it is in the "Anonymous Login" section. This ID is what allows others to get to the web server, not the web server to get around to other servers. I changed the id and password and now anyone who goes to my server gets prompted for a username and password before they can see anything.

In my user manager there is no user called 'IUSR_WEB_SERVER' or anything close to that. If the server uses that id to get around on the network then shouldn't it also be listed in my user manager as a valid user of this pc as well?


0
 
LVL 7

Expert Comment

by:BlackMan
ID: 1856422
As a matter of fact, the IUSR_WEB_SERVER used for Anonymous Login IS the user that needs to have access to other servers. I think that you started User Manager for Domains, IUSR_.. is a local user, so try to select your local server from User Manager..
You are correct that this user is what allows other to go to your server, but it is the same user that are used when you (or a foreign user) click on a link to another server. If users comming from the internet (or intranet) all of a sudden could take advantage of the administrative user that you log in to the server with, it would be a serious security hole...
0
Looking for a new Web Host?

Lunarpages' assortment of hosting products and solutions ensure a perfect fit for anyone looking to get their vision or products to market. Our award winning customer support and 30-day money back guarantee show the pride we take in being the industry's premier MSP.

 
LVL 1

Author Comment

by:johnsm
ID: 1856423
I logged into my web server as local administrator. I went into user manager. I saw that there was a user named IUSR_WEB_SERVER.
I changed the password to 12345 I then logged into my netware server and set up a user call IUSR_WEB_SERVER and set it's password to 12345. I then logged into the NT server as IUSR_WEB_SERVER and proceeded to map a drive to the netware server. IF my ID or password were different on Netware it would prompt me for an ID and password but since they were the same, I got mapping with no problem. I then logged out of NT as IUSR_WEB_SERVER and logged back in as Administator. I then mapped a drive to Netware and this time it prompted me for an ID and pw. because there is no Admin. ID on the netware machine, so I attached as IUSR_WEB_SERVER and used the password of 1235 and the mapping worked fine. So now I go to set up the virtual directory and I still get the exact same error message. Nothing has changed.

Apparently it must be looking for something else.

0
 
LVL 7

Expert Comment

by:BlackMan
ID: 1856424
Have you changed the password in the IIS setup also? (Where you specify Anonymous account)
0
 
LVL 28

Expert Comment

by:sybe
ID: 1856425
Johnsm,

What you want to do is really not a good idea. You should realize that the naming of shares (drive D, E, F etc) is dependent on the user that is logged in. If you want a webserver to run on a machine undisturbed, most administrators will log out competely, so that there's no one logged in on the machine. That means that no shares are active at that moment, and none of your network drives are valid.

The best way to solve your problem is to install IIS on the other machines to and refer to them by IP-number or network-name.

0
 
LVL 3

Expert Comment

by:uilleann
ID: 1856426
You will indeed have to setup the netware server in iis.
I don't think that it is possible to make a virtual dir on a netware server in iis3
(maybe someone can proof me wrong)
It is in iis4 though, so you could get that.
I'm pretty new to iis and read about it in the "big bad iis book" at work today.
So I can't tell you how to do it, sorry.

Good Luck
0
 
LVL 5

Expert Comment

by:aioudine
ID: 1856427
I'm not sure if this will work but
Try to do the folowing:

First solutions:
1) remove password for IUSR_WEB_SERVER on NT and Netware
(be sure that that user account has limited rogth to files and dir,
ussialy it's should have ReadOnly)

2) When you setup virtual directory using UNC (Universal name conversion)
ie not F:\directory
but \\nw_server_name\nw_volume\directory

Second solutions
1) Install CSNW (Client servises for netware)

2) When you setup virtual directory use UNC (Universal name conversion)
ie not F:\directory
but \\nw_server_name\nw_volume\directory

Third solutions:
If you have Intranetware, NW.411 or Netware 5
install bundled Webserver for Netware and enjoy

0
 
LVL 1

Author Comment

by:johnsm
ID: 1856428
Thanks for all of your suggestions. I have tried them all. Still nothing seems to work. Here is a summary...

- Using UNC gives me the same error.

- setup IUSR_WEB_SERVER on netware with no password, also changed properties on NT for that ISR_WEB_SERVER has no password, and also changed properties on IIS manager to no password for anonymous. Still no change.

- Gateway and client services for netware are already on the NT machine.

- I realize that it's not the most secure thing in the world to do, but it is just and intranet server and it will never go external.

It might not be possible, and I have yet to talk to anyone who has done it, but just the fact that I get the error message saying that the "specified network password" is wrong, leads me to believe that it's trying to do something and the settings are just not right.

I think that if it wasn't possible, I would get a different error message, like "Access denied" or something. and when I go to setup the virtual directory there is a browse button and the button allows me to browse the whole network. I think if I wasn't allowed to go to netware volumes they would not be made available to me.

Anyway, I guess my only hope is to ask if anyone else has a setup where they could try this and let me know what they get. Or if there is someone out there who has been successful at this you could tell me what I am doing wrong.

Thanks.
 
0
 
LVL 5

Accepted Solution

by:
aioudine earned 800 total points
ID: 1856429
I did it!
Here is solution:

Im assume that you have GSNW istalled and function properly

1) Run GWNW applet in control panel
2) Click on gateway botton
3) Click on add button
4) enter share name (say nwdocs)
and path to netware dir ( \\server\nw\volume\dir)
drive letter can by any
5) run IIS manager
6) click on WWW service
7) select Directories tab
8) click on add
9) in directory fiel enter  \\youreNTserverName\\nwdocs
10) click on Virtual Server and enter alias (say altdoc)
11) In account information enter name and password for Anonymous Internet User
(IUSR_NTSERVERNAME)
12) Press OK and restart WWW service
13) TA-DA, now you can access file on netware using http:/server/altdoc



0
 
LVL 5

Expert Comment

by:aioudine
ID: 1856430
Correction
1)  \\server\nw\volume\dir
should be read as \\server\nwvolume\dir
fo example \\odysseus\sys\web\docs

2)  \\youreNTserverName\\nwdocs
shoul be read as
\\youreNTserverName\nwdocs
0
 
LVL 1

Author Comment

by:johnsm
ID: 1856431
Wow, it finally works. I knew it could be done. Thank you very much.

Let me add some notes here in case anyone else reads this later.

Even though I had GSNW installed, I didn't have any shares set up. So I had to set one up. When you do this you need to set up a gateway account. This is an account name that the gateway can use to log into the Netware machine with.

** This needs to be the same ID that the web server runs under. In my case the ID is 'IUSR_WEB_SERVER' because IUSR_ is the default name and the rest of the id is automatically taken from my machine name by IIS (which is WEB_SERVER).

So in the Gateway Account the name is now IUSR_WEB_SERVER. You have to give the account a password. ** This password needs to be the same as the one specified in IIS manager for anonymous accounts.

Now you need to set up the share simply by clicking on add and following the setup.

Important !!! Before you can do all of this, you need to have the IDs setup on the Netware side. First of all you need to have IUSR_WEB_SERVER as a user name on the Novell side. This user has to have the same password that you gave him on the NT side. You can not simply set up the user with no password. This will not work (believe me). Set the restrictions so that the password never expires. You also need to have another account set up on the Novell machine. This ID has to be the same as the one you are logged into the NT machine with. I was logged into my NT machine as administrator so that i could set up the web server. I did not have an ID that was 'administrator' on my Novell server (I am running NW3.12. It has a supervisor account. Those running NW4.x need to add the exact account name 'administrator'. The 'admin' account that exists by default won't work). So I had to set one up and give it the same password as 'administrator' on the NT machine. Now you need to give both the administrator and the IUSR_WEB_SERVER accounts the proper rights on the Novell box so that you can get to the info you need.

** make sure IUSR_WEB_SERVER has the same password everywhere! Which includes NT, Netware, and IIS manager. And that this is the account you have set up as the anonymous user. Also use this when you are setting up the user name and password for the virtual directory.

That should cover everything.

One curious note. If I put this in my web page it works and I can get to it.

<a href=/altdocs/page.xls>whatever</a>
(where 'altdocs' is the alias I set up in IIS manager)

but if I put it in my URL Location field, like:

http://[web server]/altdocs/page.xls

I get an error that says the location is not found. I don't know why it works that way, but I'm glad it does.

Anyway, thanks aioudine and everyone else who tried.


0

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

When it comes to write a Context Sensitive Help (an online help that is obtained from a specific point in state of software to provide help with that state) ,  first we need to make the file that contains all topics, which are given exclusive IDs. …
Today, the web development industry is booming, and many people consider it to be their vocation. The question you may be asking yourself is – how do I become a web developer?
This tutorial walks through the best practices in adding a local business to Google Maps including how to properly search for duplicates, marker placement, and inputing business details. Login to your Google Account, then search for "Google Mapmaker…
The viewer will learn how to dynamically set the form action using jQuery.
Suggested Courses

636 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question