Solved

Too large dialog boxes

Posted on 1998-11-19
34
425 Views
Last Modified: 2013-12-29
Even if I use small fonts in the display settings the dialog boxes and the buttons on them are larger than usual. That causes some problems too with the display of some texts like in Notepad.
I use 800x600 resolution. It may be a registry problem but I have no idea which
0
Comment
Question by:csaveanu
  • 11
  • 8
  • 3
  • +9
34 Comments
 
LVL 6

Expert Comment

by:sgenther
ID: 1728018
Go under Plus! settings in display properties and make sure "use large icons is unchecked. Also what is your resolution set at?
0
 
LVL 6

Expert Comment

by:sgenther
ID: 1728019
Also make sure under accessiblity option in control panel doesn't have the vision impared options set.
0
 
LVL 9

Expert Comment

by:rmarotta
ID: 1728020
Re-install your display (video) drivers.
Let me know if you need help with it.
Regards,
Ralph
0
 
LVL 2

Expert Comment

by:nebworth
ID: 1728021
 Under display properties/appearance, you 'should' be able to make all your desktop/windows as small or as large as you would like.
0
 

Expert Comment

by:joelscott
ID: 1728022
It is my understanding that you cannot manipulate the dialog boxes in windows. You can change the resolution of the screen. You can change the font size in display\properties\appearance. But I was always lead to beleive the dialog boxes and their buttons were unchangable.Can you change the font in a dialog box????  
0
 

Expert Comment

by:joelscott
ID: 1728023
It is my understanding that you cannot manipulate the dialog boxes in windows. You can change the resolution of the screen. You can change the font size in display\properties\appearance. But I was always lead to beleive the dialog boxes and their buttons were unchangable.Can you change the font in a dialog box????  
0
 
LVL 3

Expert Comment

by:tedoff
ID: 1728024
Try going to display the display properties in control panel, go to the appearance tab, and select the Windows Default scheme.  This will set your setings back to the "factory" settings.  If that doesn't work, make sure your resolution is better than 640x480, as the others have suggested.
0
 

Author Comment

by:csaveanu
ID: 1728025
The resolution I use is 800x600 and if I try a lower resolution (640x480) some dialog boxes run out of the screen and I can't even see the bottom of them where the usual OK or Cancel buttons are. Reinstalling the display drivers had no effect. I believe is a registry problem but I have no idea which.
0
 

Author Comment

by:csaveanu
ID: 1728026
Edited text of question
0
 
LVL 9

Expert Comment

by:rmarotta
ID: 1728027
What does the display look like when you boot to safe mode?
(Press F8 key for menu when you see "Starting Windows95" message at boot-up)
Are the dialog boxes normal-size then?
Ralph

0
 
LVL 2

Expert Comment

by:G0LIATH
ID: 1728028
Did you try tedoff's sugestion?
0
 

Expert Comment

by:Vitenka
ID: 1728029
You _can_ change all font sizings and so forth.

Go into 'display properties' (right click on desktop or whatever)

Select the 'appearence' tab

And then click on the windows and so forth.
Change the fonts to something sensible, and a smaller size.
That _should_ fix it in most things.
0
 
LVL 1

Expert Comment

by:snowolfe
ID: 1728030
Go to display Properties

Under the appearance tab = go to item - default settings should be as follows (item is a pull down menu)

3d Objects             -     no setting
Active Title Bar       -     18
Active Window Border   -     1
Application Background -     no setting
Caption Buttons        -     18
Desktop                -     no setting
Icon                   -     32
Icon Spacing (horz)    -     43
Icon Spacing (vert)    -     43
Inactive Title Bar     -     18
Inactive Window Border -     1
Menu                   -     18
Message Box            -     no setting
Palette Title          -     15
Scrollbar              -     16
Selected Items         -     18
ToolTip                -     no setting
Window                 -     no setting

0
 

Author Comment

by:csaveanu
ID: 1728031
The method of snowolfe did not solve my problem. While entering the display properties I foun another one, linked maybe with the first: I cannot change Large Fonts to Small Fonts.
The Safe Mode has the same problem.
0
 
LVL 3

Expert Comment

by:tedoff
ID: 1728032
The option to change Large Fonts to Small Fonts is not in the Appearance tab, it's in the Settings tab of the Display Properties.  Try using that.  Also, please try my previous suggestion of going back to the Appearance tab and selecting the Windows Standard under the Scheme pull down menu.
0
 

Author Comment

by:csaveanu
ID: 1728033
I tried to use the Windows Standard but it didn't solve the problem. Thanks anyway.
0
 
LVL 1

Expert Comment

by:snowolfe
ID: 1728034
can you email me your win.ini, and system.ini - there's somthing i'd like to look at
0
IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

 
LVL 6

Expert Comment

by:sgenther
ID: 1728035
Are you using and Desktop themes such as Nature or 60's USA?
If so try this:
1. In Control Panel, double-click the Display icon.
 
2. Click the Appearance tab.
 
3. In the Item box, click ToolTip.
 
4. Select a different font or smaller font size in the Font and Size
   boxes.
 
5. Click OK.
 
6. If the problem persists, repeat these steps and try a smaller font.

0
 

Author Comment

by:csaveanu
ID: 1728036
I cannot find your e-mail, snowolfe. Mine is csaveanu@umfcluj.ro. Thank you for being interested in this problem. I'll e-mail those files if something useful can be found out of them.
0
 

Author Comment

by:csaveanu
ID: 1728037
I'm not using Desktop Themes but I used the Active Desktop that comes with IE4.
0
 
LVL 9

Expert Comment

by:rmarotta
ID: 1728038
When I asked:
"What does the display look like when you boot to safe mode?"

You later replied in a comment:
"The Safe Mode has the same problem."

I don't know if by that, you meant to say the display was still too large, or that you were unable to change font sizes.

Are your dialog boxes correctly sized in safe mode?
(With ability to get to the OK & Cancel buttons)
Ralph
0
 
LVL 9

Expert Comment

by:rmarotta
ID: 1728039
When I asked:
"What does the display look like when you boot to safe mode?"

You later replied in a comment:
"The Safe Mode has the same problem."

I don't know if by that, you meant to say your display was still too large, or that you were unable to change font sizes.

Are your dialog boxes correctly sized in safe mode?
(With ability to get to the OK & Cancel buttons)
Ralph
0
 

Author Comment

by:csaveanu
ID: 1728040
The dialog boxes are correctly sized in safe mode. I was confuse in my comment because the dimensions of dialog boxes in Safe Mode (which has a resolution of 640x480 that cannot be changed) look of exactly the same dimensions as in Normal Mode with a resolution of 800x600, but now I reevaluated the situation. If in Normal Mode I turn to 640x480 I get huge dialog boxes and sometimes the OK and Cancel buttons are out of the screen.
0
 
LVL 9

Expert Comment

by:rmarotta
ID: 1728041
If the video driver is poorly written, or somehow corrupt, many unexplainable problems can occur.
Find the latest driver available for your video card and re-install.
Let me know if you need help with it.
Regards,
Ralph
0
 

Author Comment

by:csaveanu
ID: 1728042
No positive change if I change the drivers.
0
 
LVL 9

Expert Comment

by:rmarotta
ID: 1728043
Did you change the driver, or simply re-install the same one?
Ralph
0
 

Author Comment

by:csaveanu
ID: 1728044
I have changed the driver with different compatible others.
0
 
LVL 9

Expert Comment

by:rmarotta
ID: 1728045
Perhaps the wrong monitor is installed in Device Manager and causes this problem.
How is your monitor listed there?
Have you tried changing it?
Ralph
0
 

Author Comment

by:csaveanu
ID: 1728046
I tried to change the monitor and since it was not correctly configured I searched the Net for the corrct .inf file. Nothing really happened.
0
 
LVL 9

Expert Comment

by:rmarotta
ID: 1728047
Do you know what display adapter card is in your system?
Watch the screen carefully at power-on for a message on-screen  indicating the video type.
How is it listed in Device Manager?
Can you tell us which drivers you have tried?
Ralph
0
 
LVL 1

Expert Comment

by:Theophilus
ID: 1728048
You've probably already checked this but since I don't see it mentioned I thought I would ask. In the Settings tab of Display Properties, are the desktop size and screen size the same? If the screen area is set to less than the desktop it would cause the problem you describe.
0
 

Expert Comment

by:Quixsilver
ID: 1728049

This may be an extreme sollution, but if nothing else works, give it a try.

I've made this a comment so the question won't be locked and others can submit solutions that may be easier to implement.  Though this is about as easy as it gets.

http://www.scitechsoft.com

It's a program called Scitech Display Doctor.  It detects your exact hardware(monitor, video card, xcelerator card, and video memory as well as the exact chipset and revision.)

Here is a direct link to the program.

ftp://ftp.scitechsoft.com/sdd/sdd653.exe



Let me know how it works for you.
0
 
LVL 1

Accepted Solution

by:
FutureX earned 200 total points
ID: 1728050
"The dialog boxes are correctly sized in safe mode"
well... IF so the problem MUST BE your local user settings.

delete win.ini (by moving it temporary see what happens!)

In system.ini
replace
the line display.drv=whatever.drv with display.drv=vga.drv see if that Makes a difference!!!

It won't hurt your system a bit!!! just back them up when you are done! Also, try to get/download Desktop Themes and change to a different themes make sure you allow it to change your appearances and colors otherwise it won't work no matter how many themes you used!
0
 

Author Comment

by:csaveanu
ID: 1728051
Evrika!
With a little chance and stimulated by the suggestion of  FutureX to modify everything I can, I solved the problem. In Regedit I imported a large (4 Mb) file called regpack.reg that is located in the Windows directory. After this kind of restoring (?), I was very surprised, while rebooting, to find that everything was all right. The monitor was reset to general S-VGA monitor but the video driver was correct.

I don't know what is the use of REGPACK, but whatever it may be it certainly helped me. So it was a registry problem after all.

Thanks to everyone who sent me suggestions.
Cosmin.
0

Featured Post

Threat Intelligence Starter Resources

Integrating threat intelligence can be challenging, and not all companies are ready. These resources can help you build awareness and prepare for defense.

Join & Write a Comment

For a variety of reasons, it sometimes makes sense to reboot a Windows-based computer on a regular, perhaps daily basis. This "cures" a lot of ills by resetting processes, flushing caches, refreshing memory, and reestablish network connections. In a…
Update 11/3/2014 - Although the below article will get you to relocate the WINSXS folder, Microsoft has finally released a utility to reduce the size of the WINSXS folder. For some reason, it's not that straightforward. It only works on Windows 2008…
This video Micro Tutorial explains how to clone a hard drive using a commercial software product for Windows systems called Casper from Future Systems Solutions (FSS). Cloning makes an exact, complete copy of one hard disk drive (HDD) onto another d…
Windows 8 comes with a dramatically different user interface known as Metro. Notably missing from the new interface is a Start button and Start Menu. Many users do not like it, much preferring the interface of earlier versions — Windows 7, Windows X…

758 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

21 Experts available now in Live!

Get 1:1 Help Now