Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

How to keep HPUX process table from filling up?

Posted on 1998-11-19
10
Medium Priority
?
365 Views
Last Modified: 2008-03-10
I have an HP machine where the process table is filling up about every week.  We have to reboot it to get it back online.  The symptom is that when users try to log in, they'll get a message like "telnetd: fork() failed, process table full."

The machine is basically for users to telnet in, start a datakit session (through a multiplexer card), and do their business.

So how do you find out why the process table is full, and what do you do about it?
0
Comment
Question by:marimba
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
10 Comments
 
LVL 51

Expert Comment

by:ahoffmann
ID: 2007954
did someone have an exec call in her/his .profile, .cshrc, .bashrc etc.
0
 
LVL 2

Expert Comment

by:seedy
ID: 2007955
When this happens, login onto the console as root and then find the list of processes running.  you can also do this before the system reaches the saturation(about 4 days after reboot, may be). Do you see a lot of <defunct> processes?  who owns them?  What are they?

Sometimes when you telnet from PC's, and when the PCs crash, the processes are not removed, they stay as <defunct>.

Alternatively, you may try and increase the number of process.  This can easily be done through sam by changing the parameter and rebuilding the kernel(Sam / Kernel Configuration / Configrable parameters).  You may change MAXUSERS - maximum users, MAXUPRC - max. processes per user, etc.
0
 
LVL 1

Expert Comment

by:arthurd
ID: 2007956
Try increasing the number of Max Users and Max Processes in SAM.  I think the names of these are:

max uproc
max users

Hope this helps,

Dave
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
LVL 3

Expert Comment

by:elfie
ID: 2007957
If lots of people connat from a pc, ask them to logoff before switching off their pc. If they dont logoff, some processes wont disappear.

If this is the case, increasing some kernel parameters will onmy temporarily solved teh problem (ie reboot after 2 weeks iso 1week)

Another thing to consider is, if you see some shells with parent id 1, that have no son processes running, you can kill these. Normally these are sessions from users who switched off their pc.
So you can limit the number of running processes
0
 

Expert Comment

by:olvo
ID: 2007958
Have you tried to log out inactive telnets?
0
 

Author Comment

by:marimba
ID: 2007959
I wanted to award the points for arthurd but I don't see the option anymore (been a few months since I used this).  Other suggestions were good but what did it was to increase the value of MAXUSERS (which of course increased the critical value NPROCS).  We were just running out of process space.  

Good job arthurd.
0
 

Author Comment

by:marimba
ID: 2007960
I can't find the option to grade the answer or award the points to arthurd.  email marimba@atlcom.net if you want to tell me how to do it.
0
 
LVL 2

Expert Comment

by:seedy
ID: 2007961
> I wanted to award the points for arthurd
Why?  Was it not I who first mentioned to increase the MAXUSERS(see my comment before arthurd).

No one has answered this question yet.  So you cannot yet award the points.  Invite that expert whose comment you found useful to post the comment as answer.  Once he does that, you can evaluate the answer and award the points.
0
 

Author Comment

by:marimba
ID: 2007962
Looking back through the comments I see that it is indeed seedy who first mentioned increasing the values of MAXUSERS and NPROC.
If you enter the answer I will grade it and assign the points.
0
 
LVL 2

Accepted Solution

by:
seedy earned 800 total points
ID: 2007963
Alternatively, you may try and increase the number of process.  This can easily be done through sam by changing the parameter and  rebuilding the kernel(Sam / Kernel Configuration / Configrable parameters).  You may change MAXUSERS - maximum users, MAXUPRC - max. processes per user, etc.
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Installing FreeBSD… FreeBSD is a darling of an operating system. The stability and usability make it a clear choice for servers and desktops (for the cunning). Savvy?  The Ports collection makes available every popular FOSS application and packag…
Using libpcap/Jpcap to capture and send packets on Solaris version (10/11) Library used: 1.      Libpcap (http://www.tcpdump.org) Version 1.2 2.      Jpcap(http://netresearch.ics.uci.edu/kfujii/Jpcap/doc/index.html) Version 0.6 Prerequisite: 1.      GCC …
Learn how to find files with the shell using the find and locate commands. Use locate to find a needle in a haystack.: With locate, check if the file still exists.: Use find to get the actual location of the file.:
In a previous video, we went over how to export a DynamoDB table into Amazon S3.  In this video, we show how to load the export from S3 into a DynamoDB table.

705 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question