Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Ctrl Alt Del Revisited

Posted on 1998-11-20
13
Medium Priority
?
4,024 Views
Last Modified: 2013-12-29
HISTORY OF QUESTION BELOW
                                                                             02:40PM PST

                                                                                         


    Title: "Ctrl Alt Del"

    From: suobs
                                                                                  Date: Saturday, September 19 1998 - 07:43AM PDT
    Points: 6 Points


    What would cause my computer (Win95) to not respond to Ctrl Alt Del?  It is a laptop that also has a resume button that also does not
    work (it shuts down but resume always fails).
                                                       Accepted Answer
    From: blood_angel
                                                                                   Date: Monday, September 21 1998 - 09:38AM PDT

    As far as I can see the only way to repair the damage done by Norton Utils and Cleansweep is to reinstall windows onthe computer...

         You DON'T have to delete windows/format your hard drive, just reinstall it over the top. Make sue you are in DOS before you  run
    setup.






Question History:
                                    (Only last 4 entries shown - click here to see entire question history)


                                                          Comment
       From: blood_angel
                                                                            Date: Wednesday, September 23 1998 - 04:34AM PDT

       reinstall windows over the top of your existing setup.
       The comment about the registry was to walterq...








                                                          Comment
       From: walterq
                                                                             Date: Wednesday, September 23 1998 - 07:11AM PDT

       The problem with reinstalling windows on top of an existing setup is that Win95/98 assumes what you have is what you want and
       that evertyhing is working fine and you just want to upgrade to a newer version. It is unlikely to fix a problem like your
       CTRL-ALT-DEL glitch since it most likely wasn't caused by Win95/98 itself.
       I have found nothing on Symantec's tech site to indicate that Norton may have inserted a trap for the key sequence and
       CleanSweep is unlikely to have done it either.
       You can definitely try the reinstall, if the problem is some defective system file the reinstall will replace the file, but if it is
       something outside of the system core it won't.
       Unfortunately that usually means a from the ground-up reinstall. Not a lot of fun, time consumming, but guaranteed to solve the
       problem unless it is hardware related and from what you described that seems unlikely now.
       As a final try before telling you to reformat and reinstall let's see if we can find anything loaded when you're running that cannot
       be identified.
       Follow these steps and post your results. Please be exact when you post.
       Check Win.ini and see if there is anything in the Load= or Run= lines in the [Windows] section. If there is post what's there.









                                                          Comment
       From: suobs
                                                                                Date: Saturday, November 07 1998 - 12:29PM PST

       Sorry - got busy there.

       No run= lines.  The only load= lines are:

       load=
       device=HP DeskJet 690C Series Printer,HPFDJC08,LPT1:

       rem load=H:\PROGRAMS\QUICKEN\QUICKENW\BILLMNDW.EXE C:\SIDEKI~1\remind.exe

       I noticed something else odd.  Resume on this machine does not work.  I had assumed this was because the backup battery
       was not charged, as I usually use it without any battery.  However, I recently put the main battery in and gave it two days to
       charge the backup, but resume still does not work.








                                                          Comment
       From: suobs
                                                                                  Date: Friday, November 20 1998 - 02:40PM PST

       Yet another odd thing:

       I tried to do a backup several times today using Ditto Tools with and Iomega tape drive, and was told each time that the
       Registry could not be accessed.

       Could all of these wierd problems be related? To summarize, they are:
       1. Ctrl Alt Del does not bring up a shut down screen
       2. Ctrl Alt Del has no effect whatsoever
       3. Resume does not work
       4. Ditto Tools cannot access the registry for backups








Here are your options, suobs:

           1.Have a comment to add?
                                                                                 

           2. Check here if you'd like an email notification whenever this question is updated





                              (Or you can always... Return to Windows95 General topic area)






                                     Copyrights © 1996-1998 Experts Exchange, Inc. - Patent Pending
0
Comment
Question by:suobs
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 2
  • 2
  • +3
13 Comments
 

Author Comment

by:suobs
ID: 1728106
To clarify, I am resubmitting the original thread because I received no response to my last comment.  The problem remains and was not resolved, and there are additional odd things I ahve noticed recently.

Thanks!
0
 
LVL 14

Expert Comment

by:smeebud
ID: 1728107
0
 

Author Comment

by:suobs
ID: 1728108
The question was, what's next?

The additional problems were in the last post.  The gist was:

       Could all of these wierd problems be related? To summarize, they are:
           1. Ctrl Alt Del does not bring up a shut down screen
           2. Ctrl Alt Del has no effect whatsoever
           3. Resume does not work
           4. Ditto Tools cannot access the registry for backups

The main problem now is I would like to back up before uninstalling and reinstalling Windows, but I can't.
0
Connect further...control easier

With the ATEN CE624, you can now enjoy a high-quality visual experience powered by HDBaseT technology and the convenience of a single Cat6 cable to transmit uncompressed video with zero latency and multi-streaming for dual-view applications where remote access is required.

 
LVL 5

Expert Comment

by:j_powers
ID: 1728109
This is going to be a long comment, so bear with me.

I had an old 486 that would not do it if I went into Win95. It would bring up the Task Manager, but would not reboot.
 
First part (1.1), this Knowledge Base article Q81887, which explains how the restart option works.

I suggest this to you. Turn on your computer. When you see 'starting windows95', then hit F8. Choose 'safe mode command prompt only'. That will not load any device or driver. Try Ctrl-Alt Delete. See if you can reset in another config.

What kind of laptop are we talking about? This is a very important question, because laptops can be kinda odd. If you can update the BIOS, then I would highly suggest doing this.

You say that Ditto Tools cannot access the registry. What is the error that you get (word for word). Is your Ditto drive a Parallel or SCSI? If it is parallel, make sure you have ECP enabled on the port in the BIOS. I assume you also have the Ditto drive attached. The reason why I suggest this is because the drive may be giving this error due to the fact that connection to the Ditto drive is not working correctly.

check out the comments below, and let me know what happens.



(1.1)SUMMARY
The simultaneous pressing of the CTRL, ALT, and DEL keys (CTRL+ALT+DEL) causes the computer to restart. This article demonstrates one method of preventing this from occurring.



MORE INFORMATION
Every time a key is pressed, the following sequence of events take place:


The interrupt 09H handler reads a 1-byte scan code from the keyboard controller.

The interrupt 09H handler calls interrupt 15H with AH=4FH (the keyboard intercept service) on PC/AT and PS/2 machines.

Control is returned to interrupt 09H. If the CTRL+ALT+DEL key sequence, or any other special key sequence, is detected, the appropriate handler is invoked.

If no special cases have occurred, the 1-byte code is translated into a 2-byte code (using internal tables) and placed in a circular keyboard buffer. This buffer may now be accessed by user applications through interrupt 16H calls.

The sample code below takes advantage of the second event by hooking the keyboard interrupt service. When the new handler is called, if the scan code in the AL register is that of the DEL key, check to see if the CTRL and ALT keys are being pressed. This is done by checking the ROM BIOS keyboard-status byte located at 0040:0017H. Bits 2 and 3 of this byte will be set if the CTRL and an ALT keys are being pressed, respectively.
If a CTRL+ALT+DEL key sequence is detected by the handler, the handler resets the carry flag, which consumes the DEL. This causes the interrupt 09H handler to see only the CTRL and ALT key sequence, thus preventing the reboot from occurring. Note that MS-DOS and/or other applications may hook the keyboard intercept service first. If this occurs, the interrupt 15H service may not be called each time a key is pressed. Also, this program will not work properly with EMM386 earlier than version 4.44

0
 
LVL 8

Expert Comment

by:netmage
ID: 1728110
This may sound simple but nobody seems to have suggested it yet.

ctrl+alt+del is a low level dos command.

Try sys c:   and check the dates on the upgraded version of system files and see if one of them is write protected.

compare its date.

Check the functionality of the ctrl+alt+del keys.

Sounds like you've had a handful of problems. Laptops have even less standards than desktops
0
 

Author Comment

by:suobs
ID: 1728111
I apologize - I thought I had copied the whole previous thread into this question.  For reference the previous thread is called Ctrl Alt Del, dated 9/19/98, and is under Windows95 General Questions.

The laptop is a Toshiba 435 CDS, P-120mHz, with 48 MB RAM.  

The backup drive is an Iomega Easy800 tape drive, parallel connection.  It has worked fine with this machine in the past, and seems to be detected OK and is reading the computer's drives OK.  I also did the Ditto compatibility self-test on the drive and there is no problem.   But when it starts to do a real backup, the Ditto Tools window reads "Saving WIndows 95 Registry" as usual, then stops and I get the message

"The windows 95 registry could not be backed up.  An error occurred accessing the information from the operating system."  

This seems to be a dead end (click OK and start over again).  It happens whether I try to do a "simple copy" or a "backup" using "The Works".  I finally determined how to specify that the registry NOT be backed up and was able to access the tape drive and backup my files.  I hesitate to backup programs though, without  the registry backup.

To netmage:  what is sys c: and how do I "try" it?  I typed sys c: in the W95 run dialog and get a DOS window that says "Cannot specify the default drive".

I will try j_powers' suggestion now.

0
 

Author Comment

by:suobs
ID: 1728112
To j_powers, how do I update the BIOS?
0
 
LVL 5

Expert Comment

by:j_powers
ID: 1728113
Toshiba says that the 435 can be updated BIOS wise. Go here to download the BIOS file

http://www.csd.toshiba.com/cgi-bin/WebObjects/Home.woa/-/FilesByCategory.wo?ID=1002

The 1010v640.exe is the file you will need. You will also need a zip program to expand it. Once you expand it, there will probobly be a read me file on how to extract and update the BIOS.

See what happens, and let me know.
0
 
LVL 8

Expert Comment

by:netmage
ID: 1728114
Sorry i forgot to mention.
make a boot floppy and start with it. Then type sys c:

I only mentioned it to test the raw function but it sounds more like there's more to it.

it really hard looking through all the stuff you posted but a few points you mentioned about the keys not working indicates functions not available. I only mentioned the DOS thing as a test.
if you Use Cleansweep, there is a chance it took one to many files with it and if you unistalled something that intercepts the ctrl-alt-del call. (some of those anti crash programs doit and especially if you used a Nortons Product)

You could try a standard win95 reload to check if it was a system file but if its a registry entry, you have a few options.

1. if you unistalled Nortons with Cleansweep  to a backup, reinstall it.
2. Install nortons again and trace it with Cleansweep and then review what it did checking what it has done with redirecting key calls. Then uninstal it with its uninstaller and check with the cleansweep log what has to be done.

3. look through the registry for entries nortons and key combinations. Redirect these back to ( not sure what system file handles these).

4. well, at this point i'd give up and reinstall the lot.

Obtw I had lots of probelem with my Iomega back up programs also.


Regards

netmage
0
 

Author Comment

by:suobs
ID: 1728115
I did the BIOS update and it had no effect on Ctrl Alt Del problem.  I then tried restarting in Safe Mode and Crtl Alt Del also did not work.  

Netmage, I appreciate your ideas, but like the last option best (reinstall the lot), as I have spent too much time on this already.

So my next question would be, what would be the most thorough, just-get-it-over-with approach to redoing this computer from scratch.  I am prepared to reinstall all programs if necessary and have backed up my files.

Specifically, how to uninstall Windows and reinstall so that it does not set up again with the same problem?  How to make this fix repair any Registry problems?  Especially, how do I make sure I have the laptop perks like power control and resume functions supplied by Toshiba (I have the original stuff on disk).

Norton and Cleansweep have both been removed already, and I will probably reinstall one or the other - any preferences?
0
 
LVL 7

Expert Comment

by:MATTCEI
ID: 1728116
Don't see this having been suggested yet,but it's kinda obvious:

Are you sure all 3 of those keys are functioning? Easiest way to check would be to plug in an external keyboard.
0
 
LVL 14

Expert Comment

by:smeebud
ID: 1728117
OK,
before you do that try this. it's an old trick.
system.ini
[386Enh]
LocalLoadHigh=1

lemme know.

Regards,
Bud
http://www.geocities.com/~budallen/
http://www.budstroubleshooter.eliteservers.net/
0
 
LVL 2

Accepted Solution

by:
potent earned 200 total points
ID: 1728118
Before going the route of a re-install, two options I suggest are to use RegClean and Tweak UI. They are both Excellent & Free programs from Microsoft and have saved my ass more than a few times.

It is possible that when installing a program, a Windows system file was overwritten (very common with DLL's, do you use cfgback.exe to backup your Registry?) or if you've had previous error msg's (invalid page, Ilegal opertation, etc.) and have not corrected your Registry settings, then they are now, way out of whack.

Either program fixes a multitude of problems with Windows 95 and if you don't have them let me know.
0

Featured Post

On Demand Webinar: Networking for the Cloud Era

Did you know SD-WANs can improve network connectivity? Check out this webinar to learn how an SD-WAN simplified, one-click tool can help you migrate and manage data in the cloud.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

When asking a question in a forum or creating documentation, screenshots are vital tools that can convey a lot more information and save you and your reader a lot of time
Compliance and data security require steps be taken to prevent unauthorized users from copying data.  Here's one method to prevent data theft via USB drives (and writable optical media).
In this video, we discuss why the need for additional vertical screen space has become more important in recent years, namely, due to the transition in the marketplace of 4x3 computer screens to 16x9 and 16x10 screens (so-called widescreen format). …
This is used to tweak the memory usage for your computer, it is used for servers more so than workstations but just be careful editing registry settings as it may cause irreversible results. I hold no responsibility for anything you do to the regist…

715 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question