module

As I can specific the modules load at system boot up time at /etc/modules/'uname -r'/'uname -v'.default, but, it seems that I cannot specify the parameter of those modules there ! As a result, where can I specify the parameter of the modules ?

Andrew
andrewyuAsked:
Who is Participating?
 
jprohartCommented:
There is a file /etc/conf.modules. Put your modules options here.
eg:

alias eth0 ne
options ne ioaddress 0x300
alias eth1 3c5x9
options 3c5x9 ...
0
 
dochenchCommented:
I'm not sure i'm understanding your question right, but either way, this may help you out. After recompiling my kernel, It was not finding the IPX and Appletalk modules because I didn't compile them in or as modules. So, I went into the /etc/bashrc (your mileage may vary depending upon distro) and aliased them out..
example
alias net-pf-4 off
alias net-pf-5 off

you may be able to alias it to include whatever options you are wanting.

If this isn't at all what you are wanting, sorry, just a comment. ;)
Hench.

0
 
andrewyuAuthor Commented:
As I know, there is a file (/etc/modules/'uname -r'/'uname -v'.default) in Caldera OpenLinux 1.3 storing a list of modules load at bootup time, but, how can I declare the parameter pass to those modules in the list ?

Andrew
0
 
andrewyuAuthor Commented:
Thank you very much and I will try it a little bit later !

Andrew
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.