Printing on RedHat-5.1

Posted on 1998-11-22
Last Modified: 2013-12-15
I have setup my printing on my server and everything works fine even my print queue and spooling are working, but lpq says: "waiting for lp to become ready (offline ?)"

My printcap looks like:

# LOCAL HP Laser Jet

It is a HP LaserJet 4 Plus.

If I run "cat dhcpd.leases /dev/lp0" I get "cat: /dev/lp0: Device not configured"
If I run "cat dhcpd.leases /dev/lp1" I get "cat: /dev/lp1: Invalid argument"
In my messages I keep "kernel: lp1 at 0x0378, (polling)" every two minutes. It seems like I have to configure my lp0? How do I do that?
Question by:Neogenix
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2

Expert Comment

ID: 1631697
If I run "cat dhcpd.leases /dev/lp1" I get "cat: /dev/lp1: Invalid argument"
Try "cat foo.txt > /dev/lp" and it should go to printer.

I had the polling problem once and found out that I had two
lpd daemons running (pidof lpd, if you get more than one pid fyou have 2 daemons), check if that's the case.
I got printer (canon) working with apsfilter, it seems to have support to HP Laserjet 4 so maybe you should try it.
Good luck!

Expert Comment

ID: 1631698
------------- cut ------------------------
# LOCAL HP Laser Jet

 -------- cut ----------------------

change to :lp=/dev/lp1:\  
Youre kernel says that you have the printer on /dev/lp1
"kernel: lp1 at 0x0378, (polling)"

Author Comment

ID: 1631699
Thank you wqclatre. Please answer this question so I can give you the point. Wonderfully obvious wasn't it.

Accepted Solution

wqclatre earned 100 total points
ID: 1631700
Se the comment...

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Weird Samba Connectivity Issue... 7 65
error while installing php56 in redhat enterprise linux 20 75
expand ext4 on centos 6 5 53
Apache LDAP Authentication 20 52
I am a long time windows user and for me it is normal to have spaces in directory and file names. Changing to Linux I found myself frustrated when I moved my windows data over to my new Linux computer. The problem occurs when at the command line.…
Google Drive is extremely cheap offsite storage, and it's even possible to get extra storage for free for two years.  You can use the free account 15GB, and if you have an Android device..when you install Google Drive for the first time it will give…
Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question