Solved

Errors in /var/adm/messages

Posted on 1998-11-23
13
336 Views
Last Modified: 2013-12-06
Anybody got any idea what I need to do to solve whatever is causing the following entry in the messages file ?
"sendmail[27056]: NOQUEUE: SYSERR(root): dowork:  - cannot fork: Resource temporarily unavailable"
and "unix: out of processes"
0
Comment
Question by:Penfold
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 3
  • 3
  • +2
13 Comments
 
LVL 51

Expert Comment

by:ahoffmann
ID: 2008008
max. number of processes reached while sendmail tried to fork itself (for receiving or sending mail)

If this happens frequently, you should increase your kernel parameter for max. number of allowed processes. Most UNIXs
require to rebuild the kernel for this :-(
0
 
LVL 84

Expert Comment

by:ozo
ID: 2008009
kill off some processes
recomfigure the kernel with more processes
0
 
LVL 51

Expert Comment

by:ahoffmann
ID: 2008010
ozo, you should change your account name to KISS
I like it ;-)
0
Get 15 Days FREE Full-Featured Trial

Benefit from a mission critical IT monitoring with Monitis Premium or get it FREE for your entry level monitoring needs.
-Over 200,000 users
-More than 300,000 websites monitored
-Used in 197 countries
-Recommended by 98% of users

 

Author Comment

by:Penfold
ID: 2008011
Can you give me more details on how to edit the kernel please !
0
 
LVL 1

Expert Comment

by:arthurd
ID: 2008012
Use SAM if it's HP UX (somewhere in there)

If it's Solaris, then it's in /etc/system:
   Per user--->set maxuprc =
   System wide--->set max_nprocs =
   touch /reconfigure
   reboot
 
What's the OS?

0
 
LVL 2

Expert Comment

by:cwalter
ID: 2008013
It looks like you don't have the correct permissions or directories for your mail queue. Check the access list on your mail queue directory and make sure that your mail user (or whatever account your running sendmail as) has full access as well as ownership of this directory.
0
 

Author Comment

by:Penfold
ID: 2008014
Cwalter, I'm logged on as Root, so i should have the access rights. The ownership of the file is also Root, so that should'nt be a problem.

I think Arthurd's comment is more along the right lines. In answer to your question it's running Solaris 2.5.1
0
 

Author Comment

by:Penfold
ID: 2008015
Arthurd,
Is this a serious error ?, as I've done a df-k and my /var is only at 75%

Thanks

Penfold
0
 
LVL 51

Expert Comment

by:ahoffmann
ID: 2008016
Check your message:

   .. cannot fork ..

So you have to increase the number of processes, or find out why there are so much.
0
 
LVL 1

Accepted Solution

by:
arthurd earned 50 total points
ID: 2008017
I don't think its a serious error.  It very correctable.  Diskspace isn't an issue.  I would suggest editing your /etc/system file.  Add the following line to the bottom:

set maxusers=512

This will increase the number of maximum users, which in turn will increase the number of maximum processes (10 + 16*maxusers).

After that:

touch /reconfigure

then reboot

This will reconfigure the devices and the kernel.

Dave
Dave


0
 

Author Comment

by:Penfold
ID: 2008018
arthurd,
At present I only have three users on the machine. Is setting the
Max user=512 the only way to resolve it ?
0
 
LVL 1

Expert Comment

by:arthurd
ID: 2008019
This is just kernel parameter.  It's not going to open up your system to a mass of users.  All this will do is make the kernel a little bigger and more capable of handling bigger loads.  I think the default for maxusers is something like 128.  So, it's not a huge increase.  I can't think of anything else off hand that might correct it.

Dave
0
 

Author Comment

by:Penfold
ID: 2008020
Thanks for the Answer Arthurd
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

When you do backups in the Solaris Operating System, the file system must be inactive. Otherwise, the output may be inconsistent. A file system is inactive when it's unmounted or it's write-locked by the operating system. Although the fssnap utility…
Installing FreeBSD… FreeBSD is a darling of an operating system. The stability and usability make it a clear choice for servers and desktops (for the cunning). Savvy?  The Ports collection makes available every popular FOSS application and packag…
Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…
This video shows how to set up a shell script to accept a positional parameter when called, pass that to a SQL script, accept the output from the statement back and then manipulate it in the Shell.

617 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question