Winsock's Connect does not allow 'http://'?

When trying to connect to remote sites with "http://" attached to the beginning of them winsock1.connect cannot resolve the host name/ip address. Is this another error in vb5? It only reports back an "Cannot Resolve Host" error.

Oh..and if it isn't any trouble could someone email the mswinsck.hlp file to qballme@yahoo.com...the books online is essentially the only help i can get on this topic. Everytime i hit F1 for help on winsock commands it says cant find the mswinsck.hlp file.  I've tried reinstalling to no prevail.
anistonAsked:
Who is Participating?
 
evertdCommented:
Yes, that is correct!! http:// is the protocol not the host name!!
If you type in explorer http:// is makes a connection on port ? (23 or something) and if you type "ftp://" it makes a connection on port 21 that is the difference!!
So never type http:// in front of the adress.

The same problem excist if you type "ping http://www.microsoft.com" this is not a valid adress!! You have to type "ping www.microsoft.com"
0
 
anistonAuthor Commented:
Edited text of question
0
 
anistonAuthor Commented:
The strange part is that in the examples mentioned in Help it does show that you are allowed to include "http://" to calls to Connect or even setting the winsock1.remotehost="http://test.com" . I guess this was a mistake by the manual writers, albeit repeatedly used throughout. Thanks for the info.
0
Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

 
evertdCommented:
Yes, I think so!! But what is the difference betwee http://test.com and test.com!! The only difference is the port I think but you have to specify the port anyway!!
0
 
evertdCommented:
Yes, I think so!! But what is the difference betwee http://test.com and test.com!! The only difference is the port I think but you have to specify the port anyway!!
0
 
anistonAuthor Commented:
Very good point...I guess my mind is being a little stubborn to adjust. I will make my modifications. I really appreciate you answering this mystery!
0
 
jknickelbeinCommented:
http:// goes on port 80, btw
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.