?
Solved

My hard drive and zip drive switched letters after BIOS upgrade

Posted on 1998-11-25
13
Medium Priority
?
329 Views
Last Modified: 2010-04-27
After upgrading my Dells Bios the partition on my hard drive labeled D was switched to E and my Zip drive, which was E is now D.

How can I switch them back. Dell is no help.

Thanks
0
Comment
Question by:jakedi
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
  • 2
  • +6
13 Comments
 

Author Comment

by:jakedi
ID: 1129768
Adjusted points to 150
0
 
LVL 8

Expert Comment

by:wayneb
ID: 1129769
Is this an atapi zip drive? I do not see how flashing the system bios would account for the switched drive letters. If this is an atapi zip and if you run fdisk on it and delete the partition, it should revert your second harddrive back to d: you can then recreate the partition and reformat the zip and it maybe assigned e: and not d:. The zip is being treated as a harddrive, is it a master or slave. When you flashed the bios maybe the secondary adapter is now enabled when before it was disabled, this would account for the change of drive mappings and or letters. Please answer the ? I asked so we can help you better.
0
 
LVL 9

Expert Comment

by:rmarotta
ID: 1129770
How was the system configured prior to the BIOS upgrade?
Was the zip drive installed then?
Ralph
0
Fill in the form and get your FREE NFR key NOW!

Veeam® is happy to provide a FREE NFR server license to certified engineers, trainers, and bloggers.  It allows for the non‑production use of Veeam Agent for Microsoft Windows. This license is valid for five workstations and two servers.

 
LVL 11

Expert Comment

by:speed_54
ID: 1129771
first uninstall your zip drive. then open your pc up, and make sure on the primary ide bus, you have your c drive set as master and your second harddrive set as slave. install your cd rom as master in the secondary ide, and if your zip is an atapi type, the zip as the secondary. power up and  go into bios setup and check that all drives have detected correctly. after restarting, reinstall your zip drive.
0
 

Expert Comment

by:fenix99
ID: 1129772
you might go to system-hardware devices click on the items in question then settings tab and reasign drive letters like you want them.
0
 

Author Comment

by:jakedi
ID: 1129773
Sorry speed, it didn't work. I did solve the problem myself however.

I switched my NVRAM jumpers to clear then booted up. When cleared messege came on I went to setup and set The secondary drive master and slave to auto.

Then I let the computer finish booting.

I then shut it down, put the NVRAM jumpers back to the original position and rebooted.

Thanks anyhow.

jakedi
0
 
LVL 1

Expert Comment

by:danpaul091498
ID: 1129774
The bios will assign drive letters to physical drives first and then the extended drive. So,if the BIOS sees this as a physical drive, then anything you do will have no effect. This is definitely a BIOS problem. Go back to the BIOS.
0
 
LVL 1

Expert Comment

by:danpaul091498
ID: 1129775
Sorry, I didn't see your final response. Forget what I said. I didn't know that you had a 2nd drive on your system. Anyway, that was very strange to say the least.
0
 
LVL 5

Expert Comment

by:Jason_S
ID: 1129776
F.Y.I.  The new BIOS fundamentaly supports the Zip drive.  This device will be treated as you found.  Another rev of the BIOs may treat this as a removable device as it should, but for now, it will handle it this way.
0
 
LVL 1

Expert Comment

by:THBA
ID: 1129777
I know for SCSI devices, you can set the SCSI ID. Depending on the SCSI ID, the computer will assign the drives letters to the hard drive and zip drive.  Perhaps, a similar situation is happening in your IDE drives. Can you check  the settings on your Hard drive and zip drive? ( master, slave, slave with master, see the documentation on the hard drive for jumper settings)

Is your operating system NT or 95? If it is NT, I am sure you can change the letter assignment by going to Start/Administrative tools/disk administrator.
0
 
LVL 5

Expert Comment

by:Jason_S
ID: 1129778
Jakedi?  What is the status of this?
0
 

Accepted Solution

by:
bigelow earned 300 total points
ID: 1129779
Have you tried going to control panel, system, hardware profiles, disk drives, and then changing them?
0
 
LVL 5

Expert Comment

by:Jason_S
ID: 1129780
jakedi:  Any thoughts on this?
0

Featured Post

[Video] Create a Disruption-Free Workspace

Open offices have their challenges. And Sometimes, it's even hard to work at work. It's time to reclaim your office and create a disruption-free workspace. With the MB 660, you can:

-Increase Concentration
-Improve well-being
-Boost Productivity

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Moving your enterprise fax infrastructure from in-house fax machines and servers to the cloud makes sense — from both an efficiency and productivity standpoint. But does migrating to a cloud fax solution mean you will no longer be able to send or re…
This article outlines why you need to choose a backup solution that protects your entire environment – including your VMware ESXi and Microsoft Hyper-V virtualization hosts – not just your virtual machines.
In this video, Percona Solutions Engineer Barrett Chambers discusses some of the basic syntax differences between MySQL and MongoDB. To learn more check out our webinar on MongoDB administration for MySQL DBA: https://www.percona.com/resources/we…
We’ve all felt that sense of false security before—locking down external access to a database or component and feeling like we’ve done all we need to do to secure company data. But that feeling is fleeting. Attacks these days can happen in many w…

719 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question