Solved

D3/4 and Win 98 ?

Posted on 1998-11-28
14
172 Views
Last Modified: 2011-04-14
When I upgraded my Win 95 system to Win 98.  Delphi 3 suddenly stopped working.  It kept working in Win NT 4.

Then I upgraded to Delphi 4, which worked in NT, but not in Win 98.

So I reïnstalled (Full) Win 98, hoping this would provide the solution.  I reïnstalled Delphi 4 to Win 98.  And it still doesn't work.  

Delphi 3 seemed to hang when loading the components palette.  Delphi 4 hangs at the splash screen.
With hanging I mean the mouse-cursors freezing (and everything else with it) and the only option I have left is to hard-reboot.

I've installed the first update of Delphi 4, but this doesn't do the trick.

So - should I install the second update?  Any other suggestions?
0
Comment
Question by:Odie
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
  • 3
  • 2
  • +3
14 Comments
 
LVL 8

Expert Comment

by:ZifNab
ID: 1348353
Odie, I work with D3.02 on Win98 without problems.
0
 
LVL 20

Expert Comment

by:Madshi
ID: 1348354
And I'm working with D4.01 AND D4.02 on Win98 without any problems...
0
 
LVL 17

Expert Comment

by:inthe
ID: 1348355
hi
it sounds like you may have the problem that when component pallet ImageList is being built im memory it is causing prob.
when you upgraded windows it may have changed your video card driver.this is a common problem with delphi 3 and 4 .i had same problem upgrading to win 98 and when i changed my videocard drivers to the latest one it was ok. you can also try and
reduce the hardware acceleration for the card or change the color depth/resolution.  
do you have a s3 videocard? if so these are worst cards for these probs.
Barry
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 20

Expert Comment

by:Madshi
ID: 1348356
Oh yes, Barry is right. I heard something like Win98 has problems with the TImageList component in 16 color graphics mode. It's a windows problem, not a Delphi problem...
0
 

Accepted Solution

by:
doogie earned 200 total points
ID: 1348357
Odie
Look elsewhere. It is not Delphi ... I'm having no probs using delphi3,4 with win98.

I've heard that some chaps are experiencing probs with certain graphics cards and D4 under win98 .. apparently S3 cards clash.

Good luck
0
 
LVL 20

Expert Comment

by:Madshi
ID: 1348358
Hey doogie, read the comments before answering!!!
Barry has written the same as you. It's not fair to take other people's points...
0
 
LVL 17

Expert Comment

by:inthe
ID: 1348359
yea grrrr..

Barry

ps madshi i can get you other game sources but not for arkanoid
have you done a search on www.altavista.digital.com for delphi games programming thats were i got mine.
0
 
LVL 20

Expert Comment

by:Madshi
ID: 1348360
It was not me with the arkanoid...
0
 

Expert Comment

by:doogie
ID: 1348361
Sorry .. didn't intend to take nobodies points .. new to the game!!!

PS check out the graphics card part of my answer/comment

You can have the points ... I'm not in this for the points .. got better things to keep me busy with!
0
 
LVL 17

Expert Comment

by:inthe
ID: 1348362
sorry madshi it was matvey(arkanoid)
0
 
LVL 20

Expert Comment

by:Madshi
ID: 1348363
No problem...   :-)
0
 
LVL 1

Expert Comment

by:xpher
ID: 1348364
I had a similar problem with D4 and 98. I went to the display properties via right clicking on desktop, and in the advanced settings/performance I reduced the hardware acceleration to the first marker which cured all my problems. This has had no adverse effect on anything else. Give it a try and let me know.

All the best
Chris
0
 
LVL 20

Expert Comment

by:Madshi
ID: 1348365
Hey doogie, don't worry. Perhaps you can read the comments the next time and we all will be happy.   :-)

P.S: Welcome to the freak show...

Regards, Madshi.
0
 
LVL 1

Author Comment

by:Odie
ID: 1348366
Ok - no hardware accelartion then.  I use an S3 card.  It works alright now.
0

Featured Post

[Webinar] Code, Load, and Grow

Managing multiple websites, servers, applications, and security on a daily basis? Join us for a webinar on May 25th to learn how to simplify administration and management of virtual hosts for IT admins, create a secure environment, and deploy code more effectively and frequently.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Controlled Assessment GCSE - desperate help needed 4 122
Drag & Drop... Data from one grid to another 2 56
RESTRequest Parameter 4 85
migrate this code to work on android 1 46
The uses clause is one of those things that just tends to grow and grow. Most of the time this is in the main form, as it's from this form that all others are called. If you have a big application (including many forms), the uses clause in the in…
In this tutorial I will show you how to use the Windows Speech API in Delphi. I will only cover basic functions such as text to speech and controlling the speed of the speech. SAPI Installation First you need to install the SAPI type library, th…
How to Install VMware Tools in Red Hat Enterprise Linux 6.4 (RHEL 6.4) Step-by-Step Tutorial

752 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question