Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 158
  • Last Modified:

Sharing not available

I have a W98 installation that is either weird or purposely forced.  It is an installation of an OEM W98 over a regular installation of W95.  I installed it by renaming win.com and installing W98 OVER W95, retaining the previous settings (fonts, add-ons, software, apps, etc.).  There was no problem except when I connected to a LAN of W95 workstations, I get the message that "System policies do not allow adding the selected device" when I try to add Microsoft: File and Printer sharing for Microsoft Networks".  I can connect properly to the LAN and view/use shared resources, but I can't share mine.  I need to share my resources badly, but I don't want to reformat my HDD to re-install W98 on its own.  Can anybody help me with this?
0
elno
Asked:
elno
1 Solution
 
MadshiCommented:
Please tell me all values that you find in the registry (regedit.exe) under "HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies" and "HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies". I'm quite sure it's some of these values.
If you have "poledit.exe" you can start this program instead and check all settings.

Regards, Madshi.
0
 
MATTCEICommented:
Could be you're running the Real Mode version of Win9X networking,which I believe doesn't allow resource sharing.Check the properties of the NIC - see if it's driver is Enhanced or Real.Also,while booting,see if any DOS lines appear that say anything about networking (hit ESC to clear the Win logo).
0
 
elnoAuthor Commented:
Madshi:

Under the Machine Policies, I have NoFileSharing as 0x00000001 (1).  Could I manually change this to allow sharing?

Under the Users Policies, I also have NoFileSharingControl as 0x00000000 (0).  Again, could I manually change this?
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
elnoAuthor Commented:
MattCEI:

I'm sorry to disappoint you, but my NIC is already using Enhanced mode, besides, I don't have any network messages that come up during boot up.  Thanks anyway.

Any other suggestions?

Regards,

Elno
0
 
MadshiCommented:
Try setting both values to 0. This should help...

Regards, Madshi.
0
 
MadshiCommented:
P.S: But don't ask me who set this value to "1"...
0
 
theyakCommented:
Hummmm  heres a wild question, did you select FILE and PRINT sharing in Networks???
if it is selected, un select it, reboot, reselect it, reboot
if it ISNT selected, select it, reboot.....
0
 
MrfixitCommented:
Seen this before make sure both registry entries that Madshi provider are set to 0. Then refresh the registry close it and try again. You have either ran poledit on your machine and had this policy set. If you run poledit you can disable all of the check boxes and save it. Poledit is avaialable on the cd
0
 
elnoAuthor Commented:
Theyak and Madshi:

Thank you very much for the suggestions. Apparently, Madshi beat you guys to the finish. His suggestion set everything right.

Regards,

Elno
0
 
elnoAuthor Commented:
Theyak and Mrfixit:

Thank you very much for the suggestions. Apparently, Madshi beat you guys to the finish. His suggestion set everything right.

Regards,

Elno
0
 
elnoAuthor Commented:
Madshi:

HURRY!!! SUBMIT THE ANSWER!!!!!
0
 
MadshiCommented:
Thanx, elno...  :-)
0

Featured Post

Hire Technology Freelancers with Gigs

Work with freelancers specializing in everything from database administration to programming, who have proven themselves as experts in their field. Hire the best, collaborate easily, pay securely, and get projects done right.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now