Word - "Have a nice day!" virus...

My Word 97 'caught' the "Have a nice day!" (word8_niceday) virus from a document.  My virus detection program found the virus and cleaned it from the file.  It also cleaned it from normal.dot

The document (which was infected but now clean) now always warns me with a dialog box explaining that the doc contains macros or customisations and whether or not I want to enable or disable the macros. When I click disable the doc become read-only and when I click enable the doc seems fine. This prompt never used to appear with this doc. When I exit Word, there is no longer an annoying "Have a nice day!" greeting.  However, although the document is a *.doc it is infact it has changed to a template - when I click File/Save As... I am prompted to input a name for the template.  Also, when I check Tools/Macro/Macros there are no macros.

Finally, when I open other docs up no initial macro dialog box and the docs are not templates.

Any ideas about what I can do with this doc - to stop the macro dialog box on opening and to make it a doc & not a template?
LVL 3
ombAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

rosefireCommented:
Can you restore normal.doc from a backup copy?
0
ombAuthor Commented:
I assume you mean normal.DOT - this file I deleted and it then regenerated itself when Word was restarted; so I believe the file is 'clean'.
0
rosefireCommented:
Don't count on the regenerated file being normal (pun intended).  Send me your email address and I will send you a copy of my normal.dot if you wish.  You can reach me at keiths@sdd.hp.com.

I had a problem where word 97 thought normal.dot was corrupted EVERY TIME I RESTARTED WORD!  It rebilt it repeatedly.  I had to reinstall word to fix the problem.  Reinstalling word is no big deal if you have the CD.  That may be a pretty quick solution too.  You can use the setup for office or word 97 to uninstall word.  Make sure normal.dot is gone, then reinstall it.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

ombAuthor Commented:
Do you really think that the problem I am having with the original document that had the virus, and not with any other document, has something to do with my normal.dot?  Would the macro dialog box prompt and the filename.doc infact being a template have something to do with normal.dot? No other file is having this problem.
0
rosefireCommented:
Rereading your problem statment I read "the doc" to refer to normal.dot and I agree.  You are right, the problem is probably in the doc, not the template.

How big and involved is your document?  If it is not complex you can save the file in another format (maybe Word 6) then read it back and it may strip out the problem parts.

Depening on the docuement complexity, a real simple quick fix is to use cut and paste to copy the entore file contents to a different file and if all goes ok, discard the old file with its hiccups.

Hope this helps.  Sorry for the confusion earlier.  If this doesn't solve the problem, tell me more about your document and what is in it.
0
maryt052198Commented:
It sounds like your file is in a pretty nasty mess.
Here is another suggestion:
Open your file and go to "File--Save As..."  and, under "Save File As Type:" is probably says "Word Template".  Select "Word Document."  This will take away the template thing.

Also, in "Tools--Macro..." under "Organizer", you may see the different macros and the templates they belong to.  You could delete some ghost macros there.

Also, in "Tools--Options" somewhere, you should be able to disable the "Prompt for disabling macros" dialog.  That would fix your prompting problem.

0
rosefireCommented:
OMB, how are things going with this problem?  Are you still working on it?
0
ombAuthor Commented:
rosefire - thanks for your suggestions. In the end I had to save the file as a Word 6.0 file and then resave as a Word 97 file - this sorted the problem out. Other documents with the virus, were cleaned and I then used cut & paste - long winded but it worked fine.

rosefire - just post your answer and I will award you the points.

Thanks.
0
rosefireCommented:

How big and involved is your document?  If it is not complex you can save the file in another format (maybe Word 6) then read it back and it may strip out the problem parts.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
ombAuthor Commented:
This was the only method which actually worked - although long-winded, all macros were stripped and the document could then be re-saved as a Word 97 and no more aweful prompting!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Office

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.