?
Solved

MS Peer Service Network Login

Posted on 1998-12-01
5
Medium Priority
?
153 Views
Last Modified: 2013-12-25
I am attempting to create a small web site using Microsoft Peer Services Webserver on Windows NT.

One of my web pages calls a C++ CGI executable, which creates a small text file and tries to copy it to another NT network server. However, the CopyFile function fails because the error 'invalid username or password' is returned.

I have worked out that this is due to the 'World
Wide Web Publishing Service' forcing any network logins to
use the 'System Account', rather than the current user account. I tried to change this in the Services option in#
control panel, but the options where ghosted out.

My current user account is in the Domain, but the
system account (Administrator) is password protected and I am not allowed to use this account (only Domain Administrator can use this). Therefore, does anyone know how to force the service to use a different login ?

0
Comment
Question by:jasonatkins
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
5 Comments
 
LVL 28

Expert Comment

by:sybe
ID: 1856837
The system account is not the administrator. Why don't you give change rights to "system" on the other network server ?  
0
 

Author Comment

by:jasonatkins
ID: 1856838
I don't follow. The current login I'm am using on the NT webserver already has 'full control' over the network share I
am trying to copy to.

What is the 'System Account' ?

ps I appreciate the help. I'm pulling my hair out over this.
0
 
LVL 28

Expert Comment

by:sybe
ID: 1856839
the CGI does not use your username/password, but uses "system" as username. You should add "system" (as if it were a user) to the directory you want to copy files to, and give it (at least) change rights.
0
 

Author Comment

by:jasonatkins
ID: 1856840
Great. Your last comment made me think and I've now worked it out. The complete solution was:

1. Start the Peer Server up.
2. Double click the WWW Service.
3. Change the Username and Password in the Anonymous Logon
section to the current login account (which is on the domain)

CGI now works. Thanks a lot.
0
 
LVL 28

Accepted Solution

by:
sybe earned 600 total points
ID: 1856841
I am happy you solved it.
0

Featured Post

Linux Academy Android App Now Supports Chromecast

We have some fantastic news for our Android fans. We’re so excited to announce that the Linux Academy Android app is now available with Chromecast support. That’s right – simply download the latest update of the Linux Academy App and start casting your favorite course videos!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Today, the web development industry is booming, and many people consider it to be their vocation. The question you may be asking yourself is – how do I become a web developer?
Dramatic changes are revolutionizing how we build and use technology. Every company is automating, digitizing, and modernizing operations. We need a better, more connected way to work together as teams so we can harness the insights from our system…
The viewer will learn how to dynamically set the form action using jQuery.
Any person in technology especially those working for big companies should at least know about the basics of web accessibility. Believe it or not there are even laws in place that require businesses to provide such means for the disabled and aging p…
Suggested Courses

800 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question