Solved

RealTek RTL8029 ethernet  and Windows 98

Posted on 1998-12-02
29
13,327 Views
Last Modified: 2008-01-09
 I have a RealTek RTL8029 ethernet card which worked fine, and straight away, under Windows '95.  When I upgraded to Windows '98 this was the only thing that stopped working.  Whenever Windows starts up it tells me that this device is not working properly.  And indeed it's not !  I can't get my other machines to see it on the network, nor can it see anything.
  In the Device Manager, Windows reports 'This device is either not working properly, not present, or does not have all the drivers installed'.
  I went to http://www.realtek.com.tw/cn/driver/8029-driver.htm and downloaded the Win98 driver there, but this did not make any change at all !  I still get the same problems and messages.
0
Comment
Question by:davidmwilliams
  • 12
  • 7
  • 3
  • +7
29 Comments
 
LVL 2

Expert Comment

by:dudleyf
Comment Utility
My guess is a hidden memory address or IRQ conflict. The Control Panel>System might say no conflicts but that's not always true.
Step 1 would be to get the latest video driver from the _manufacturer_. Diamond for example uses a common chip but in a different way, so if you use the generic chip driver, hidden conflicts can develop.
Step 2 would be to yank out & delete any other cards from the CP>System>Device manager and delete the Realtek but don't yank it. Reboot and reinstall the driver. If the device is working properly, reinstall the other cards one at a time, rebooting and configuring each. The video and the sound card - especially ensoniq - are the main culprits.
Last, are you sure you have a real Realtek card? there are lots of clones based on the 8029 chip that are not perfectly compatible with the Windows realtek driver.

I don't want to close this question with an anwser without anyone else getting a comment in.

Brian
0
 
LVL 3

Expert Comment

by:uilleann
Comment Utility
check to see if it is listed in Control->System->Other devices
If it is change the driver.
0
 
LVL 6

Expert Comment

by:bartsmit
Comment Utility
Unplug the Realtek card and place it in another PCI slot.
Windows will find the "new" hardware and do another plug n play.
0
 
LVL 4

Author Comment

by:davidmwilliams
Comment Utility
Thanks for the comments thus far, I hope to check out all these solutions very soon.
0
 

Expert Comment

by:andrygun
Comment Utility
Try using a Software called DirectX 6.0 is useful for device conflict or hardware no detect or device not working properly.
0
 
LVL 4

Author Comment

by:davidmwilliams
Comment Utility
 Some of the suggestions seem to me a bit odd -- looking for new graphics card drivers, installing DirectX 6.0 ... I think maybe the fact the problem is with a _network_ card has escaped some of you :)
  As DudleyF suggested, however, it turns out my card is a clone 8029 - a WinBond W89C940.  Now, I was able to get some Windows 95 drivers for this card but I've had problems ever since.
  Firstly, Windows 98 just keeps detecting and installing the RealTek 8029 drivers every single time I reboot, after removing it.  I simply can't get Windows to forget about the 8029.  Eventually I was able to stop this behaviour by just marking the 8029 as 'disabled in this profile'.
  Also, after installing the WinBond drivers - which gave no device not working errors at all -- it became a matter of pot luck as to whether Windows would boot or not.  It just kept failing during start up.  Once I got it to boot, and could indeed see the network fine, with the WinBond drivers in place.
  However, ultimately there is a clear incompatability here between the RealTek stuff Windows keeps forcing in, and the WinBond drivers.  The only way I can get my system to boot reliably is by disabling the RealTek driver and just removing the WinBond driver.  So, I still can't see the network, but I have a better idea what the problem is.
  I'm going to look for '98 versions of the WinBond drivers, right now, but what can I possibly do to stop Windows installing the RealTek junk every time?
0
 
LVL 3

Expert Comment

by:uilleann
Comment Utility
HAVE you looked under "other devices"? (see previous comment)
The winbond / realtek /rp1621 are one and the same.
We have had hundreds of these cards and they all have either one of three above mentioned drivers.
If you kick out ALL references to you ethernet adapter (go through device manager and kill)
Then windows will find the card again, just let it do it's stuff and see where the card ends.
Then go and "change driver" in the driver tab of the card.
Choose "choose your own", click previous, choose networkadapters, click next, click have disk
You should get it going then.
If you still have problems let me know and i'll put copy's of the drivers on the net for you to download.

Good Luck
0
 
LVL 4

Author Comment

by:davidmwilliams
Comment Utility
Hi Uilleann,
  No, there is nothing under 'other devices'.
  I am interested to note that WinBond and RealTek are one and the same.  This means then, that I should be able to get the original RealTek drivers to work properly - especially because Windows keeps forcing them.
  I have indeed removed all references to all ethernet adapters, several times.  However, on the next reboot Windows just keeps finding a 'RealTek 8029' and installs drivers (from where?  I've even reformatted and re-installed Win '98 and my apps) without giving me the option to cancel.
  However, even though Windows does this, there is still some sort of problem - because the RealTek 8029 is flagged as not working in the device manager, it can't see the network, and on every reboot Windows pops up a message 'The RealTek 8029 ethernet adapter is not working'.
  The WinBond drivers installed fine with no problems flagged -- and I was able to see the network once with them --- but Windows just keeps on reinstalling the RealTek driver even with the WinBond driver installed, and if I disable the RealTek driver then Windows refuses to boot.
  It seems to me I must get the RealTek drivers to work, or figure out how to get Windows to stop trying to install them all the time.
  I've downloaded the latest RealTek 8029 drivers from the Web site I mentioned in the initial message, and updated the driver to these, but to no avail.
  If you have some drivers for me to try, I would be very happy.
My email address is dave@qed.newcastle.edu.au

Thanks !
0
 
LVL 3

Expert Comment

by:uilleann
Comment Utility
I'll send all realtek drivers i have to you first thing when i get to the office. which will be tuesday, ok?
Can you hold on until then? :)
0
 
LVL 6

Expert Comment

by:joopv
Comment Utility
Removing an existing driver is sometimes very difficult, as you are experiencing.  This is probably one of the main reasons why people are re-installing windows...

You have to remove ALL .inf files associated with the device.  There are a zillion files located in windows\inf\ directory.
Your question now will be : what .inf files belong to my xxx card ?  Well, that can only tell you the manufacterer of the card.
You could try to look at the temporary files that are produced when you install the card's drivers.  Or look at the names of the files.

You also have to remove (or at least rename) the drvdata.bin and drvidx.bin files located in your windows\inf directory.

The have to remove each and every occerence of the card in device manager and network neighbourhood properties / bindings.

DO NOT REBOOT until all these traces of your are gone !

0
 
LVL 4

Author Comment

by:davidmwilliams
Comment Utility
Uilleann - sure, I can wait till then, no problem !
Joopv - boy, that sounds complicated.  I'll take a look in the inf directory and see if I can work things out.
0
 
LVL 2

Expert Comment

by:Hippy
Comment Utility
One thing that may be being overlooked here is the chipset on the mainboard, win98 hadles IRQ's a little different to win95, and some boards eg. VIA MVP3 require the loading of a special IRQ routing driver to run on win98.

What chipset/mainboard do you have?

Also you may have to remove the realtek .INF file from the c:\windows\inf directory, if you want to run the winbond one, these drivers will just be different implementations of the same thing as the chips are the same, only a different stamp on them.

'' c:\windows\inf '' is a hidden directory (at least to windows it is) so to look in it, click the START button, then RUN, then type '' c:\windows\inf '', this will open the directory.

By memory the file(s) you are looking for will start with the letters '' RTL '' for Realtek, just delete the RTL???.INF files and try the driver you found from winbond.

Good Luck

Hippy.
0
 
LVL 4

Author Comment

by:davidmwilliams
Comment Utility
 What you are saying, Hippy, sounds like a good lead.
My motherboard is an Intel PD440FX.  Unfortunately there are no files called *RTL* in C:\Windows\Inf
0
 

Expert Comment

by:rschnei3
Comment Utility
Since you are running 98 you should take advantage of its troubleshooting tools.

You say that when Windows start it tells you the card isn't working properly. Is that all it tells you? Does it say something like NO PROTOCOL MANAGER LOADED the instant the 98 logo screen disappears?

One suggestion I have is to run MSCONFIG from the START->RUN box. On the general tab check Selective startup and process only the WIN.INI and group items. Restart the system and see if the network works. If it does, then the problem most likely is in the system.ini file. Go back to MSCONFIG and go to the SYSTEM.INI tab. Open the 386Enh folder and uncheck the lines that
1)do not have a Windows flag in front of them and
2) that also end in .386 The system will ask you to restart windows. If the network works, then what you've been encountering is a driver conflict.
MSCONFIG is very slick for troubleshooting such problems. You can also try other combinations of solutions through MSCONFIG that may lead you to the actual problem.

0
New! My Passport Wireless Pro Wi-Fi Mobile Storage

Portable wireless storage to offload, edit, and stream anywhere.

High-capacity, wireless mobile storage designed to accompany professional photographers and videographers in the field to easily offload, edit and stream captured photos and high-definition videos.

 
LVL 4

Author Comment

by:davidmwilliams
Comment Utility
 Thanks for the suggestion - and also for making MSCONFIG known to me!
  Unfortunately it hasn't helped.  I don't get a 'No Protocol Manager Loaded' error message.  Also, there were no lines in my 386Enh section that did not have a Windows folder, or that ended in .386.  I couldn't actually see anything there, either, that looked like it related to the network driver.
0
 

Expert Comment

by:rschnei3
Comment Utility
What happens when you disable everything except the win.ini and Load Startup Group Items in MSCONFIG? Does the network card show up?

0
 

Expert Comment

by:rschnei3
Comment Utility
Or better yet, do the other machines show up in your network neighborhood?

0
 
LVL 4

Author Comment

by:davidmwilliams
Comment Utility
 Uilleann has sent me some drivers, so I hope to check these real soon.
  RSchnei3 - the network card has always shown up, it's just that Windows keeps saying it's not working properly.  Unfortunately when I disable everything win.ini and Load Startup Group items, there is no change.  I still can't see other machines - or even the machine itself - when I try to browse the network.
0
 
LVL 4

Author Comment

by:davidmwilliams
Comment Utility
 Thanks for the drivers, Uillean, unfortunately they haven't helped :(  Windows carried on just the same.

 - If I delete the network card from the Device Manager, and reboot, Windows keeps 'finding' a "RealTek or compatible card" and installs drivers, without giving me an option.
 - Windows then reports, on each startup, that the device is not working properly.  And indeed, it's not because I can't browse the network.
 - Looking in the Device Manager shows that "the device is not properly setup, some of the drivers are missing".  If I opt to update the driver, Windows will not accept the WinBond drivers, but does accept the RealTek ones.  However, this doesn't help, everything happens just the same.
 - I can install the WinBond drivers, manually, by selecting this an option from the Add New Hardware control panel applet.  Looking in the Device Manager shows _two_ ethernet cards - the WinBond and the RealTek.  The WinBond shows up as "the device is working properly" with no errors shown.
 - However ...when I reboot, Windows just hangs and hangs.  All I can do is restart - in safe mode - and delete the WinBond driver from the Device Manager.  if I try to remove the RealTek driver (after all, the card does actually have 'WinBond' written onit) then the same happens - Windows refuses to start.  All I can do is remove the WinBond driver - then Windows starts up ok - and then disable the ethernet card (in the Device Manager) so that no error is given on start-up.

  Hopefully somebody can help me crack this.  I'm wondering if I should just get a new network card ...
0
 
LVL 3

Expert Comment

by:uilleann
Comment Utility
I supose you also tried the rp1621 drivers?
But before doing that, get to the situation where you said
" Looking in the Device Manager shows _two_ ethernet cards - the WinBond and the RealTek.
The WinBond shows up as "the device is working properly" with no errors shown."

Then delete the realtek from device manager and reboot.

When the pc boots you'll see a screen with processor, mem, ports etc, when you're there press
the pause button (top right on keyboard) and see if your card irq's are listed and make sure this is the right one in device manager.
Also make sure there is only one card listed in "network properties".
you can remove the cards from there as well.

Please get back to me on this.
I hate it when an ethernet card behaves like this and want to make it listen to you! :)

0
 
LVL 3

Expert Comment

by:uilleann
Comment Utility
another thing, you DO have a properly terminated cable connected to the card do you?
Probably have, but have to ask..
0
 
LVL 4

Author Comment

by:davidmwilliams
Comment Utility
 Hi Uilleann, thanks for being persistent with this.
Unfortunately, I didn't actually try the rp1621 drivers - for some reason, these didn't unzip properly.  Actually, would you be so kind as to possibly send them again?
  I've tried what you've suggested - about deleting the RealTek when I have the WinBond added - but unfortunately in this circumstance Windows refuses to boot ... it simply seems to lock up while booting and I have to reset the computer.  The only way I can find to get it to boot again is to start up in safe mode and (sadly) remove the WinBond from the Device Manager.
  I am finding it frustrating, myself !  Especially because this ethernet card worked fine with Windows '95 - it was only when I upgraded to Windows '98 that I had this problem.
  I do have a terminated cable connected to the card - thanks :)
0
 
LVL 3

Expert Comment

by:uilleann
Comment Utility
No worries mate. (you notice i saw crock dundee? ;) )
Yes, i'll send the drivers again.
In the meantime can you verify on which irq the card resides and how many cards are listed in network properties.

Hang on! :)
0
 
LVL 4

Author Comment

by:davidmwilliams
Comment Utility
 Ahh, Crocodile Dundee :)  That takes me back :)
  The card is on IRQ 10, and I presently have just one card listed in network properties - "RealTek RTL8029(AS) PCI Ethernet NIC". As usual, Windows is saying "This device is either not present, not working properly or does not have all the drivers installed".
0
 
LVL 4

Author Comment

by:davidmwilliams
Comment Utility
 Well, sadly, the new drivers didn't work.  At least I wasn't just missing something simple, in the first instance.
  I just keep getting the same problem - the drivers install, but then the network card is flagged with the error above.  I think the clear deduction is that the drivers are not faulty; the problem is that the device itself mustn't be working properly.  Although, it seems curious that this coincided with upgrading to Windows '98 ... maybe the device had failed, but Windows '95 hadn't realised?
  In any case, thanks all for all your hard work.  I think Uillean deserves the points for all his effort and emails, if he'd like to propose an 'answer' to this.
0
 
LVL 3

Accepted Solution

by:
uilleann earned 150 total points
Comment Utility
The problem really isn't solved so if you want to reject to save your points that will be ok with me, accepting the answer that probably the card has died will also do of course but then please first try another card and see if that works ok.
Sorry i couldn't help, you know i tried ;)

Good Luck and a happy healthy new year!


0
 
LVL 4

Author Comment

by:davidmwilliams
Comment Utility
 I think you deserve the points, because even though we didn't "solve" the problem as such, you did put in a lot of work, and I think we "solved" the problem in the sense that we deduced one possibility was closed, and hence, the appropriate path to follow next.
  Have a nice new year !
0
 

Expert Comment

by:Fayolinsky
Comment Utility
This is a nightmare! I do not have any RealTek hardware but windows installed the driver anyway and now I cannot get rid of it. If I just touch anything to do with a realtek file the system crashes and a whole list of crosslinked files get displayed. I downloaded a new RealTek driver in case this was a corrupted one but it wont install because it says there is already a file of that name.
I have now re-booted and tried again, new RealTek file has gone in, will now try to remove same from add remove programmes. Hey now it seems to have worked! Rebooting, Nope there is some corruption in the AC'97 driver files and the installation cannot find the alcxwdm.sys file  AHA! it is a known WIN XP problem. Directed to Driver Guide site to download missing file No that doesn't work either...this is so darn annoying I cannot be the only one doing this.
0
 

Expert Comment

by:geoperkins
Comment Utility
The Realtek drivers for Windows 98 are very problematic.  The Realtek chips are used by a variety of manufacturers and the Realtek drivers are loaded by PnP by Windows 98.  The latest drivers for Windows 98 are available at www.realtek.com.tw, but as I said, they are problematic.  Depending on your configuration, they may work for you.   If you are running other operating systems (95, NT, 2K, XP) the drivers may be more stable (no promises).
0

Featured Post

Comprehensive Backup Solutions for Microsoft

Acronis protects the complete Microsoft technology stack: Windows Server, Windows PC, laptop and Surface data; Microsoft business applications; Microsoft Hyper-V; Azure VMs; Microsoft Windows Server 2016; Microsoft Exchange 2016 and SQL Server 2016.

Join & Write a Comment

Upper back Pain: My back hurt for months. Upper back, mostly my neck, spine and across my shoulder blades. I was getting headaches too, that felt like they were caused by tension in my shoulders, but now I feel fine! I'm sharing this hoping someone…
Every server (virtual or physical) needs a console: and the console can be provided through hardware directly connected, software for remote connections, local connections, through a KVM, etc. This document explains the different types of consol…
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.
In this tutorial you'll learn about bandwidth monitoring with flows and packet sniffing with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're interested in additional methods for monitoring bandwidt…

772 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

13 Experts available now in Live!

Get 1:1 Help Now