Solved

Printer improperly connected to computer

Posted on 1998-12-03
26
473 Views
Last Modified: 2013-12-27
The next chapter in this saga.

This is not just a problem about printing. It is a problem
of the last two weeks.

The present visual problem is that when I try to print with
my Epson Stylus Color 500, a simple letter that should
print on one page is printed piecemeal on three or four
pages. Over two weeks in trying to resolve a resource problems,
 I have been without sound, my scanner not functioning,
my internet connection, but now its just the printer. I have IRQ's available.

I am using Windows 95 version 4.00 950a. The computer is
a 200MhZ Gateway. Netscape 4.06 is the browser.

At this point, as far as I know, my problem concerns
the allocation of resources to the printer. At times the printer
has worked fine, but at those times the speakers, or scanner, or something
else didn't work properly.

When I click on file to follow with a click on  print:

The PRINT window shows up with a red x over the printer
icon, text states that the printer is off line. I have a HP scanner
(5100C) on the parrallel port with  the printer.

By clicking to  Control Panel, then the System icon,
Device Manager, I see the "yellow splat "(with exclamation point)
 on the Communications Port under Ports (COM and LPT)

Under Ports [COM & LPT]
I see three lines. The "yellow splat"
was on the first and it is explained below. I highlighted
and went to properties of the second and third line
and found no indication of a problem. These two lines
were:

Communications Port [COM1]
Printer Port [LPT1]

On both of the above, the text stated the
device is working properly.


My next step is to highlight the "yellow splat" and go
to"Commmunication Port Properties. Under the "General"
tab I see:

Devices Type Ports (COM & LPT)
Mfg (Standard Port Type)
Hardware Version   Not available

Under "Device Status" in the message
area I see:

This device has been disabled in the hardware.
In order to use this device, you must renable the
hardware. See your hardware documentation. [Code 29]

Clicking on the driver tab, I see:

c:\windows\SYSTEM\serialui.dll
c:\windows\SYSTEM\serial.uxd

Clicking on the Resource tab, I see:

Input/Output Range   02F8-02FF
Interupt Request 03

Setting Based on "Basic Configuration 0001"

Conflicting device list:

Input Output Rannge 02F8-02FF used by
 Sportster Voice 33.6 PnP FAX Internal
Interrupt Request 03 used by
Sporster Voice 33.6 PnP FAX Internal

I just sent a siimple fax, and called
to get a confirmation. It appears to
have transmitted, OK.

Where I click on the Epson 500 icon, go
to properties, I find under detail that
spool print jobs has a dot and the data format
is raw. Under graphics, driver matching is checked.

I have gone back and forth between the computer
manufacturer, the ISP people, etc. This all started
at the time I was changing to a cable connection which
required a card from a phone ISP. There were IRQ problems,
and changes to my BIOS, but the connection to cable
is working fine.

I would appreciate any recommendation you can give me.

Lou Hall

lhall1@midsouth.rr.com
0
Comment
Question by:LouHall
26 Comments
 

Expert Comment

by:steath_acid
Comment Utility
Ok removew the scanner and all of its software then in Device manager remove your printer port, and also remove you printer compleatly.  Also in your bios resore you defualts. No re install you printer and see if it works then reinstall you scanner if the printer works.  If the printer still does not work can you try iis on another computer, if so and it still does not work you might have a serios problem.  A different printer with the scanner still on there.
Hope this helps.
0
 

Author Comment

by:LouHall
Comment Utility
Thanks steath acid, but

I'll skip to the line of maybe, I have a serious problem, but if I did all of
those things you suggested, or if I was able to do "all" of them, then I
might be answering questions instead of asking. I have done most of
what you suggested, but not all within a single time frame.

Prior to now, the scanner and the printer have worked together on the parrellel
port. I believe the answer is outside of the paramater you are suggesting.

Lou

0
 
LVL 17

Expert Comment

by:xema
Comment Utility
Disable the biderctional function of the printer port, this is done under the printer propeties, details Tab, spool configuration button.
The words may be diferent I'm using the spanish Win 95 version.
0
 
LVL 1

Expert Comment

by:EMTECH
Comment Utility
WITHIN YOUR BIOS CHANGE THE PRINTER PORT SETTING FROM ECP TO EPP. THIS IS WHERE YOUR PROBLEM LIES.

GOOD LUCK....
0
 

Author Comment

by:LouHall
Comment Utility
EMTECH

Do you get to the BIOS by clicking F1 as the system is booting? If this is the
correct path, I lost my way. I could not find anything about printer port settings
there.

Can you be more specific as to how I might follow your lead?

Lou
0
 

Author Comment

by:LouHall
Comment Utility
to xema:

I followed your suggestion and found "spool print jobs so program finishes
printing faste"r checked along with "start printing after first page is spooled".

THe printer doesn't work with this setting, nor did it work with my using
"print directly to printer". I also tried check port setting before printing.

So, I'm open for any ideas.

If this isn't fixed before Monday, I'm going to reformat the works, and reload
Windows 95 along with a bunch of software. This should really create a mess.

Well, I'm checking out for today. It's almost ten p.m. where I am.

Lou


0
 
LVL 23

Expert Comment

by:Tim Holman
Comment Utility
Lou,
  Seeming it's your modem that is conflicting, do into device manager (shortcut for this is the 'windows key' + pause), remove the modem.
  Restart the machine.
  Win 95 redetects the modem and assigns it a spare IRQ ??
 
Tim
0
 
LVL 19

Expert Comment

by:cheekycj
Comment Utility
Try what tim_holman stated.

Definitely seems you need to re-assign your modem.

If Win95 doesn't automagically assign a free IRQ then you might need to
physically change some jumpers on the modem to force it to use another IRQ.

CJ
0
 
LVL 27

Expert Comment

by:Asta Cu
Comment Utility
Check your printer documentation, I have a different Epson printer, and also share parallel port.  Epson advised me that their printers do not tolerate port sharing (lpt1), if your motherboard supports it, perhaps you can use lpt2 as well for the other resource.  Also confirm what type of port setting you require.  At boot, closely watch the words, you'll see what you need to do to access your bios, some say hold DEL, others have PF function keys.  Therein should be an option to set your printer port to either normal, EPP, or ECP (lpt1 probably if that's your setup).  My epson likes EPP, the other assigns a DMA, and doesn't work.  When I had similar problems with my scanner, etc... ended up in device manager, removing all COM ports not required (if you use PS2 mouse, it typically uses IRQ 12), if that is your situation, you should be able to remove all ports (if you use normal non PS2 mouse, don't remove that com port - perhaps com1, you'd know best).  Then remove all modems, printers, scanners, anything with exclamation marks and/or problem annotations.  Then I shut down my computer completely and waited a couple of minutes before rebooting to ensure all drivers, etc. are unloaded.  Then at reboot I let Windows redetect all my stuff, had drivers handy, if not supported within Windows and was OK.  Again, there are some other issues to consider.  First, does your BIOS support Plug and Play, and if so, is it configured to know that you have a PNP OS?  Also, if you want Windows to auto-detect, and all your devices are plug and play, it should work for you.  The LPT port setting is key and your printer documentation should guide you as to its setting requirements.  One last consideration is about your modem.  I had to remove my modem jumpers which basically hard-wired controlled IRQ and Com settings, and got in the way of my set up and flexibility within Windows to control resources.  Some modems have switch settings.  All in all, from all you identify, there are clearly resource conflicts. One final thought, Windows has a way of confusing us by reporting a free IRQ to either IRQ 2 or 9, which is typically incorrect.  IRQs 2/9 are used together - that is cascaded IRQs and normally used by system components.  Often shown as free, when not.  I'd steer clear of these.  Did you check to see if there is a BOOTLOG.TXT and if it identifies any failed loads?  Good luck on this, I have total sympathy for your situation, having been there many times for many reasons.
0
 
LVL 27

Expert Comment

by:Asta Cu
Comment Utility
In conjunction with my prior comment, here is more:  When you first boot your system, watch the screen closely for instructions as to how to access your BIOS, mine is accessed by holding the DEL key.  Then choose Chipset Features, where you should see the Parallel Port information, the standard settings are 378H/IRQ7 (each system and bios is unique, but some standards apply for most) - also the parralel port mode.  I have two Epsons Inkjets, both require parallel port mode of EPP.  Neither works with the ECP setting (which requires a DMA assignment).  These settings helped me fix my printer problems, however, I could NOT SHARE THE PARALLEL PORT with SCANNER without conflicts.  The most current Epson driver I found at the Epson site for your printer is from '97 and is S50022AE.EXE.  I've included URLs, and other resource information obtained from EPSON for my own troubleshooting purposes and included it herewith.  You might benefit, if your motherboard supports it, by using LPT1 for the printer and LPT2 for the scanner, but that is unique to your environment.  You should have documentation on your computer which guides you in this regard.  Hopefully this will help you in this ongoing saga.  I did also post a note to Epson Tech Support for your Epson 500, asking that they post and confirm to me the port mode setting requirements -- I would bet that it is either normal or EPP, both would likely work, but EPP would be faster, since it is the bi-directional mode. If they respond today, I'll send you a note and copy you on the response, since you've posted your ID directly, and sound as though timing is critical.

Although I don't know exactly about your Epson Stylus 500 and its settings/requirements relative to the BIOS set up for the port, and if these resources don't help you, perhaps the Epson connection at (800) 922-8911 can confirm the port setting requirements.  Here are some bits of information I've gotten for my daughter, that may help you.

Epson Stylus 500 driver S50022AE.EXE at http://www.epson.com/support/styc500.html
Epson Stylus 500 Q&As at:  http://www.epson.com/support/faqs/inkjet/faqscl50.txt
RE: Scanner and Epson Printer: http://www.epson.com/support/instans/passthru.html
Here's some of the information from this Epson resource:
Online Technical Support - EPSON® WebAdvice™
The EPSON Connection

If you are experiencing problems printing with the printer connected to a scanner, zip drive or other external device pass-through port, try connecting the printer directly to the PC's parallel port. We do not recommend using any type of pass-through connection with our printers since it often interferes with the printer's data communication to the computer.

The best solution would be to purchase an optional bidirectional parallel adapter board to add an additional parallel port (LPT2) to your computer. Each device could then be set up separately without conflicts and you can switch between them in your software rather than switching cables or using a switch box. Parallel adapter option cards are available from most computer stores and they are inexpensive and fairly easy to install.

An A/B switch box that switches all of the pins in the printer cable from one device to the other is another possibility. It allows you to switch back and forth between the two devices as needed, however, there are many types and manufacturers, some work and some do not work. If you wish to try this method make sure you can return the switch box if it doesn't work correctly.


0
 
LVL 1

Expert Comment

by:mwakefield
Comment Utility
Well...alot of stuff here...all good advice...

1) Try changing your cmos/bios setting for the printer port (parallel port, lpt1) to SPP (Standard Parallel port)...it probably has other options such as EPP, ECP...change to SPP...

2) Plug the printer directly into the printer port on the PC...lets get the scanner out of the picture here...

3) As far as the com port goes...you may have that disabled in the cmos/bios...Win9x gets that info from the bios...so it would report that the hardware is there but disabled...or you may have a conflict...I don't think that would effect your printing though...
0
 
LVL 27

Expert Comment

by:Asta Cu
Comment Utility
To confirm my prior information:  Epson tech support responded that this printer requires a parallel port mode setting of SPP -- as you probably know, BIOS info. varies, I do not have an SPP option, the equivalent setting for me in my bios is EPP -- the ECP DMA selection (if you have this option) should be disabled.  These settings as well as the COM Port settings typically reside in the CHIPSET FEATURES SETUP option of the BIOS.  Re-reading all your information, I'd also disable all my on-board Com ports, unless you use a non PS2 mouse.  At the very least, I'd disable port 2 (where you have listed conflicting modem).  In the PNP and PCI setup option of the bios, I'd confirm that you have said YES to an option which may exist there stating that you have a PNP OS (plug and play operating system), then save the changes.  I'd then boot in SAFE MODE and right click "my computer" and choose properties to get to device manager. (Can also be accomplished by choosing start, control panel, system and device manager).  I'd remove all non-mouse COM ports (in case you are using a PS2 mouse, with round attach to port, it typically uses IRQ12) and if so, can remove all COM ports, remove lpt port(s), remove modems, remove printer, remove SCSI controllers.  I would then shutdown my system and turn everything off for a couple of minutes to ensure everything unloads.  Then ensure that all cables are checked (I assume that your modem doesn't have any jumpers forcing COM and IRQ settings -- if your modem shipped at default, it has jumper settings forcing Com2 and IRQ3, which caused me grief until I removed jumpers and let the operating system control the resource and assignments)...  Turn on external gear, printer, SCSI, etc. and reboot your system normally and let the Windows Operating System detect and add new hardware.  Recommend you have your updated driver disks handy, if you don't want to use the windows defaults, and install when requested.  

I'd then go back to device manager and check to see if any devices are listed as problems with X or !, double click and read messages should problems still exist.  I'd also confirm that in the resource settings items are selected as use auto settings.

In my case, using Adaptec 3940 and AIC78**.MPD drivers to control my SCSI, I had to update my drivers, downloaded from Adaptec's site.  Your SCSI interface may require different drivers, check your documentation, they usually provide URL for support and driver info.

So much good information provided here already, assuming you've tried prior recommendations, this information may complement and help.  Needless to say, if you've done all this stuff, and come to resolution, all this troubleshooting probably created chaos in your system, I'd run SCANDISK and DEFRAG, if you haven't already done to improve response time/performance.

Good luck.

0
 
LVL 27

Expert Comment

by:Asta Cu
Comment Utility
Prior answer provided path and most current Epson driver for your printer -- when you go to your PRINTERS panel, and add printer, point to the place where you downloaded the most recent driver to make sure that potential driver problem is resolved.  Let us know if any questions remain.Epson Stylus 500 driver S50022AE.EXE at
http://www.epson.com/support/styc500.html
0
Highfive Gives IT Their Time Back

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

 
LVL 1

Expert Comment

by:hddp666
Comment Utility
I would try yanking the scanner cable out, so that only the printer is connected to the parallel port. It may be that the scanner has a more advanced logic in communicating with the computer (bi-directional control), and is precluding any other access to the port. Turning the scanner off might do the same thing.
0
 
LVL 1

Expert Comment

by:msunder
Comment Utility
Do you know if you have a Bi-Directional Printer Cable?

If not I would get one and try it.  Sounds like it is having problems communicating a clean/single stream of data to your printer.
0
 
LVL 3

Expert Comment

by:rosefire
Comment Utility
LouHall, are you still working on this problem?
0
 
LVL 3

Expert Comment

by:rosefire
Comment Utility
I guess not.
0
 
LVL 3

Expert Comment

by:eal4
Comment Utility
The printer and the scanner are both bidirectional but will not allow each other the opportunity to talk with the computer at the same time. Two choices, install an additional printer port (LPT2) or get an AB switch box and run the unit off that. My Epson 600 and scanner did the same as yours is doing, my cure was the switch box.
0
 

Expert Comment

by:steath_acid
Comment Utility
An AB switch box can ruin you printer and/or scanner. A second printerport (even a high speede one for a scanner) would be better but it seemes that LouHall does ot care enought to coment or visit his own question.
0
 
LVL 12

Expert Comment

by:Patricia Siu-Lai Ho
Comment Utility
To LouHall,fm Dec03 till today,not hearing u anymore,how it goings. Yr problem solved after re-installation,If not,pls give a word so others experts may give you some advices. Pslh
0
 
LVL 1

Expert Comment

by:ChrisD
Comment Utility
I don't know if this has been mentioned before - but If you have been able to get into your CMOS setup - there may be an option for "Automatically assign resources (irq's etc)" This can sometimes cause problems with Win95 because the software will try to optimize the system - assigning resources the way it wants to. Whichever this is set in CMOS - change it to the oposite - enabled / disabled. try that - if it doesn't work, just change it back again.
0
 

Author Comment

by:LouHall
Comment Utility
This is a great group, but I must apologize for leaving all of you in the dark for the
past few weeks. I have been completely off line (internet). I saved, reformated,
restored, etc., then I had a two week wait for an installer to put a new S3 card in
my computer for a cable connection. I will read over the answers, then award the
points. I am going to award the 300 points to one person, even though this might
not be the fairest way, but I do not want to put the administrators of Experts to
any bother in trying to allocate them.

Just wanted to let all of you know that I didn't run away. I will get back today or
tomorrow.

Lou
0
 
LVL 5

Expert Comment

by:Jason_S
Comment Utility
So all is working now?  Ill admit, I didn't read everything here, but I have the same system as yours (basicaly) and I was able to set my LPT: port to use another IRQ (I beleive 11) in the BIOS.  This may help in your case.
0
 

Author Comment

by:LouHall
Comment Utility
To the Experts:

I have lost the true detail  in the  chronology of events. Obviously, I had an internet
connection in my "printer problem" of 12/03/98. At some point I blew things apart
when I entered a series of DOS code that I was advised would help my registry
problem. As I remember it had a bunch of letter codes, such as r_h_,etc. Whatever,
this led to much garble. At that point, I went along with the advice of saving, reformating
and reloading everything. It was misery. Examples such as: while trying to reload
Windows, I had to back off and remove the PCI card for the cable connection. Then
in trying to reload Faxworks, I had to remove the Miro Video Card. On and on, but
at this point I have my 100+ 3.5 floppys back on the system, reloaded the software
I had on CDs, downloaded Netscape 4.08. On the 29th the cable people came out
and put another type PCI card for their connection. Of course, this was on a day
that the Netscape site was having problems downloading. After seven hours of
that experience, I had only a garbled browser file. The next day I downloaded the
 15 million browser file in minutes and all appears well now.

Much of the advice was about solving the printer problem. I tried connections with
only the printer or the scanner installed. Also,Ii reloaded the software for these devices.
I have a cable that is recommened for this type of connection. Much of
the suggestions that related to the BIOS and other technical areas were a little
over my head.

I am awarding the points to "astaec" because of the specifics he included in his
recommendations. I am copying his advice, and that of others to a text file for
a later review, especially the information cited by "astaec" in making sure I
have the latest drivers. My problem wasn't just the printer. It, as I said, was
but a symptom. With reloading everything, one app at a time, then with the
new PCI card which was promoted as doing a better job with IRQ's on a
Gateway, things started looking up. Anyway the cable man suggested that
the new card he brought would solve my problem. When he came around
I had a pretty clean system. You experts were working with a novice who
was pushing a keyboard on a cluttered system.

**********************************************************************************
I would appreciated "astaec" responding with some simple comment so
that I can award him the points. Many thanks to each of you for
sticking with this, even when it appeared that I was hiding in the woodwork.
************************************************************************************

Lou

P.S.
I really like the speed of the cabel modem. It adapts itself to being
connected around the clock.

Thanks also to, steath_acid, Xema, EMTECH, cheekyj, Mwakefield, bddp666,
msunder,rosefire,ea14,pslh and Chris D




0
 
LVL 27

Accepted Solution

by:
Asta Cu earned 300 total points
Comment Utility
Thank you.  The most rewarding piece of all this is that you are up and running, I appreciate your kind words.

Experts Exchange is really a team effort, we all keep learning -- and teamwork works for us all.

Have a great '99.

(Mrs.) astaec
0
 

Author Comment

by:LouHall
Comment Utility
                     

                          All's well, that end's well. Happy New Year, All,
[OFF TOPIC]....................................... and now  with Y2K to think about in
1999, what I know, is there were many 80 column card records that I designed.
Ninty-nine per cent provided for two spaces for the four numbers of the year, but when
I was really short of room, I used the twelve levels in the card for the twelve months.
This was  far back, and I hope those data records havn't been copied  ad infinitum.
See, I used X99 to mean 11/99, as we called the level of the card just above the horizontal zeros in a card document, the X level. It took only  three positions, not six positions
to allocate space for November 1999, or 111999, or X99. Many times this was an aid
in not going to two "eighty column records" where much of the second record would
have been [no holes] blank. Then to, a cornor notch sometimes identified a record, but I don't think this is a Y2K problem.
0

Featured Post

Complete Microsoft Windows PC® & Mac Backup

Backup and recovery solutions to protect all your PCs & Mac– on-premises or in remote locations. Acronis backs up entire PC or Mac with patented reliable disk imaging technology and you will be able to restore workstations to a new, dissimilar hardware in minutes.

Join & Write a Comment

We recently endured a series of broadcast storms that caused our ISP to shut us down for brief periods of time. After going through a multitude of tests, we determined that the issue was related to Intel NIC drivers on some new HP desktop computers …
Every server (virtual or physical) needs a console: and the console can be provided through hardware directly connected, software for remote connections, local connections, through a KVM, etc. This document explains the different types of consol…
Illustrator's Shape Builder tool will let you combine shapes visually and interactively. This video shows the Mac version, but the tool works the same way in Windows. To follow along with this video, you can draw your own shapes or download the file…
This tutorial demonstrates a quick way of adding group price to multiple Magento products.

771 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

13 Experts available now in Live!

Get 1:1 Help Now