Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Need Redhat 5.2 IP Masquerade Help

Posted on 1998-12-06
4
Medium Priority
?
370 Views
Last Modified: 2013-12-15
I am trying to setup Ip Masquerading, I have followed the instructions in several how too's. My server is connected via a dial up. I have a static ip address and a domain name for this. I have been sucessful in setting up email on the work stations they can send an receive mail fine. I can telnet from a workstation to the server ok, from there I can telnet to the outside world. I just can not get the browers to see anything from the workstations.

Gill Blue
http:\\kb4fsk.com (redhat 5.2) system
0
Comment
Question by:gblue
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
4 Comments
 
LVL 2

Expert Comment

by:vx
ID: 1631820
What are your masquerading rules? Did you add any? Telnetting to your server doesn't involve masquerading.  
0
 

Accepted Solution

by:
woodson earned 150 total points
ID: 1631821
type these lines in from console or to have it done for you when you boot put these lines in a startup script

ipfwadm -F -p deny
ipfwadm -F -a m -P TCP -S192.168.1.0/24 -D0.0.0.0/0
ipfwadm -F -a m -P UDP -S192.168.1.0/24 -D0.0.0.0/0

192.168.1.0 is your network address. What I have here will masq to all machines that have ip's of 192.168.1.* as their ip address. Make each client machine's ip something like
192.168.1.2 etc
0
 

Author Comment

by:gblue
ID: 1631822
Thanks for the reply, Here's what I got so far, I was using 10.0.0.1 as my local ip address, I changed my eth0 address to 192.168.0.1

Now I tried your suggestion
ipfwadm -F -p deny Works, I get no errors

When I type ipfwadm -F -a m -P TCP -S192.168.1.0/24 -D0.0.0.0/0
I get the following error:  invalid protocol 'TCP' specified.

any suggestions ?

Gill
 
 
0
 

Expert Comment

by:woodson
ID: 1631823
gblue you have to set your linux machine to 192.168.1.*  the star
can be any number. You say that you have setup with 192.168.0.1 this will put the machine onto a different network address from the machines so make that change of course you dont have to if you keep all machines on the same network :). The next thing to do is to make the TCP and UDP tcp and udp. Put the info i gave you into
/etc/rc.d/rc.local  and make sure ipv4 is running also. Your client machines should use the linux server ip as their gateway and their ip address should be 192.168.1.*
0

Featured Post

Windows Server 2016: All you need to know

Learn about Hyper-V features that increase functionality and usability of Microsoft Windows Server 2016. Also, throughout this eBook, you’ll find some basic PowerShell examples that will help you leverage the scripts in your environments!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

If you have a server on collocation with the super-fast CPU, that doesn't mean that you get it running at full power. Here is a preamble. When doing inventory of Linux servers, that I'm administering, I've found that some of them are running on l…
Setting up Secure Ubuntu server on VMware 1.      Insert the Ubuntu Server distribution CD or attach the ISO of the CD which is in the “Datastore”. Note that it is important to install the x64 edition on servers, not the X86 editions. 2.      Power on th…
Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…
Connecting to an Amazon Linux EC2 Instance from Windows Using PuTTY.
Suggested Courses

721 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question