Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 769
  • Last Modified:

Weird boot message: "cannot open volume for direct access".

Weird boot message: "cannot open volume for direct access".

This appears under de first blue boot screen under the dots.
Can somebody help me.
0
p05010
Asked:
p05010
  • 2
  • 2
  • 2
1 Solution
 
tcalesaCommented:
Did you have a volume set created in disk administrator? I've never seen this message, but it sounds like you have more than 1 disk or partition and the volume was lost.
0
 
cognitionCommented:
This message appears because NT wants to run chkdsk on a volume, and a service or device is preventing it from running becasue the running service or device is preventing NT from locking the volume.

You can prevent it from appearing by looking in the registry

HKLM\System\CurrentControlSet\Control\Session Manager\BootExecute

The value is in binary and will probably read
autocheck autochk /r \??\C:.autocheck autochk *

change this to
autocheck autochk *

and it should stop appearing. However you do need to run chkdsk  with the /f parameter to correct changes. However this has to be done at startup, and requires the volume to be locked. I am currently struggling to get chkdsk to run as I get the same message.

The only way that I can think of doing it is to partially install another copy of NT and stop the installation once the disk has been checked.




0
 
cognitionCommented:
You may be able to get the chkdsk to run, by creating a separate hardware profile, and disabling any non essential devices, and services using the services and devices applets int he control panel.

0
Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
p05010Author Commented:
Hello Cognition,

It has indeed to do with the chkdsk, because when I want to check the system's partion It gives me a reminder that it is not possible while you logged on. So typing Yes on the question to do the job at startup.
When the pc is restarted there's no checkdisk that runs.

I will try your solution,

See ya,
P05010
0
 
p05010Author Commented:
Thks for a GOOD hint.

HKLM\System\CurrentControlSet\Control\Session Manager\BootExecute was not changed and has the following key:
autocheck autochk *

So the cause was something else. When looking in the windows knowledge base we find several issues about BootExecute.
There was also stated that ChkNTFS locks the autocheck probably by changing the registry key in: autocheck autochk /r \??\C:.autocheck autochk *
This is because ChkNTFS (invoked by an convert to NTFS) checks the partition itself. Look for it, because with the /D option you can set the behavior to the default so that checkdisk runs again with every boot (invisible ofcourse).

Try it and Do not reïnstall NT !
0
 
tcalesaCommented:
Thanks from me as well, I learn something new each day!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 2
  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now