Solved

Dial-up networking/ppp binary transmissions slowing down and freeze

Posted on 1998-12-09
11
418 Views
Last Modified: 2010-03-18
Keywords: Dial-up networking/ppp transmissions slowing down and freeze
Summary: through my best ISP - PPP binary transmissions slowing down
Program: pppd 2.3.3 - dip 3.3.7o - kernel 2.0.35
Hardware: Intel Pentium 133  16 MB RAM  Rockwell K56Flex modem  2.1 GB EIDE HD
          UART 16550A
Description: I dial into my ISP successfully but binary transmissions slow down
like images , FTP , ETC

The problem is that after I connect to my ISP and I surf the
transmissions of binary data (pictures, compressed files, etc.) is
getting
slower and slower and it goes with 242 bytes/sec - horrible at any site
at any time with any protocol.
But the ISP is working well under other OS-es and when I phoned them ,
they could only tell me that the modems are system
independently configured. (They run SunOs)
One of the other ISPs I tried runs perfectly, but the best is that I
want to fix.
!
The PPP debug from the working ISP file differs in only one thing from the
want I want to use is that the good one sets MTU to 576 no matter what
I use in ppp options file and the other one sets MTU 1500 automatically, which
can't be changed , too.
!
I use a Pentium-133 PC with a modem based on Rockwell  K56Flex Chipset.
I use 2.0.35 kernel with pppd 2.3 p3.
I use dip (since chat does not work correctly) to access my server, I
include the script at the end.
I've alredy tried:
-setting up the  ports correctly with setserial
- there's no shared IRQ, I use IRQtune to optimise the system
- setting pppd options (on and off) (like asyncmap 0 ,nobsdcomp+novj,-detach,
lock,modem,crtscts,defaultroute
noipdefault,debug
-Trying out different MTU-MRU, Window size values
- The phone line's quality is good. I always log in with >=28.8 as in
Windows.  The modem Init script is good.

Please e-mail me or post a message if you have any more suggestions.

Thanks
  ViZo - vizo@usa.net


-----------------DIP Script -------------------
       port cua1
       speed 115200
       shell setserial /dev/cua1 uart 16550A spd_vhi port 0x2F8 irq 3
       shell /sbin/irqtune
       get $mtu 1500
       netmask 255.255.255.0
       send AT&FE0V1&C1&D2S95=47S0=0\r
       # send AT&K3\r
       wait OK 5
         if $errlvl != 0 goto modem_trouble
         dial 1234567
        if $errlvl != 1 goto modem_trouble
       login:
         sleep 2
         print Waiting for login prompt...
 wait Username: 20
         send xyz\r
         wait assword: 20
         send xyz2\r
       loggedin:
         send ppp\r
         wait is 20
         get $locip remote 20
         wait is 20
         if $errlvl != 0 goto ppp_error
         print IP $rmtip
         print CONNECTED $locip
         print MTU: $mtu
         default
         mode ppp

       modem_trouble:
         print The modem connection failed
         goto error

       prompt_error:
         print TIME-OUT waiting for PPPlogin to fire up...
         goto error

       ppp:
         print time-out waitin for ppp message
         goto error

       error:
         print CONNECT FAILED to $remote
         quit 1

Expected: Stable binary transmissions speeds.
0
Comment
Question by:vizo2
11 Comments
 
LVL 2

Expert Comment

by:alexbik
ID: 1587844
Hi,

If I understand all of the above correctly, you are having trouble with one ISP, and things work well with another ISP?


0
 

Expert Comment

by:grey90
ID: 1587845
Slow down your serial port. Or upgrade your RAM. Or both!
Your machine is being flooded with information and your machine can't handle it.
Try some different,slower speeds and see what this does.

Cheers.
0
 

Author Comment

by:vizo2
ID: 1587846
I've already tried to slow down the serial ports and the connection, it doesn't use. And it doesn't explain why other ISP's do work perfectly. I'm not silly. I would change my ISP , but the one I use is free and good. Because my linux workstation
is configured now well and I want to use it for networking , too.
They use SunOs 5.6 but they can't explain the situation.
Thank you for your answer. And please help me.

ViZo
0
 

Expert Comment

by:boingone
ID: 1587847
i got same problem on my a few linux(s). excetly the same. i also want to know the answer.

thanks

0
 

Expert Comment

by:TarDar
ID: 1587848
Try dialing one of the ISPs numbers long distance.  If it speeds up, then your telco has a bad switch.  What kind of equipment is the ISP using on their end?

Also you might want to check the manual and turn data compression off.

Always add the time tested AT&F1&C1&D2

Try adding +MS=11,0,9600,33600 and try setting that last value lower and lower (i.e. 28800, 26400, 14400, 9600, etc)

But in my opinion, it's either a set of equipment that doesn't like each other (like USR and Ascend), or a telco screw up.
0
What Should I Do With This Threat Intelligence?

Are you wondering if you actually need threat intelligence? The answer is yes. We explain the basics for creating useful threat intelligence.

 

Author Comment

by:vizo2
ID: 1587849
I use the same init string as in windows the perfect fo v.34 -mnp5,..
I also tried every combination and turning off compression methods.
The starnge thing that it's working well under other OSs and I use the perfect init code.
Other local-numbered ISPs work well.
And I don't know why the hell it is working under Windows perfectly and not under Linux.
But, anyway thanks for your answer but I tried to slow down the speed at 24000 , too, while others running at 26 <= are running cool.

Thank you,
  ViZo
0
 

Author Comment

by:vizo2
ID: 1587850
the ISP use Sun Solaris 2.56 based machines with 28.8 US Robotics modems.
I think it must be a bug between the two systems.
0
 

Expert Comment

by:vladoz
ID: 1587851
Change the PPP daemon with ppp-2.3.5. This PPP work great and I think I saw kinda problem with ppp-2.3.3 and linux kernel 2.0.3x.
0
 

Author Comment

by:vizo2
ID: 1587852
I've alredy tried it (as I've written down), and it is bad with linux 2.1.1, too. It doesn't work with other systems too, with only one it does but that's the worse service.

0
 
LVL 1

Expert Comment

by:canacar
ID: 1587853
Alan Cox, who is responsible for most of the networking code
of linux, has reported a "slow network connection problem"
between linux and solaris:

http://www.uk.linux.org/NetChanges.html

He writes:
<quote>
Slow FTP Linux<->Solaris 2.4 or 2.5
     Solaris has some very bad TCP problems over slow links. Sun have now released a patch set for Solaris 2.5
     103447-03 and 103169-06 (ftp://sunsolve1.sun.com/pub/netpatches )
</quote>

also the same document mentions a problem due to MTU mismatch

<quote>
Sessions work but the first large output hangs the link
     This is often seen over SLIP links when path MTU
     discovery is used. Previously you could normally get
     away with mismatched MTU's at each end of a slip link
     to Linux boxes. With Path MTU this is no longer true.
     Fix the MTU's. Also beware of some very old terminal
     servers that mishandle MTU discovery. If so turn
     MTU discovery off or use 1500 byte+ MTU's
     on the slip link.
</quote>

The first one is related to your ISP (do they have the
patch installed?)

The second one is I think more likely in your case
you can try setting your MTU to be the same as used by
your ISP (576)

or try disabling MTU discovery
I am not sure how but
there may be a related setting in /proc
or you may have to recompile your kernel
(with relevant options)
try checking the kernel source/documentation

hope this helps...

Can


0
 
LVL 5

Accepted Solution

by:
tfabian earned 1000 total points
ID: 1587854
you can fiddle with increasing your window and buffer sizes, but for it to really make a difference, you need to get your ISP to do it too..

check out url

http://www.psc.edu/networking/perf_tune.html

for details..   it explains how you can performance tune almost any tcp implementation to achieve maximum throughput on slow networks..

good luck



0

Featured Post

What Is Threat Intelligence?

Threat intelligence is often discussed, but rarely understood. Starting with a precise definition, along with clear business goals, is essential.

Join & Write a Comment

Suggested Solutions

I have seen several blogs and forum entries elsewhere state that because NTFS volumes do not support linux ownership or permissions, they cannot be used for anonymous ftp upload through the vsftpd program.   IT can be done and here's how to get i…
Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…
Internet Business Fax to Email Made Easy - With eFax Corporate (http://www.enterprise.efax.com), you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, fr…
This video demonstrates how to create an example email signature rule for a department in a company using CodeTwo Exchange Rules. The signature will be inserted beneath users' latest emails in conversations and will be displayed in users' Sent Items…

758 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

18 Experts available now in Live!

Get 1:1 Help Now