MSVC++ V5 DEBUGGER WON'T EXECUTE

I have new install on a second machine. I copied Workspace
and Project info from old computer into corresponding
directory of the new install. I can recompile the project
on the new computer, but when I hit 'F5' to start debug , I get the
message: "Can not execute. Invalid Directory .Win32 Error 267" . This is followed by a second message:
"Can not execute program." When I locate the newly built
executable, it does execute properly. It seems to me
that the debugger itself will not run. On the Old machine
MSVC was on D: on the new machine it is on C: .
I don't see the answer in Project - Settings .
The View - Debug Windows choice shows only grayed
out choices for CallStack, Memory etc.
 What is wrong here.
mbarronAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
arunmConnect With a Mentor Commented:
Visual C++ uses sometimes uses absolute path names to identify the location of project data. This is why the project wont compile. There are 2 possible solutions:-

1) Change the project paths to be relative. There are several ways to do this and can be tricky.
2) A easier solution is to create a drive mapping to fix the problem. Using explorer create drive d: as a re-mapped drive c: Thus c: and d: will be the same drive. The program should then compile.
 
0
 
McCrearyCommented:
On the Visual C++ menu go to project/setting, hit the DEBUG tab and check the drive and path of the executable.

Also go to menu tools/options, hit the directory tab and make sure all your libraries, MFC source, includes,  everything is set to the new drive.
0
 
The_BrainCommented:
Check your menu find the
options...

go to links, and you will see include in a combo box.  there you click to see the various paths, just enter the path that your other projects are in.  This way you have the least chance of stuffing up the Drives. :0

0
 
The_BrainCommented:
Check your menu find the
options...

go to links, and you will see include in a combo box.  there you click to see the various paths, just enter the path that your other projects are in.  This way you have the least chance of stuffing up the Drives. :0

0
 
mbarronAuthor Commented:
Many Thanks,
Project,Settings,Debug,Working Directory was non-existant
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.