Configure DNS Client to connceted to the Internet

I have a SUN WKS Solaris 2.6 & try to connect to the internet.  I asked our DNS group to added my WKS to DNS.  I can use DNS in the LAN environment, but I can't connect to the internet with netscpae. I am a stand alone wks & not part of any NIS group.  The two files I configurated are NSSWITCH.CONF & RESOLV.CONF.

The configuration files for NSSWITCH.CONF & RESOLV.CONF

#
# /etc/nsswitch.files:
#
# An example file that could be copied over to /etc/nsswitch.conf; it
# does not use any naming service.
#
# "hosts:" and "services:" in this file are used only if the
# /etc/netconfig file has a "-" for nametoaddr_libs of "inet" transports.

passwd:     files
group:      files
hosts:      files dns
networks:   files
protocols:  files
rpc:        files
ethers:     files
netmasks:   files
bootparams: files
publickey:  files
# At present there isn't a 'files' backend for netgroup;  the system will
#   figure it out pretty quickly, and won't use netgroups at all.
netgroup:   files
automount:  files
aliases:    files
services:   files
sendmailvars:   files

RESOLV.CONF

domain  fmr.com
nameserver      127.0.0.1
nameserver      137.199.36.20
nameserver      155.1.1.15
nameserver      155.200.144.15
nameserver      155.1.28.22                                                    
                                                         
THX in Advance...

-VT
vctsangAsked:
Who is Participating?
 
maximumCommented:
I see a
possible problem with the configuration. The /etc/resolv.conf
file is listed:

RESOLV.CONF

   domain  fmr.com
   nameserver      127.0.0.1
   nameserver      137.199.36.20
   nameserver      155.1.1.15
   nameserver      155.200.144.15
   nameserver      155.1.28.22    

The first nameserver line points to a nameserver on the local host
(127.0.0.1).  There may not be a nameserver on the local host or it
may be misconfigured.  Try commenting out that line and see if it
works.  Also, you should test with something other than netscape.  
netscape caches DNS information, so its hard to tell if it is really
using the network to answer any particular query.  It would be better
to use ping or telnet for testing.
0
 
vctsangAuthor Commented:
Edited text of question
0
 
vctsangAuthor Commented:
Adjusted points to 100
0
Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

 
ahoffmannCommented:
Can you ping your specified nameservers?
If so, does nslookup give you IP addresses for names?
If so, can you ping these names or IP addresses?
If not you have a routing problem, post result of:
  netstat -rn
0
 
vctsangAuthor Commented:
Thanks for your response ahoffmann.

I changed the Resolv.conf to match the DNS I am using for Windows 95. I can ping all the servers with names & IPs.

# more resolv.conf
domain  fmr.com
nameserver      137.199.36.20
nameserver      155.1.1.15
nameserver      155.1.167.22

# ping 137.199.36.20
137.199.36.20 is alive
# ping 155.1.1.15
155.1.1.15 is alive
# ping 155.1.167.22
155.1.167.22 is alive

# nslookup 137.199.36.20
Server:  fddn-qns.fmr.com
Address:  137.199.36.20
Name:    fddn-qns.fmr.com
Address:  137.199.36.20
# ping fddn-qns.fmr.com
fddn-qns.fmr.com is alive

# nslookup 155.1.1.15
Server:  fddn-qns.fmr.com
Address:  137.199.36.20
Name:    fddn-tns.fmr.com
Address:  155.1.1.15
# ping fddn-tns.fmr.com
fddn-tns.fmr.com is alive

# nslookup 155.1.167.22
Server:  fddn-qns.fmr.com
Address:  137.199.36.20

Name:    fddn-ns.fmr.com
Address:  155.1.167.22

# ping fddn-ns.fmr.com
fddn-ns.fmr.com is alive

# netstat -rn  

Routing Table:
  Destination           Gateway           Flags  Ref   Use   Interface
-------------------- -------------------- ----- ----- ------ ---------
155.1.0.0            155.1.243.184         U        3      4  hme0
224.0.0.0            155.1.243.184         U        3      0  hme0
default              155.1.243.1           UG       0     12
127.0.0.1            127.0.0.1             UH       0   2260  lo0
#                                                                                                                        
0
 
ahoffmannCommented:
so, does it work now?
0
 
vctsangAuthor Commented:
No..I still having the same problem
0
 
rkuetheCommented:
Just to rule out the obvious, check for /etc/defaultdomain and /etc/defaultrouter.  Also run domainname from the command line, set your domain and see if that helps.  Maybe trying entering a site in /etc/hosts.  Are you trying to go through a firewall?
0
 
vctsangAuthor Commented:
I checked the /etc dir & I don't have a defaultdomain file.  I have the following 2 files:

Default
Defaultrouter

I tried the enter a the yahoo.com site in the host file, it failed to connect.  I am going through a firewall.
I was able to connect to the internal intranet but not the internet.   I am thinking it might be the firewals.

Thx...
-VTl


0
 
rkuetheCommented:
Can you ping your wks by name from a LAN PC?
Also run a tracert on a PC (WIN/NT command); it will show if it is going through a firewall:
tracert ahost.adomain.com
0
 
vctsangAuthor Commented:
Yes, I can ping & telnet to my Sun WKS in the LAN environment from my PC.  When I did a tracert to www.yahoo.com from my Win95 Wks I got the following Infos.



Tracing route to www5.yahoo.com [204.71.177.70]
over a maximum of 30 hops:

  1     1 ms     1 ms     1 ms  h99a.fmr.com [155.1.243.2]
  2  h99a.fmr.com [155.1.243.2]  reports: Destination host unreachable.

Trace complete.

Thx again....
-VT



0
 
arthurdCommented:
Does your site have a firewall?  Do they have a proxy server?  If so, you'll have to configure netscape to use the proxy server or have your local lan admins to punch a hole in the firewall for you.


0
 
rkuetheCommented:
arthurd is on the money, try setting up your proxy server to be:

155.1.243.2  (the http port is 8080)

That is the typical port number used (default);  to see if that port is active try:

"telnet 155.1.243.2 8080"

You can also download "traceroute" (I think gnu has it), compile and run that on the workstation.  

or try this:

/usr/sbin/ping -Rvs ahost.adomain.com

If all else fails:  (as root on your station)
snoop mystation >>/tmp/a.log.file
Try connecting again (different screen) and check the packet info in the logfile.  ****CAUTION:  LOG file will grow quickly!!!; don't forget to kill the snoop.
0
 
vctsangAuthor Commented:
I am all set.  I want to thank you both...You guys are the  greatest....Happy Holidays!!!!!!!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.