Solved

SB32 and RedHat 5.1?

Posted on 1998-12-11
9
371 Views
Last Modified: 2010-04-20

   I cant get my SB32 to work with RedHat 5.1 with Kernel 2.0.36. Please help!!!
0
Comment
Question by:dirty_al
9 Comments
 

Expert Comment

by:screwdriver
ID: 1638800
could you describe it more specific? Have you configured your kernel to support sound?

0
 

Expert Comment

by:hallstein
ID: 1638801
Get OSS - open sound system at
http://www.4front-tech.com/. Remember to get one that fits your kernel (if you have 2.0.36 - get the 2.0.36 version of it)
when downloaded run oss-install - and it detects and configures your soundcard. use soundon and soundoff to turn the sound on and off. - Good luck!
0
 

Author Comment

by:dirty_al
ID: 1638802

   I already have the OSS but as far as I can tell it is a shareware and so it just works for a limitted time and the SB32 should work with the drivers provided with the kernel as I have read in the HOWTOs and on the internet itself a lot.
   I am using isapnp to set up the card as described in the HOWTO and the Kernel is compile with all those normal options and the settings are the same as in the DOS/Windows environment.
   Any further help??
0
Simplifying Server Workload Migrations

This use case outlines the migration challenges that organizations face and how the Acronis AnyData Engine supports physical-to-physical (P2P), physical-to-virtual (P2V), virtual to physical (V2P), and cross-virtual (V2V) migration scenarios to address these challenges.

 

Expert Comment

by:hallstein
ID: 1638803
Read the documentation regarding soundcards listed in kerneldir(linux)/Documentation/README.soundcards (whatever)
you get your card modprobed i guess. i've never used anything else than oss - because i dont use time with it if dont have to :) (my isdn card is another story tho)

0
 
LVL 17

Expert Comment

by:Kent Dyer
ID: 1638804
Did you re-compile the kernel?

From /usr/src/linux ...

make mrproper;make config;make dep;make clean;make modules;make modules_install;make zImage (or zlilo).

You will then need to specify the card in make config.

-Kent
0
 

Author Comment

by:dirty_al
ID: 1638805

   I have compiled the kernel many times in order to set up my SB32 and I have tried Isapnp also and nothing seems to work, exept the OSS-driver, that works pretty good. I guess I am missing something in beetween, I just dont know where.
    I am using the same settings as in DOS mode, but I have't had any luck with my sound card at all.
    I will keep trying next year, because it's summer down here in Brazil and it's beach time till the first week of January 1999.
0
 

Expert Comment

by:hng
ID: 1638806
If you know all the settings of your SB32 (IRQ, DMA etc), then you don't need to recompile your kernel or use isapnp of that sort for Redhat 5.1. Run the program /usr/sbin/sndconfig as root. The settings presented in this setup program are usually good on first try; if not set them to the correct settings. Then sndconfig will attempt to use modprobe to insert the module. If successful, some sort of sound will be heard; if not, take note of what the complain is about. I will need the error message to figure out what is going on then.      
0
 

Author Comment

by:dirty_al
ID: 1638807

    It says that modprobe has reported an error.
0
 
LVL 1

Accepted Solution

by:
cypherpunks earned 20 total points
ID: 1638808
You will need to update your kernel.  You can get the new
one from the errata page at
http://www.redhat.com/support/docs/rhl/rh51-errata-general.html#kernel
be sure to follow all the directions that are on that page.

Your other problem may be PnP.  

The 2.0.xx kernels do not directly support the Plug and Play (PNP)
protocol. You will need to either disable PNP on the card (via jumpers or card setup tools). You can also change your boot method to use Loadlin.exe from Windows (as windows would then have set up the PNP hardware).

Finally you can try using the isapnptools programs.

Do this:
pnpdump > /etc/isapnp.conf

first.  This will create a configuration file that you will need toedit to choose the settings used. Then do isapnp /etc/isapnp.conf to set up the devices.

See http://www.roestock.demon.co.uk/isapnptools/ for more information.

I hope that this helps.


0

Featured Post

Microsoft Certification Exam 74-409

Veeam® is happy to provide the Microsoft community with a study guide prepared by MVP and MCT, Orin Thomas. This guide will take you through each of the exam objectives, helping you to prepare for and pass the examination.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

If you have a server on collocation with the super-fast CPU, that doesn't mean that you get it running at full power. Here is a preamble. When doing inventory of Linux servers, that I'm administering, I've found that some of them are running on l…
I. Introduction There's an interesting discussion going on now in an Experts Exchange Group — Attachments with no extension (http://www.experts-exchange.com/discussions/210281/Attachments-with-no-extension.html). This reminded me of questions tha…
Learn how to find files with the shell using the find and locate commands. Use locate to find a needle in a haystack.: With locate, check if the file still exists.: Use find to get the actual location of the file.:
Learn how to navigate the file tree with the shell. Use pwd to print the current working directory: Use ls to list a directory's contents: Use cd to change to a new directory: Use wildcards instead of typing out long directory names: Use ../ to move…

815 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

11 Experts available now in Live!

Get 1:1 Help Now