Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

x windows mouse setup (Slackware)

Posted on 1998-12-11
5
Medium Priority
?
383 Views
Last Modified: 2013-12-15
I have a 3 button "Digital Edge" mouse and I am trying to set it up within XF86Config. The best working setup is using a Microsoft driver however this still has the problem that when testing it the buttons work the right to left and vice versa works but I cannot move the cursor up and down. It is a serial mouse on com port 1 there appears to be no interrupt problems with com 3 as on start up this is moved to IRQ 11. Any ideas would be gratefully received....
0
Comment
Question by:paped
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
5 Comments
 
LVL 4

Expert Comment

by:swwelsh
ID: 1631862
Is gpm running on the console?  Sometimes you have to disable gpm before your mouse will work right in X (gpm -k). Is there a slider switch on the bottom of the mouse? If so, you can usually switch it from MS to PC, use the mouse systems protocol, and get the use of the middle button (win95 won't like this setting, however)
0
 

Author Comment

by:paped
ID: 1631863
I am not running GPM server on the system and the mouse does not have a switch as it should automatically sence the driver and work with either MS or mouse systems drivers.
0
 

Expert Comment

by:kane7279
ID: 1631864
Is the mouse running OK before you go into X?  I was having a problem with my mouse until I ran gpmconfig.  After that I had to set up the mouse under X.
0
 

Expert Comment

by:olvo
ID: 1631865
There is a mouseconfig tool, so you don't need to run XFConfig. I always had problems trying to run GPM, X and a mouse in the serial port. Killing gpm helped.
0
 
LVL 1

Accepted Solution

by:
cox earned 300 total points
ID: 1631866
in the file /etc/rc.d/rc.local

you have to take off the parameter : -R

to share data in X mode and console mode, but its doesnt work.

its a bug of GPM, you can read about this : man gpm (BUGS session)


0

Featured Post

Comprehensive Backup Solutions for Microsoft

Acronis protects the complete Microsoft technology stack: Windows Server, Windows PC, laptop and Surface data; Microsoft business applications; Microsoft Hyper-V; Azure VMs; Microsoft Windows Server 2016; Microsoft Exchange 2016 and SQL Server 2016.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

The purpose of this article is to fix the unknown display problem in Linux Mint operating system. After installing the OS if you see Display monitor is not recognized then we can install "MESA" utilities to fix this problem or we can install additio…
Join Greg Farro and Ethan Banks from Packet Pushers (http://packetpushers.net/podcast/podcasts/pq-show-93-smart-network-monitoring-paessler-sponsored/) and Greg Ross from Paessler (https://www.paessler.com/prtg) for a discussion about smart network …
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.
Suggested Courses

721 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question