PnP PCI Ethernet card.

Well I guess I'm kinda double screwed here. I've got a PCI Ethernet card that's also PnP. No onboard jumpers or software to shut off PnP on the ethernet card. It's NE2000 compatible, compiled into the kernel and all. I just have no idea how to get Linux to recognize it. Suggestions on setup/software needed to get this thing working?

BTW It's a D-Link 530TX.
jguerinAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
wqclatreConnect With a Mentor Commented:
A dlink dfe530TX..

I think that there is a dec21140 chip on that card. (And they are very good)

I think you shall use the tulip driver insted of NE2000.

Enable this when you complie the kernel:

[*] PCI Ethernet adapters
<*> DECchip Tulip (dc21x4x) PCI support  

Good luck!

0
 
jguerinAuthor Commented:
Edited text of question
0
 
wqclatreCommented:
A dlink dfe530TX..

I think that there is a dec21140 chip on that card. (And they are very good)

I think you shall use the tulip driver insted of NE2000.

Enable this when you complie the kernel:

[*] PCI Ethernet adapters
<*> DECchip Tulip (dc21x4x) PCI support  

Good luck!

0
 
jguerinAuthor Commented:
Ok... so after I recompile the kernel... then what? Where do I put the configuration info for the card (and how do I find it?)?
BTW when the system is booting up, I get a whole mess of Warning : unknown PCI device at < x : y > or something of the sort... "read /include/pci.h". I take a look at it, but there isn't really much to read inside of pci.h. Part of the problem?
0
 
wqclatreCommented:
Dou you have more than one card? I thin'k that the kernel will autoprobe for one card. I think that youre problem will disapear with the tulip driver.

You can add a row like:

append="ether=12,0x7800,eth0 ether=5,0xf780,eth1"  

in your /etc/lilo.conf (And run /sbin/lilo) to give the eth0 card irq 12 and io 7800 and eth1 irq5 and io-adress 0xf7870

You can do a
cat /proc/pci
cat /proc/ioports
cat /proc/interrupts

To check that you does not have 2 things at the same irq / io

0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.