Solved

Easy: mailto problem in Internet Explorer

Posted on 1998-12-11
14
259 Views
Last Modified: 2010-04-09
How come I can't get a simple mailto: working in IE4? eg mailto:fred@isp.com
0
Comment
Question by:BigJ
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 2
  • 2
  • +4
14 Comments
 
LVL 3

Expert Comment

by:a111a111a111
ID: 1840513
<A HREF="mailto:fred@isp.com">E-mail</a>

0
 
LVL 2

Author Comment

by:BigJ
ID: 1840514
The question's not how to write a mailto: but why it doesn't work in IE4. When testing I get an error - "mailto: is not a valid hostname or IP address" How can I get it to work in IE4?
0
 
LVL 4

Expert Comment

by:ruperts
ID: 1840515
It does work, can you put the link on this site!

I use ie4 and I have no probs...

0
Secure Your WordPress Site: 5 Essential Approaches

WordPress is the web's most popular CMS, but its dominance also makes it a target for attackers. Our eBook will show you how to:

Prevent costly exploits of core and plugin vulnerabilities
Repel automated attacks
Lock down your dashboard, secure your code, and protect your users

 
LVL 2

Author Comment

by:BigJ
ID: 1840516
ruperts, could you try the links at http://www.wr.com.au/~ja/cv/details.htm and let me know if you have success with IE4 - maybe I need to change some settings in my program...
0
 
LVL 2

Expert Comment

by:vendrig
ID: 1840517
It does work, BigJ... MSIE4.0, version 4.72.3110
So your problem may be your own browser/mailprog config.
0
 
LVL 3

Expert Comment

by:a111a111a111
ID: 1840518
<A HREF="mailto:fred@isp.com">E-mail</a>
0
 
LVL 4

Expert Comment

by:ruperts
ID: 1840519
mmm.

Just installed Netscape 4.? and it doesn't like mailto either, (not just yours). I didn't installed communicator as the mail package, prehaps that is a problem. What mail package do you use and have you tried clicking on other mailto's on other sites?

I use Outlook and your mailto works fine with MSIE4.
0
 
LVL 2

Author Comment

by:BigJ
ID: 1840520
I think it's a Windows setting. I took a look at Explorer/View/Options/File Types and there is no entry for "URL:mailto" but there are others for things like "URL:File protocol".

IF someone could tell me the typical settings for Netscape and IE that would be great.
0
 
LVL 2

Expert Comment

by:vendrig
ID: 1840521
On my system the "URL:mailto" entry refers to a program I don't use anymore, so I doubt it will help. However, for MSIE4 you can set your mail program in View|Internet Options|Programs, have you done that?
0
 

Expert Comment

by:java_kevin
ID: 1840522
I don't have IE4 sorry. But could it be that on your computer, you don't have any email software installed? If you have any, you may need to configure IE to use them as vendrig said. Such problem may occur when you originally had some email software installed but you removed them.

For NS, I think if you are using non-email package, you can't email at all.
However, you set your emial program eg eudora to work in background ie open it and minimise it, you can send emails using mailto:

There are other mailto links which you can try to see if your link is the problem. If theirs can and coding is similar to your, the problem is with your configuration.
0
 
LVL 2

Author Comment

by:BigJ
ID: 1840523
It's definitely a setup thing. I have 2 computers, one with IE and one with both IE and Netscape communicator. IE doesn't work with mailto's on either computer, but NS does.

The one I'm using now doesn't have IE so I can't check the mail settings. I 'll take a look next week when I'm back in the office.


Thanks for all your comments folks, but I don't see this one getting fixed easily...
0
 
LVL 2

Author Comment

by:BigJ
ID: 1840524
Stop press - No, I do have IE on this one!! I looked at options to set the mail program but There is an empty list and I cannot add to it by typing....
0
 

Expert Comment

by:bs316
ID: 1840525
for ie4 maybe you can try the toolbar
view --> internet option

^programs^ tab and change the email program

if it work and you want to give me the point, i will then post a empty message to collect the points
0
 
LVL 10

Accepted Solution

by:
MasseyM earned 50 total points
ID: 1840526
Open your Windows Explorer.  Choose View/Folder Options/File types Tab\ and locate the URL:mailto Protocol.  Choose edit. then click open. Choose Edit from below it and see what it says in "applicaiton used to perform action".  This is what mine says:
"D:\Program Files\Microsoft Office\Office\outlook.exe" -c IPM.Note /m "%1"

the %1 is the text that will go to the message.  use DDE is unchecked.  

that should fix the problem for you.
0

Featured Post

Why Off-Site Backups Are The Only Way To Go

You are probably backing up your data—but how and where? Ransomware is on the rise and there are variants that specifically target backups. Read on to discover why off-site is the way to go.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article describes how to create custom column layout styles for Bootstrap. The article uses 5 columns to illustrate the concept, but the principle can be extended to any number of columns.
Finding original email is quite difficult due to their duplicates. From this article, you will come to know why multiple duplicates of same emails appear and how to delete duplicate emails from Outlook securely and instantly while vital emails remai…
The viewer will the learn the benefit of plain text editors and code an HTML5 based template for use in further tutorials.
The viewer will learn the basics of jQuery including how to code hide show and toggles. Reference your jQuery libraries: (CODE) Include your new external js/jQuery file: (CODE) Write your first lines of code to setup your site for jQuery…

728 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question