• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1031
  • Last Modified:

Win98 LAN Network Setup

I have 2 win98 PCs each with an Intel 10/100Mb NIC, each connected to a 3Com 8-port TPO 10/100Mb EtherLink Hub.  I have assigned 10.1.1.1, 10.1.1.2 with 10.1.1.1 as the gateway.   I'm trying to use TCP/IP between them, to simply share a printer, then to play games later.  I've configured IPX and NetBUI on both.  I can see my workgroup on each machine, and the machine itself and can ping itself, but not the other PC.  However, I cannot see the other machine on either one.  Hub shows a link lites, with an Alert (!) lit.  What am I missing in this setup, or, what have I done wrong?  Thanks in advance.
0
bryanjones
Asked:
bryanjones
1 Solution
 
bryanjonesAuthor Commented:
Edited text of question
0
 
fatalerror080298Commented:
Try setting your "server" machine as 192.168.0.1 and your "client" machine as 192.168.0.2....  Not sure but I don't think you can use the 10.1.1.1....  Let me know if this helps at all...  I have a setup with 4 machines and I am not having any problems....  About the Hub having an "Alert" light lit...  Mine doesn't have that so I don't know....

Another thing is, if you have both machines hooked into the hub and not directly connected make sure that the cables you are using are NOT cross over cables...  If they are using a cross over cable then you could connected them directly w/o the hub....
0
 
shadowlord42Commented:
One thing you may want to try, as opposed to 10.1.1.1, is this:
Use 10.0.0.x and 10.0.0.y.  Choose one of the machines' addresses (preferrably the one that is working) as the gateway address and set that address as the default gateway on the other machine.  This will allow both machines to see each other.  This has worked for me in the past many times, including on my home PC.  The problem you may have is that you do not have an actual computer with an address of 10.1.1.1 as the gateway (a gateway is a gateway, afterall, and not just some virtual number we use to break up the network. . . . in other words. . . you need to have a gateway in order for your system to work).
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
TracerBulletsCommented:
Several ways to do what you ask.  
First if you have NetBUI, IPX and TCP/IP protocal you could just
use NetBUI, IPX (share files and printer) rather than TCP/IP.  
A: both computers are in the same Workgroup.  On your desktop
right click on Network Neighborhood, click Properties, select
Identification tab.  Verify on both machines you do indeed have
them in the same workgroup (if one computer says HOME, the
other PC should say HOME)  B: Now select the Configuration tab.
Click on IPX/SPX, than Properties, select the Advanced tab.
Highlight Frame Type, and change the Value from Auto to
Ethernet 802.3 (do this to both machines).  Remove all those
TCP/IP settings you have i.e. 10.1.1.1, 10.1.1.2 etc (which btw
are invalid).  Reboot both machines.  You'll be Quakin' on both
machines in no time.  Now if you want to do TCP/IP only, it's just
as simple, but try this first.  FYI - I have a IBM Laptop crossover
cabled to my Desktop with printer attached, both see and print
fine.
Hope it helps;-)
-Tracer

0
 
bryanjonesAuthor Commented:
This use of an ip address is not the issue
0
 
gaestarCommented:
First of all, try another cable on the hub to be sure there is no cable failure.  Use your installation disk to check in dos mode if the test is working properly.  If it doesn't and there is no resources conflicts, try an other card, it's probably and defect card.

2° go to control panel , system , device manager to check if 2 network cards are OK.
   If you have a resource confict, use your installation disks in dos mode to change irq, and memory adress untils there are no more resources conflicts.
 
3°  be sure you have the last driver version ( for win98) for your 2 networks cards.  If you don't , find it , desinstall, reboot, and reinstall drivers.
4°  Why do you put a gateway ?  Your 2 computers are in the same subnet, you don't need a gateway if you are just using a Lan.  Check your subnet mask, and put it to 255.255.255.0 to be sure.

5° in network properties, put the tcp/ip in the first place in the list of used protocols.

6° Now you can try a ping and it should work.

Good luck

0
 
bryanjonesAuthor Commented:
The problem was that I did not have the correct drivers for the NIC Cards.
0

Featured Post

Hire Technology Freelancers with Gigs

Work with freelancers specializing in everything from database administration to programming, who have proven themselves as experts in their field. Hire the best, collaborate easily, pay securely, and get projects done right.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now