Solved

Rebooting when trying to dial-up

Posted on 1998-12-12
28
206 Views
Last Modified: 2013-12-27
Here's a good one for you.
US Robotics FaxWinmodem installed, more info works well, but I get Modem not found and tells me that possibly the com port is open which is not the case. Modem installed on com3 or com4, I still have the same problem. AND when I try to connect to internet the system reboots. This is a new computer and I have installed win98.
My old modem 28.8 US robotics faxmodem installed in ISA, works well. Winmodem in PCI is where all my problems starts.
I've tried reinstalling win 98 and had deleted the modem before install with no luck, I have the same problem.
0
Comment
Question by:RogerRabbit
  • 10
  • 6
  • 5
  • +5
28 Comments
 
LVL 3

Expert Comment

by:rosefire
Comment Utility
To begin with we need to establish that you have not got a com port conflict.  You may have one even though windows says otherwise.  

What are the COM ports set to on the motherboard?
What are the COM ports set to according to window 98?
Are all unneeded COM ports disabled?
Are any conflicts shown if you run Start > accessories > system > system information?
What are the COM port and other device IRQ assigntment. Can you list  them here?

This should get us started.
0
 
LVL 7

Expert Comment

by:MATTCEI
Comment Utility
Try moving it to a different PCI slot.
0
 
LVL 27

Expert Comment

by:Asta Cu
Comment Utility
USR modems notoriously ship with jumpers, are you sure yours doesn't have jumper settings which may conflict with your environment?  I had to pull jumpers in order for my BIOS setting which pointed to PNP OS yes (plug and play operating system = yes) to allow WIndows to properly assign IRQ and com port settings.  Most of my USR Modems, including my last 33.6 Voice modem shipped with IRQ 3 and Com2 port settings via jumper.  Caused me problems, yanked jumpers, reinstalled and deleted modem and all non-mouse ports from device manager, rebooted and all was well.  Just in case you haven't check this out.
0
 
LVL 3

Expert Comment

by:a111a111a111
Comment Utility
1. Turn the PC OFF.
2. Boot into SAFE MODE and remove the MODEM from my computer.
3. Turn the PC OFF again.
4. Insert the MODEM into the PC.
5. Turn the PC on in normal mode and reinstall the Modem software.

0
 
LVL 3

Expert Comment

by:rosefire
Comment Utility
RogerRabbit, did you solve this problem on your own, or are you still working on it. We need feedback from you to get a start on this problem.

Thanks
RoseFire
0
 

Author Comment

by:RogerRabbit
Comment Utility
Tried a diff PCI slot with the same problem. No Jumpers on a winmodem from USR, check it out.

What are the COM ports set to on the motherboard? How do I get this
What are the COM ports set to according to window 98? Com1 and 2 for communication it says
Are all unneeded COM ports disabled? How?
Are any conflicts shown if you run Start > accessories > system > system information? NO
What are the COM port and other device IRQ assigntment. Can you list  them here? This is a long list. How can I list them all, cut and paste?

NOTE: I have installed a USR FAXMODEM, the real thing which works under DOS and Windows in ASI Slot and this works well but I've heard a lot of nightmares about winmodems conflicts.
I would like to solve this problem and get this thing(Winmodem) to work.

Let me thank you in advance for all the help you are giving out.

So, how do I get all this info you need?

And sorry for the delay, I have long hours during weekdays.

0
 
LVL 3

Expert Comment

by:rosefire
Comment Utility
Knowing how much detail to give is always a problem since we don't know how much the person asking a question knows.  Sorry about that.  I think this will help.

To find out how your motherboard is setting up your com ports you have to enter SETUP and configure your system settings.  Usually this is done by pressing a key early in the boot process (F2 or the delete key, for example).  Most systems will tell on the screen which key you should use. If not, you will have to read your manual or tell us the computer model and the maker of the BIOS. This is usually printed on the screen early in the boot process as welll.  The most common are Award and Phoenix.  You should disable any unused COM ports by finding their listing in SETUP and changing the IRQ and address assignements so that they don't specify a valued.  Take care, since it is possible that your mouse is on a COM port.  Write down anything you change so that you can put it back if it causes problems.  You don't have to worry about changing anything in setup until the point in time you want to save and exit.  Changes are only made at that time.  You should look around in the BIOS settings just so you learn what is there.  If any of this doesn't seem to apply, just explain why and tell us what kind of BIOS and computer you have.

If COM1 and COM 2 are unused, you can free the resouces they use by going to the COM and LPT devices on  the device manager tab at My Computer > Control Panel > System and clicking the box entitled "disable in this hardware profile" (for windows 98).  I don't rememberfor certain  if this is there in windows 95 or if it is somewhere else.  If you are using windows 95 and can't find this, let me know.  Checking this box should cause your COM ports to appear on the device manager tab with a red "x" showint they are disabled.

Every winmodem I have configured has required a little tinkering, so this is not unusual.  

The best way to get a listing of your COM port IRQs in windows 98 is to run system information which can be found at Start > PRograms > Accessories > System Tools.  Once you have this running you can select the tabs for conflicts and sharing or for IRQs and get a list of the IRQs in your system.  I don't think you can cut and paste from this screen, sorry.

I don't expect you to be able to get all of the above instructions to work the first time you try.  Give it a shot and then tell us what happened.  Getting unused COM ports out of the way is, I think, the simplest way to get a Winmodem to work when there are problems.  It will also free resouces for next time you try to add a new device.

It is possible that you can install the modem without disabling the unused ports, if you get frustrated with the above we can take a look at the IRQ assignments first and figure out what you have.

Good luck,

RoseFire
0
 
LVL 27

Expert Comment

by:Asta Cu
Comment Utility
I am able to get screen copies by sending a screen to the clipboard, for instance, and having a minimized session open in Word(for instance), and then pressing ALT plus PRINTSCRN key concurrently, and then within the word document pasting the captured screen results.  Should eliminate some work.
0
 
LVL 27

Expert Comment

by:Asta Cu
Comment Utility
You can use Wordpad or a number of other applications to do this process.
0
 

Author Comment

by:RogerRabbit
Comment Utility
Ok here's all the info I could gather, hope it will help. Note I also have a Zip drive installed.
AMD K6 Pentium 350
64mgs RAM
Video Card 3D Banshee
CDROM
Floppy
Sound card CREATIVE
MODEM as I said in ASI slot which is working. Winmoden iis not working.

I have an AWARD for the BIOS

From windows98 configuration:
Windows98 IRQ Settings

0      System timer
1      Standard 101/102-Key or Microsoft Natural Keyboard
2      Programmable interrupt controller
3      Communications Port (COM2)
4      Communications Port (COM1)
5      U.S. Robotics 56K FAX INT PnP
6      Standard Floppy Disk Controller
7      Printer Port (LPT1)
8      System CMOS/real time clock
9      Adaptec AHA-150X/1510/152X/AIC-6X60 SCSI Host Adapter
10      Creative Labs Sound Blaster PCI128
10      IRQ Holder for PCI Steering
11      IRQ Holder for PCI Steering
12      PS/2 Compatible Mouse Port
13      Numeric data processor
14      Primary IDE controller (dual fifo)
14      VIA Bus Master PCI IDE Controller
15      Secondary IDE controller (dual fifo)
15      VIA Bus Master PCI IDE Controller
======================================
Windows98 Conflicts/Sharing

IRQ 10      Creative Labs Sound Blaster PCI128
IRQ 10      IRQ Holder for PCI Steering
IRQ 14      Primary IDE controller (dual fifo)
IRQ 14      VIA Bus Master PCI IDE Controller
IRQ 15      Secondary IDE controller (dual fifo)
IRQ 15      VIA Bus Master PCI IDE Controller
============================================
From the BIOS

In PNP/PCI Configuration:
IRQ3  Legacy ISA
4     as above
5  PCI/ISA  PNP
7,9,10,11,12,14,15  same as IRQ5 settings
PCI slot 1 IRQ(right) : Auto
PCI slot 2  IRQ       : Auto
PCI slot 3  IRQ       : Auto
PCI slot 4  IRQ(left) : Auto

In Integrated Peripherals:

Onboard FDD controller: enabled
    "   serial port1  : 3F8/IRQ4
    "   serial port2  : 2F8/IRQ3
    "   UART2 mode    : Standard
    "   parallel port : 378/IRQ7

In Power management setup:

IRQ3 (com2) Primary
   4 (com1) primary
   5 (LPT2) primary
   6 (floppy) primary
   7 (LPT2) primary
   8 (RTC alarm) disabled
   9 (IRQ2 Redir) secondary
  10 (reserved) secondary
  12 (PS/2 mouse) primary
  13 (coprocessor) primary
  14 (hard disk)  primary
  15 (reserved)  disabled

Thats it, I hope this is the info you needed. If you need something else, do not hesitate to ask

thanks
0
 
LVL 7

Expert Comment

by:MATTCEI
Comment Utility
Two previously mentioned and one new 'things to try' would seem to be your best bet at this point:

rosefire: Disable Com1 and 2 in BIOS,remove in Device Manager - just for testing (if you have a mouse on either of these,do it anyway,and use keyboard commands to test the modem).

astaec: In BIOS, "Plug and Play..." to YES.

Also: Near where the above setting is,something like "Reset Configuration Data".
0
 
LVL 27

Expert Comment

by:Asta Cu
Comment Utility
Noticed IRQs 2 and 9 are used for two devices, that could be a problem, since IRQ 2 and 9 are cascaded, and frequently reported by Windows to be free, when they're not.


0
 
LVL 3

Expert Comment

by:rosefire
Comment Utility
Ok it appears that you are using COM port IRQs which may be forcing conflicts.  The data you provided is excellent.  You do have a lot of devices.  Your mouse is shown as PS/2 and unless you know the mouse is connected to a COM port, it pobably is not.  These COM ports should be disabled as I described earlier.  If you are unclear on the instructions I gave earlier, let me know.

I also noticed that you have two IDE controller channels enabled and you have a CD-ROM.  There may be an opportunity to free IRQs there, but we probably will not need to do this.  Disabling COM ports should allow your modem to fall from IRQ5 to one of IRQ4 or IRQ3 where it is more natural and standard for it (historically).

I think you will find that your PC finds your modem without much trouble when the unused COM ports are disabled on the Motherboard and in Windows as I described. I have had the problem you are having.  These USR modems and windows seem to be easily confused between the COM port settings on the MB, in windows, and what the modem drivers try to use.

Good Luck,
RoseFire
0
 
LVL 4

Expert Comment

by:istal112898
Comment Utility
make sure that COM2,COM3,COM4, and above are removed from the system properties under safe MODE.
I see that you have a conflict with the Sound card. the sound card has to be set in IRQ 5 and the Modem set to IRQ 3,10,not 5.  one thing you need to do is to go to BIOS set UP, and disable Serial Port 2. I see that it is enable, leave COM1 enable for using with the Mouse. set it to ENABLE to Reset CONFIGURATION. set configuration to Manual.,PNP OS: YES. Go to the COM of the MODEM and set all the COMS to ISA except COM1 under manual Resources set IRQ 5 to PNP for Sound Card, set the IRQ 10 to ISA. DMA1 set to ISA.set COM3 and IRQ 3 as ISA.ENABLE reset Configuration. Reboot.this should solve it. your PCI SOUND CARD is taking IRQ10 because it is being used for PNP/PCI, if you set it to ISA. the SOund card will have to go to IRQ5 therefore freeing the IRQ and the modem will move up to 10. since IRQ5 was set to PNP/PCI and IRQ 10 set to ISA. which is the USR MODEM.I will Assume that it will take COM2 and IRQ 10.

0
IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

 
LVL 4

Expert Comment

by:istal112898
Comment Utility
> DMA1 set to ISA < set it to plug and play/PCI. it has to be to PNP. not ISA.
0
 

Author Comment

by:RogerRabbit
Comment Utility
I've disabled com1 and 2 in win98 and bios, it seem to have helped since my computer does not reboot when trying to connect to internet.
By the way DMA1 is to plug and play PCI.
Now when trying to connect to internet, I get no dialtone as a message. Connection has been checked and its ok.

On the other hand I seem to have a conflict on IRQ 4 and regardless if I set it to com1 or 2 I get the same conflict as below (IRQ Holder for PCI Steering):

IRQ 4      U.S. Robotics 56K Voice Win
IRQ 4      IRQ Holder for PCI Steering
IRQ 10      Creative Labs Sound Blaster PCI128
IRQ 10      IRQ Holder for PCI Steering
IRQ 14      Primary IDE controller (dual fifo)
IRQ 14      VIA Bus Master PCI IDE Controller
IRQ 15      Secondary IDE controller (dual fifo)
IRQ 15      VIA Bus Master PCI IDE Controller

0
 
LVL 27

Expert Comment

by:Asta Cu
Comment Utility
RogerRabbit has a PS2 mouse, on IRQ 12, normal.  He should disable, as you've indicated, COM1 and COM2 in the BIOS.

These sound cards prefer IRQ 5 from my experience.  Are you creating an IRQ assignment for the soundcard in Autoexec.bat or Config.sys somehow, using an old Creative Labs diagnose or set command?



0
 
LVL 3

Expert Comment

by:rosefire
Comment Utility
The modem is now being recognized after disabling the ports as I advised.  The modem is telling your PC that it can't find a dial tone on the line.  The no dialtone message generally happens if the line is not connected properly (check this with a phone) or if the line is connected to the wrong jack on the card.  Most modems have 2 and one is for a pass-through to the phone.

This should do it.  If it doesn't let me know. We can troubleshoot the further.

RoseFire
0
 
LVL 3

Expert Comment

by:rosefire
Comment Utility
Oh yes, there is no conflict on IRQ4, 10, or 15.  The PCI holding is a normal message.  You will get one of these for every PCI device that uses an IRQ.

RoseFire
0
 
LVL 3

Expert Comment

by:rosefire
Comment Utility
I missed IRQ14 in my last note.  There is no conflict there either.

Sorry for the omission.

If you are 100%  certain your modem is connected right and it still gets no dialtone, take a look at the connectors.  They may be bad.  The modem is working and is trying to hear a dialtone on the line. It then reports that it can't find one.  With  IRQ conflicts, etc generally the modem can't be found and it won't try to detect a signal on the phone line.

RoseFire
0
 

Author Comment

by:RogerRabbit
Comment Utility
Ok, the line is connected in the proper jack and I connected a phone in the other one, I'm getting a dial tone in the phone but when I try to connect to internet I still get the same message: no dialtone. Its working well in my other modem.
By the way I've changed the default modem to winmodem in networking connection also when using one or the other modem.
0
 
LVL 3

Expert Comment

by:rosefire
Comment Utility
Does the modem have 2 jacks?
Did you try them both?
DId you inspect the connecors for damage?

Since the modem is able to say that there is no signal on the phone input wires, it is pretty likely it is either right, or the modem is broken.

A long shot would be that you have the wrong modem drivers or the line interface unit thinks it is in another country. You could try reinstalling them.

RoseFire
0
 

Author Comment

by:RogerRabbit
Comment Utility
I have tried to reinstalled with no luck.

Does the modem have 2 jacks? yes
Did you try them both? yes
DId you inspect the connecors for damage? connector is ok since its the same line I use with the other modem I have while writing this note.
The modem jack is working ok since i'm getting a tone thru the phone hooked up in the other winmodem jack.
Don't forget that its a winmodem voice 56k if this helps any.

0
 
LVL 3

Expert Comment

by:rosefire
Comment Utility
I have a winmodem 56k (no voice).  The voice part should not have any effect.  This one is puzzling because the modem hardware is what detects the dial tone signal on the line.

Let me ask this, can you here the line getting picked up either though the modem speaker or the phone on the pass-thru?  Pick up the phone just befor/after  the modem tries to and verify that there is a dial tone and that the modem is ignoring it.  If you can hear the modem pick up the line and hear the dial tone then the modem isn't detecting it.  If you picking up the line makes the modem hear the dialtone, then the modem is having a problem being recognized.

If you cord is long enough, try a different phone jack.  One person here found there modem wouldn't work on one jack in their house.

Have you uninstalled and reinstalled the modem drivers since you finally got it recognized?  This doesn't seem like it should make a difference, but....

RoseFire
0
 

Author Comment

by:RogerRabbit
Comment Utility
All I get is the modem trying to pick up the line and then hang up, after I get the "no dial tone" message.
I've tried with the phone opened and not open.
When I lsten on the phone, after the modem hangs up I can hear the dial tone in the phone again.

The phone line to the computer is connected directly in the phone co. line in the wall.
But like I said earlier, the other modem is using that same line without problem.

Couln't be other configuration on the computer.
Also this Winmodem is an OEM product,  not that it should matter but for information sake.

When trying to locate new modem, it does not pick it up. But when I go Add new hardware then it does find it. Would the problem lie there? And if it does, how could I fix this.

If you people succeed in helping me fix this problem, I won't have any choice to bring up the points to 200. I have to admit that these points are all worth it with all the help I'm getting.

I appreciate it.
0
 
LVL 3

Expert Comment

by:rosefire
Comment Utility
So at this point you know

1. that the modem is picking up the line,
2. it gets the dial tone, but it doesn't recognize that the tone is there and hangs up.  

If this is true, then I think your modem is malfunctioning. There is a possibility that the modem is configured with jumpers or in hardware  to work with the phone system in another country and it is not getting the line respons it expects.  I have no idea how you would fix this it this is in fact the case. If there is any infomration on country with your modem, or in the modem settings you might look it over.  You have diagnosed this thing pretty thoroughly, I think you have a bad modem..

You asked: When trying to locate new modem, it does not pick it up. But when I go Add new hardware then it does find it. Would the problem lie there? And if it does, how could I fix this.

This is pretty common.

Being an OEM product shouldn't really matter.

RoseFire
0
 
LVL 1

Accepted Solution

by:
penniwel earned 200 total points
Comment Utility
Hi:

  Try this:  go to MSdos Prompt....type  msd & then enter.
See what your operating system thinks the settings are your modem is using.

You can also try:  in the Systems window, double-click on the computer icon at the very top of the tree and look for IRQ conflicts.  Locate the one using the same IRQ as your modem....go back to 'system devices by connection' and remove it. (if this won't work you can always reboot & change it back).  After removing it....try accessing your modem again.  Does it now have a dial tone?

3Com *US Robotics has a "Modem Station" program which can help also.

0
 
LVL 1

Expert Comment

by:Moondancer
Comment Utility
GREETINGS!

This question was awarded, but never cleared due to the JSP-500 errors of that time.  It was "stuck" against userID -1 versus the intended expert whom you awarded.  This corrects the problem and the expert will now receive these points; points verified.

Please click on your Member Profile and select "View Question History" to navigate through any open or locked questions you may have to update and finalize them.  If you are an EE Pro user, you can also choose Power Search to find all your open questions.

This is the Community Support link, if help is needed, along with the link to All Topics which reflects many TAs recently added.  Also in the Community Support link is a question on how experts can help, if they wish, on the cleaning of old and abandoned questions.

http://www.experts-exchange.com/jsp/qList.jsp?ta=commspt
http://www.experts-exchange.com/jsp/zonesAll.jsp
 
Thank you,
Moondancer
Moderator @ Experts Exchange
0

Featured Post

How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

Join & Write a Comment

If you’re like me and you like peace and quiet, saving money, and pretty lights, then this article is for you. For financial reasons, I buy all the Cisco equipment for my home lab second-hand. The first thing to wear out is usually one of the coo…
Before I go to far, let's explain HA (High Availability) and why you should consider it.  High availability is the mechanism used to provide redundancy to any service at the same site and appears as a single service to the users of that service.  As…
In this seventh video of the Xpdf series, we discuss and demonstrate the PDFfonts utility, which lists all the fonts used in a PDF file. It does this via a command line interface, making it suitable for use in programs, scripts, batch files — any pl…
When you create an app prototype with Adobe XD, you can insert system screens -- sharing or Control Center, for example -- with just a few clicks. This video shows you how. You can take the full course on Experts Exchange at http://bit.ly/XDcourse.

763 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now