FoxPro

How can I open a FoxPro table through the FoxPro native drive in Delphi 4 ?

Andrew
andrewyuAsked:
Who is Participating?
 
dwwangConnect With a Mentor Commented:
The Foxpro drive along with delphi can not support VFP5 tables, it can only support forpro for DOS 2.5/2.6

For ASCII driver, I don't know.
0
 
dwwangCommented:
Yes, any problems?
0
 
andrewyuAuthor Commented:
It seems that I cannot use the native driver named "FoxPro" !

Andrew
0
Cloud Class® Course: Python 3 Fundamentals

This course will teach participants about installing and configuring Python, syntax, importing, statements, types, strings, booleans, files, lists, tuples, comprehensions, functions, and classes.

 
dwwangCommented:
Didn't experienced such kind of problem.

Add a alias using "Stardard" driver, then in the alias's 'Default driver', select Foxpro. Select the correct path, then every thing is OK.
0
 
andrewyuAuthor Commented:
Do you mean that I can only configure it in Delphi !

Andrew
0
 
dwwangCommented:
What do you mean?
To access databases, you must have an alias defined. You can do it in BDE Administrator/DBExplorer.
0
 
andrewyuAuthor Commented:
I know, but, where can I find 'Default driver' ?

Andrew
(I am using Delphi 4 Professional)
0
 
dwwangCommented:
I haven't used D4 Prof., but I think the BDE setup
should be the same:

In BDE administrator, select the menu Object-New..,
then select Standard, right?
So there will be a new alias in the left tree, usually named STANDARD1, right?

Select the STANDARD1, and see the right side of the windows, there will be 4 rows, as are 'Type', 'Default driver',
'Enable BCD' and 'PATH'.              ^^^^^^^^^^^^^^^

Select the 'Default driver', it is a ComboBox, drop it down and you can see foxpro there. If you can't that means D4 professional does not come along with FoxPro.
0
 
andrewyuAuthor Commented:
It is ok now, but, can it use the table of Visual FoxPro 5 ?

Thank you very much !

Andrew
0
 
andrewyuAuthor Commented:
But, how can I use ASCIIDRV ?

Andrew
0
 
andrewyuAuthor Commented:
I understand !

Thank you very much !

Andrew
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.