Browser not contacting local IIS Server

I set up the IIS web server via the NT 4.0 Option Pack. The NT server 4.0 is an isolated standalone server; that is, it is not connected to a network, although it contains a network adapter card. Once I start the IIS web, I try to bring up the default.htm page. However, neither I.E 4.0 nor Comm 4.0 can not connnect to the web server. I tried entering both the server name and IP address, but the error message returned from the browsers is "A connection with the server could not be established". I can successfully ping the IP address and the server name at the command line.
ronandersenAsked:
Who is Participating?
 
hnminhCommented:
Ron,
 I see that the IP is your only problem. Change it then everything must be fine!
Cheers and Happy New Year!
0
 
ronandersenAuthor Commented:
Please return all responses to ronandersen@hotmail.com or call Ron Andersen at 561-989-2556.
0
 
tcalesaCommented:
Have you checked the permissions for the directory you set up for the home page? are you using NT security for the site or did you allow the default guest account access to the site when installing IIS?
0
Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
mdakshuCommented:
Try typing
http://localhost
in the brower, does this work.
0
 
ronandersenAuthor Commented:
Tcalesa,

I used all defaults when setting up the server; that is, I allowed guest users to access the account. The system was set up as a domain controller, but I did not connect it to any network. I tried the same install procedures on another system, but this time it was configured as a standalone server and it was connected to a network. The browser, whcih is located on the same system, was able to connect to the server using both the IP address and servername. Why can't the browser connect to the local IIS domain controller, which is not physically connect to a network? Does the Domain Controller have to be physically connected to a network in order for the borwser, which is on the same system as the Domain Controller, to connect to the IIS?

Mdakshu,

I tried typing "localhost", which is the loop back IP, but it still failed.
0
 
ronandersenAuthor Commented:
Tcalesa,

I used all defaults when setting up the server; that is, I allowed guest users to access the account. The system was set up as a domain controller, but I did not connect it to any network. I tried the same install procedures on another system, but this time it was configured as a standalone server and it was connected to a network. The browser, which is located on the same system, was able to connect to the server using both the IP address and servername. Why can't the browser connect to the local IIS domain controller, which is not physically connect to a network? Does the Domain Controller have to be physically connected to a network in order for the borwser, which is on the same system as the Domain Controller, to connect to the IIS?

Mdakshu,

I tried typing "localhost", which is the loop back IP, but it still failed.
0
 
sweatbeastCommented:
The www site is started? You have set IIS permissions on that site? They dont conflict with NTFS permissions?
0
 
tcalesaCommented:
OK,
You set up the server as a DC. I assume you had it connected to the network during setup or created a PDC right? If it is a BDC and you installed IIS when the BDC was not connected to the network, Your installation may not have been able to add the default IIS guest account. Unless the account was created on the domain already, the BDC would not have a user ID for the IIS user and without connection to the PDC it could not have been able to add the user to the master SAM.

It's a shot in the dark, but I don't know exactly the process you used.

What you can do is tell the site to use domain user security, and try accessing again and log in as a domain user.

If I'm all wet, please post anything you can think of in terms of the configuration and the order of what you did during installing the server and IIS.

Thanks.
0
 
sugdenjCommented:
have you tried \\machinename?  by ip address?  ip address 127.0.0.1?
0
 
ronandersenAuthor Commented:
Sugdenj,

Yes, I have tried entering not only machine name, but also IP address, localhost, and 127.0.0.1. The browser still responds with "internet site not found".

Tcalesa,

I am still reviewing your feedback..
0
 
sweatbeastCommented:
Did you change default port settings for the website IP address?
Try adding the port number at the end of the webserver url
ie. http://webserver:80 where 80 is the port number
0
 
ronandersenAuthor Commented:
Tcalesa,

I set the system as a Primary Domain Controller(PDC), but it was not connected to a network during the installation. My objective is to setup my home NT server and use IIS. At home I have one computer, yet I have NT4.0 server and IIS installed. For some reason, the PDC's(at both home and at work), which is not connected to a network, browser can not connect the PDC's IIS.

I did not try this, but if I connected the system(PDC) to a network, the browser would probably connect to the IIS.
0
 
ronandersenAuthor Commented:
Sweatbeast,

I tried not only placing the port number (80)after the server name, but also I created another web site and assigned it a different IP address and port number(88). When I tried to connect using both the IP address and port number(88), it would not connect..
0
 
tcalesaCommented:
OK somehow I misunderstood and thought this was a BDC.
Here's what I read into this so far. Please make corrections if I'm wrong:

1. You installed NT server and SP3.
2. You have an ethernet network card on the server, but not plugged in.
3. The network card drivers and other networking components have been installed and configured on this server.
4. The Network card has a static IP address assigned to it.
5. You installed IIS with all defaults.
6. You don't have DNS installed, but you do use the hosts file.

I did this at home once. Here's my old server config (mostly by memory, so it may have a mistake or two).

I installed NT server on a PC with a 3com ethernet card. I set it up as a PDC, and loaded the Network card drivers, and TCPIP. I installed IIS also using the defaults. I used a HOSTS file for name resolution. It seemed to work out of the box pretty well. I did have it connected to a hub, but I think I've had it disconnected and still working.
0
 
tcalesaCommented:
ron,
I tried to duplicate this at home last night. I installed server, but no NIC as a PDC. I installed option pack 4 and could not load the server web page. I then installed and configured my 3com drivers and tcp/ip with a static address and a hosts entry for the server. It worked immediately after reboot.
0
 
ronandersenAuthor Commented:
Tcalesa,

1) You installed NT server 4.0 as a PDC and IIS with Option Pack 4.0
2) Configured the TCPIP properties and added a static IP address
3) Added your hostname and static IP address to hosts file
4) Configured your network adapter card and installed the 3com drivers

After installing your web server with the above configurations, you were able to use your browser and bring up the default web page http://<hostname>/default.htm

The more I research this issue.. the more think it is a network configuration issue, but here is what I did and it still does not work ( at home and at work ):

1) Installed NT server 4.0 as a PDC and IIS option pack 4.0(note: the system was not connect to a network during the installation nor while testing the IIS)
2) Installed the network
     - installed the adapter drivers Intel Ether Express LAN adapter
     - added static ip address 200.225.250.255
     - subnet mask: 255.255.255.0
     - default gateway: 200.225.250.255
     - added magnum as hostname and added it as the only entry in the DNS search order
     - no domain
3) Added magnum and 200.225.250.255 to the c:\winnt\system32\etc\hosts file
4) Rebooted the system
5) Started I.E. 4.0 and tried to bring up the default web page    -http://200.225.250.255/default.htm
6) Then I.E. 4.0 responded with  "Internet Explorer can not open the internet site
    http://200.225.250.255/default.htm
    A connection with the server could not be established"




0
 
hnminhCommented:
You have to change your last number of your IP add. to something else but not 255 nor 0. The address you used is an boardcast address, can not be used for any host with 255.255.255.0 netmask.
0
 
tcalesaCommented:
Leave magnum out of the DNS search order unless the server is actually running DNS. Just having the host name in the HOSTS file should be sufficient. Also, make sure the host name is in the LMHOSTS file. I'm not sure if that will make a difference in brining up the web page, but I did have the HOST specified in LMHOSTS
0
 
ronandersenAuthor Commented:
I am still working with Tcalesa, who is responding excellently! I rejected hnminh's response because he did not respond.


0
 
ronandersenAuthor Commented:
Sorry, hnminh's. When I first brought up this page, your response  section was empty. I'll give it a try.

Tcalesa,

I will place the hostname in the LMHOSTS file..


0
 
sweatbeastCommented:
Lets we determine that this is a DNS problem
At the command prompt do NSLOOKUP followed by the www server name.
If we get the correct IP back we can discount DNS as our cause.
You were probably able to ping the netbios name not the DNS name.
Let us know the result.
0
 
sweatbeastCommented:
Oh, it will prove your host file as well!
0
 
ronandersenAuthor Commented:
I placed the host name in the lmhosts file and changed the last quadinal on the ip address from 255 and 252 - IT WORKED !!!!!!!!!!!!!!!!!.

Both hnminh and tcalesa resolved the problem. Thank you very much for all you help. If it is possible, I would like to award both of you 100 points..


0
 
tcalesaCommented:
If you like, You can post a new 100 point Q in this area and call it to my attention so I can answer it.

Thanks. and I'm glad to see it worked.

Happy new year
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.