QuickRpt and Changing Report Width

I'm using QuickReport and am trying to figure out how to get the report to print on paper that is 15X11 or 17X11. It allows me to set the property on the report, but when I preview or print the report it gets cut off.  I'm using a wide carriage printer that feeds off a tractor feed, therefore the Landscape setting doesn't work for me.  Is this a Delphi or Windows problem and what am I doing wrong??? Your help will be greatly appreciated...
GGriffithAsked:
Who is Participating?
 
rpetruniConnect With a Mentor Commented:
Hi GGriffith,
you could set up report size double clicking on report, and picking up "custom", wich if i untherstand ok, you did ...
. so your problem probably is in windows - you should pick in printer properties custom page size to (that was my problem with Epson LQ, and FX series printers).
Hope this will help you...
                                         rpetruni
0
 
GGriffithAuthor Commented:
I have created a custom page within Windows, but it doesn't seem to come as an option when I go into the printer/properties option.  Any ideas on what I'm doing wrong????
0
 
rpetruniCommented:
Which printer doo you have?
                                         
0
Cloud Class® Course: Microsoft Exchange Server

The MCTS: Microsoft Exchange Server 2010 certification validates your skills in supporting the maintenance and administration of the Exchange servers in an enterprise environment. Learn everything you need to know with this course.

 
GGriffithAuthor Commented:
Okidata 393 its a wide carriage printer...and I'm trying to use the tractor feed...Again the paper is something like a 15X11 size used for accounting reports. Again thank you....

0
 
rpetruniCommented:
ok, so i installed driver for OKI ML393 ELITE printer on my system (hope this is the same you are using?), and there is CUSTOM page size ...
START - setings - printers - OKIxxxxx -- file -- properties -- Paper -- CUSTOM...
so if you really didi change your page in Delphi QReport to custom, try this and it should be OK (try to chech it once more), if not, sorry, it's too much for me then... :-(
                           
0
 
GGriffithAuthor Commented:
I think we are on the right track...Let me explain what is happing. When I go into START-SETTINGS-PRINTERS-OKIxxx-FILE-PROPERTIES-PAPER...I'm not seeing the Custom option....But when I go into the FILE option from above there is an option for server properties and it allows me to create a new form. The only problem is after I create the new form it never seems to appear as an option in any of my setups....Any ideas??? Thank you.  What Windows are you using 95,98,NT....We are currently using NT....
0
 
rpetruniCommented:
Ooooooops, sorry, when you say WINDOWS, a assumed WIN95, i will have to check for NT when i get to yob (next week), i'm using WIN95 OSR2 for workstrations (WIN98 is tooooo unstable for my taste at the moment), and NT 4.0 for servers...
Hmmmm, i think there is something i owerlooked before...you sad that when you are previewing document you get some parts of it cut off? This has nothing to doo with printer (at home i don't have any printer installed, and i could preview anything yust fine....
Could you send me a screen capture of it?
rpetruni@zg.tel.hr

0
 
GGriffithAuthor Commented:
Okay it seems to be working on Windows 95/98. But on the NT I still don't get the opportunity to select the custom page layout that you setup under server properties.  If you can some how guide me in the right direction for this, I'll be all set. Thanks again....
0
 
rpetruniCommented:
I checked today, and yes, it does not have custom page....
. i will see if there is something in registry, but i think that i don't know the answer to that question considering WIN NT, sorry...
                                              Robert
0
 
GGriffithAuthor Commented:
Thank you very much, you have been very helpful to say the least.  
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.