Force IIS to unload extension?

Is there an API call to force IIS to unload my ISAPI extension?  I tried calling TerminateExtension(HSE_TERM_MUST_UNLOAD) but, that didn't work.  If you could point me in the right direction I would appreciate it.
LVL 1
perrizoAsked:
Who is Participating?
 
mikeblasCommented:
No, there isn't a way to do this. You can reconfigure the server's caching setting, but that effects all extensions--not just yours. Plus, as you indicate, it's very bad for performance.

You can't unload extension DLLs on demand in current versions of Internet Information Server.

B ekiM
0
 
wyy_cqCommented:
1 shutdown the IIS, and restart it  :-D
2 or you can make change in the registry
set "HKEY_LOCAL_MACHINE/SYSTEM/CurrentControlSet/Services/W3SVC/Parameters/CacheExtensions"
to 0.

This will cause the DLL to be reloaded everytime it is ccessed.

0
 
perrizoAuthor Commented:
Well while I debug this would be fine but, I am not going to be debugging this app forever(hopefully).  Reloading the extension every time would be horrible for performance on the web server.  I need to do it in the code.  So I can call a function like Unload so whenever I feel like it I can force my extension to unload.
0
 
perrizoAuthor Commented:
I was afraid of that.  Do you know if it is planned for future versions of IIS? Thanks for the input.
0
 
mikeblasCommented:
I'm sorry; I'm not at liberty to comment on future versions of Microsoft products.

B ekiM


0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.