cannon bjc-610 printer can't be found: LPT1 not ready

have a canon bjc-610 bubblejet printer. after installation, it typically has worked for a time (may or may not be related to restarting the computer) and then cannot be "found"  printing a test page yields "ERROR writing to LPT1: for document test page: the device is not ready."

1) i've installed the most recent windows NT40 drivers that cannon has on their website.  (Running NT 4.00.1381 with service pac 3.)

2) ive deleted and reloaded the printers

3) most recently, the delete and reload of the printer failed to solve the problem.

Help?
ancientwizardAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
bwgerhoConnect With a Mentor Commented:
Canon is terrible about supporting NT.  Try loading an Epson LQ 2550 driver from the system.  This will also work and may help decide if it is the Canon driver or the LPT1 port.  

I too have a Canon 610 and use either the Canon driver from the NT system or the Epson driver.  I like the printer but hate the Canon support.
0
 
arunmCommented:
looks like some application or device is hogging the port. You can prove it by sending some data down the port and verify this as the problem.

On the command line type; dir > LPT1
Is the same error reported?

Also, just in case it may be worth removing any other printer drivers.
One other thing; Have you ever had a dongle attached to the system?






0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.