Conflict between 32-bit and compatibility mode drivers.

My attempt at upgrading to Win98 was a disaster.  Uninstalling corrected some problems, but I still get this message, which seems to be the main source of remaining problems: "Your multi-function device (Ali M229 PCI  BusMaster IDE Controller) has some child devices using 32-bit drivers and others using compatibiliy-mode drivers.  This configuration is not supported."  Rebooting is supposed to correct things (by using compatibility mode)but I am obviously not back to where I was before my ill-fated upgrade.  Any advice?
rleventhalAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
cdouglassConnect With a Mentor Commented:
I'll repost as an answer. Thanks.
0
 
rleventhalAuthor Commented:
Adjusted points to 150
0
 
cdouglassCommented:
Make sure you aren't loading a CDROM or other IDE driver in config.sys.
0
Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
theh95Commented:
Try this bootup your Win95 in safe mode then remove the device from device manager.  Then reboot the PC  let Win95 go in to normal mode.  It should detect the new hareware, at this time install the driver from disk or CD.  That should take care your problem, if not reject my answer.

0
 
larbelCommented:
Win95/98 does not have correct driver for newer ALI chipset motherboard, since you're using ALI removing the IDE controller might not solve your problem since Win95 would detect it as standard IDE controller.  You might have to remove the controller then reload the drive that comes with your motherboard.  Or check with your motherboard manufacturer's site to see if there's any updates.
0
 
rleventhalAuthor Commented:
I removed the Standard IDE Controller, the only item of the four under Hard Disk Controllers that did not have the exclamation point.  (And the only one Windows would let me remove.)  Rebooting brought back all the same conflicts.  The practical effect of the problem is to knock out my CD-ROM, at least I think so.  It was gone again today. I can always get it back by editing the registry, as instructed by tech support, but I haven't been able to make it stick. I went into config. sys, as suggested by another, and edited it.  My D:\ stayed it on reboot, instead of disappearing as before and the conflicts are gone. So I hope my main problem is corrected. Anyway, thanks for the suggestion.  I'm not confident this is over yet.
0
 
rleventhalAuthor Commented:
cdouglass -
Your suggestion seems to be the answer.  I am not sure how to make certain you get the credit.  I will await a message from the exchange, having just rejected the first suggestion.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.