Solved

Memory drop

Posted on 1998-12-18
9
316 Views
Last Modified: 2010-04-27
I have a fairly new home built system with a pentium 450mhz processor and 128ram. 19gig hard drives (two). My problem is  whenever I am using certain features I still get a out of memory error message. I can't understand why this is occuring. Even after closing out all unnesscesary apps this still happens. Is there anywhere in the bios to check if memory is being used correctly? Award bios july98 version. I find it hard to believe that I would still need more memory with 128 installed. win98 installed
0
Comment
Question by:airbird
9 Comments
 

Author Comment

by:airbird
ID: 1013818
Edited text of question
0
 
LVL 3

Expert Comment

by:czpczp
ID: 1013819
>> My problem is whenever I am using certain features I still get a out of memory error message.

Which features are doing this?
0
 
LVL 3

Expert Comment

by:rosefire
ID: 1013820
I have seen this before.  It may be the app itself unless you are editing large data files, and you would know this.  As was asked above, which apps?

You ask:

"Is there anywhere in the bios to check if memory is being used correctly?"

The easiest way to check your memory availablity and see what is going on is to run the system tool at My Computer > programs > accessories > system tools > system monitor.  Choose edit, add item, memory manager, disk cache size.  Windows manages the disk cache dynamically so when there is plenty of memory available you get huge disk caches.  Mine is 36MB at the moment.  When memory runs low, the cache will be reduced to make room for active programs.  I think you will find this never happens.  You can have some fun with this application looking at all kinds of system behavior.  If it is not on your system, you may have to install it from My Computer > Control Panel > add/remove software.  Select the middle tab for windows setup.  The CD will be required.

If you can give us more data, we can respond better.

Thanks,
RoseFire
0
 

Expert Comment

by:demarb
ID: 1013821
I see this on ocassion when using DOS windows under windows. Windows only allocates 1MB of memory to a dos app (that can be changed, it's just the default) so it wouldn't matter how much memory or resources you have. As czpczp and rosefire have indicated, unless we know which apps are causing the memory problem, then all we can do is guess at the problem.
0
Enterprise Mobility and BYOD For Dummies

Like “For Dummies” books, you can read this in whatever order you choose and learn about mobility and BYOD; and how to put a competitive mobile infrastructure in place. Developed for SMBs and large enterprises alike, you will find helpful use cases, planning, and implementation.

 

Expert Comment

by:sureshmovva
ID: 1013822
U can also check the memory usage in dos prompt.
type : mem /c /p
It will give a detailed list of the memory usage. Even I had this problem earlier, it was due to a memory resident virus. Although I had 64MB Ram, I couldn't run some applications. It is better U boot Ur system with a clean floppy and scan it with the latest available virus scanner. Hope this solves Ur problem,
Reply back Suresh
0
 

Expert Comment

by:demarb
ID: 1013823
airbird, how about some feedback.
0
 

Accepted Solution

by:
evansj earned 50 total points
ID: 1013824
I get this under Win95. With several apps open (open the ones you use the most), go to the My Computer Icon then select the Performance tab. It should show how much resources are available. You can have a Gig or RAM, but Windows only has a fixed amount of resources available. I've noticed that with Delphi open and my app file open, resources will drop from 90% to less than 20% - thats just one app. Your application may be using goo-gobs (that's a lot of) of resource memory. Windows 95/98 was supposed to fix this by doubling the GDI and USER heap to 128K. These two heaps are used for program storage such as desktop settings, Icons,etc, things that the program needs to run. With no apps open, it usually sits at around 90%. Apps such as Office use significant amounts of the resources. Make sure you are not using things like animated cursors, high color Icons, and have a lot of TSR's loaded. Check the startup folder and see if there are a lot of small programs being loaded - video utilities, virus checkers, CD-ROM players, Desktop Managers, etc. They will also find their way into your tray at the bottom on your taskbar. You may find that some of these items are not really needed and can be removed or moved from the startup folder to some other folder. BTW, to get to the startup folder, right click the taskbar and select properties. Then select advanced. Click the programs icon, then double click the startup folder. You will see most of what is being autoloaded. If you have 16-bit apps, check under the Boot section of the system.ini file for possible apps being loaded. Also check your win.ini file for apps in the LOAD and RUN sections. If your are unsure of what you are doing, leave them alone and live with what's there. Hope this helps.
0
 

Author Comment

by:airbird
ID: 1013825
The most likely culprits causing the memory leak seem to be mainly MS apps such as Office 97 used in conjunction with Ms Publisher or Adode Illustrator used with Photoshop. If I open to many apps I get type that goes over any other type or windows that were previously open, even after closing out the app there are latent images from whatever was open. Tried Rosefires test-My Computer > programs > accessories > system tools > system  monitor. But this does not give any clue to apps causing the problem, although the kernal process seems to top out at 100% quite a bit. This was interesting but I have used this before. This is not so much a dos problem so I am not going to persue that at this time. Also scanned with Norton anti-virus, McAfee 4.1 and AVtool pro, all negative. BUT what evansj proposes might be a key to get to the bottom of all this. I will start on this tommorow. Also I can be just cruising the net with Netscape and once in awhile the same type over type situation happens. I can be printing with my epson 800 and try to open some other program and the system almost reverts back to a win3.1 Big black type in a generic font! Wow
   
0
 

Author Comment

by:airbird
ID: 1013826
This was a good enough fix to get most things working trouble free. But on top of this I used Reg Repair 2000 available at--http://members.aol.com/wcguy06/vb.htm
It's worth taking a look at simply because it allows a complete fix of the registry without reformating your hard drive. It found about 10 registry errors and it put everything back into tip top shape. I'm not sure if the answer or the program was better but things are cruising along normally now.
0

Featured Post

Save on storage to protect fatherhood memories

You're the dad who has everything. This Father's Day, make sure your family memories are protected. My Passport Ultra has automatic backup and password protection to keep your cherished photos and videos safe. With up to 3TB, you have plenty of room to hold the adventures ahead.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

What do we know about Legacy Video Conferencing? - Full IT support needed! - Complicated systems at outrageous prices! - Intense training required! Highfive believes we need to embrace a new alternative.
Great sound, comfort and fit, excellent build quality, versatility, compatibility. These are just some of the many reasons for choosing a headset from Sennheiser.
Migrating to Microsoft Office 365 is becoming increasingly popular for organizations both large and small. If you have made the leap to Microsoft’s cloud platform, you know that you will need to create a corporate email signature for your Office 365…
With the power of JIRA, there's an unlimited number of ways you can customize it, use it and benefit from it. With that in mind, there's bound to be things that I wasn't able to cover in this course. With this summary we'll look at some places to go…

863 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

24 Experts available now in Live!

Get 1:1 Help Now